aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot/u-boot-omap3beagleboard-1.1.4
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/u-boot/u-boot-omap3beagleboard-1.1.4
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/u-boot/u-boot-omap3beagleboard-1.1.4')
-rw-r--r--recipes/u-boot/u-boot-omap3beagleboard-1.1.4/500mhz-l2enable.patch42
-rw-r--r--recipes/u-boot/u-boot-omap3beagleboard-1.1.4/armv7-a.patch11
-rw-r--r--recipes/u-boot/u-boot-omap3beagleboard-1.1.4/disable-tone-logo.patch46
-rw-r--r--recipes/u-boot/u-boot-omap3beagleboard-1.1.4/env.patch13
-rw-r--r--recipes/u-boot/u-boot-omap3beagleboard-1.1.4/name.patch13
5 files changed, 125 insertions, 0 deletions
diff --git a/recipes/u-boot/u-boot-omap3beagleboard-1.1.4/500mhz-l2enable.patch b/recipes/u-boot/u-boot-omap3beagleboard-1.1.4/500mhz-l2enable.patch
new file mode 100644
index 0000000000..0dce8f7904
--- /dev/null
+++ b/recipes/u-boot/u-boot-omap3beagleboard-1.1.4/500mhz-l2enable.patch
@@ -0,0 +1,42 @@
+--- u-boot.orig/board/omap3530beagle/clock.c
++++ u-boot/board/omap3530beagle/clock.c
+@@ -167,7 +167,7 @@ void prcm_init(void)
+ /* Getting the base address of Core DPLL param table*/
+ dpll_param_p = (dpll_param *)get_core_dpll_param();
+ /* Moving it to the right sysclk and ES rev base */
+- dpll_param_p = dpll_param_p + 2*clk_index + sil_index;
++ dpll_param_p = dpll_param_p + 3*clk_index + sil_index;
+ if(xip_safe){
+ /* CORE DPLL */
+ /* sr32(CM_CLKSEL2_EMU) set override to work when asleep */
+@@ -254,7 +254,7 @@ void prcm_init(void)
+ /* Getting the base address to MPU DPLL param table*/
+ dpll_param_p = (dpll_param *)get_mpu_dpll_param();
+ /* Moving it to the right sysclk and ES rev base */
+- dpll_param_p = dpll_param_p + 2*clk_index + sil_index;
++ dpll_param_p = dpll_param_p + 3*clk_index + sil_index;
+ /* MPU DPLL (unlocked already) */
+ sr32(CM_CLKSEL2_PLL_MPU, 0, 5, dpll_param_p->m2); /* Set M2 */
+ sr32(CM_CLKSEL1_PLL_MPU, 8, 11, dpll_param_p->m); /* Set M */
+@@ -266,7 +266,7 @@ void prcm_init(void)
+ /* Getting the base address to IVA DPLL param table*/
+ dpll_param_p = (dpll_param *)get_iva_dpll_param();
+ /* Moving it to the right sysclk and ES rev base */
+- dpll_param_p = dpll_param_p + 2*clk_index + sil_index;
++ dpll_param_p = dpll_param_p + 3*clk_index + sil_index;
+ /* IVA DPLL (set to 12*20=240MHz) */
+ sr32(CM_CLKEN_PLL_IVA2, 0, 3, PLL_STOP);
+ wait_on_value(BIT0, 0, CM_IDLEST_PLL_IVA2, LDELAY);
+--- u-boot_1_1_4_beagle.orig/cpu/omap3/cpu.c
++++ u-boot_1_1_4_beagle/cpu/omap3/cpu.c
+@@ -129,9 +129,7 @@ int cleanup_before_linux (void)
+
+ /* invalidate I-cache */
+ arm_cache_flush();
+-#ifndef CONFIG_L2_OFF
+- /* turn off L2 cache */
+- l2cache_disable();
++#ifndef CONFIG_L2_OFF
+ /* invalidate L2 cache also */
+ v7_flush_dcache_all(get_device_type());
+ #endif
diff --git a/recipes/u-boot/u-boot-omap3beagleboard-1.1.4/armv7-a.patch b/recipes/u-boot/u-boot-omap3beagleboard-1.1.4/armv7-a.patch
new file mode 100644
index 0000000000..49f8de0879
--- /dev/null
+++ b/recipes/u-boot/u-boot-omap3beagleboard-1.1.4/armv7-a.patch
@@ -0,0 +1,11 @@
+--- u-boot/cpu/omap3/config.mk-orig 2008-05-27 16:46:45.000000000 -0700
++++ u-boot/cpu/omap3/config.mk 2008-05-29 12:50:49.000000000 -0700
+@@ -23,7 +23,7 @@
+ PLATFORM_RELFLAGS += -fno-strict-aliasing -fno-common -ffixed-r8 \
+ -msoft-float
+
+-PLATFORM_CPPFLAGS += -march=armv7a
++PLATFORM_CPPFLAGS += -march=armv7-a
+ # =========================================================================
+ #
+ # Supply options according to compiler version
diff --git a/recipes/u-boot/u-boot-omap3beagleboard-1.1.4/disable-tone-logo.patch b/recipes/u-boot/u-boot-omap3beagleboard-1.1.4/disable-tone-logo.patch
new file mode 100644
index 0000000000..829a72e2d5
--- /dev/null
+++ b/recipes/u-boot/u-boot-omap3beagleboard-1.1.4/disable-tone-logo.patch
@@ -0,0 +1,46 @@
+--- u-boot.orig/board/omap3530beagle/omap3530beagle.c
++++ u-boot/board/omap3530beagle/omap3530beagle.c
+@@ -33,7 +33,7 @@
+ #include <i2c.h>
+ #include <asm/mach-types.h>
+
+-#include "beagle_logo_FNL_2.h"
++//#include "beagle_logo_FNL_2.h"
+
+ #if (CONFIG_COMMANDS & CFG_CMD_NAND) && defined(CFG_NAND_LEGACY)
+ #include <linux/mtd/nand_legacy.h>
+@@ -230,6 +230,7 @@ void s_init(void)
+ sdrc_init();
+ }
+
++#if 0
+ ushort tone[] = {
+ 0x0ce4, 0x0ce4, 0x1985, 0x1985, 0x25A1, 0x25A1, 0x30FD, 0x30FE,
+ 0x3B56, 0x3B55, 0x447A, 0x447A, 0x4C3B, 0x4C3C, 0x526D, 0x526C,
+@@ -457,6 +458,7 @@ int audio_init()
+ }
+ }
+
++
+ dss_init()
+ {
+ unsigned int i;
+@@ -586,6 +588,7 @@ dss_init()
+ udelay(1000);
+
+ }
++#endif
+
+ /*******************************************************
+ * Routine: misc_init_r
+@@ -618,8 +621,10 @@ int misc_init_r(void)
+ *((uint *) 0x49058094) = 0x00000506;
+ *((uint *) 0x49056094) = 0xF060F000;
+
++#if 0
+ dss_init();
+ audio_init();
++#endif
+
+ return (0);
+ }
diff --git a/recipes/u-boot/u-boot-omap3beagleboard-1.1.4/env.patch b/recipes/u-boot/u-boot-omap3beagleboard-1.1.4/env.patch
new file mode 100644
index 0000000000..582a6d6376
--- /dev/null
+++ b/recipes/u-boot/u-boot-omap3beagleboard-1.1.4/env.patch
@@ -0,0 +1,13 @@
+--- u-boot.orig/include/configs/omap3530beagle.h
++++ u-boot/include/configs/omap3530beagle.h
+@@ -261,8 +261,8 @@
+ #define CFG_ENV_IS_IN_NAND 1
+ #define CFG_ENV_IS_IN_ONENAND 1
+ #define CFG_ENV_IS_IN_FLASH 1
+-#define ONENAND_ENV_OFFSET 0xc0000 /* environment starts here */
+-#define SMNAND_ENV_OFFSET 0xc0000 /* environment starts here */
++#define ONENAND_ENV_OFFSET 0x260000 /* environment starts here */
++#define SMNAND_ENV_OFFSET 0x260000 /* environment starts here */
+
+ #define CFG_ENV_SECT_SIZE boot_flash_sec
+ #define CFG_ENV_OFFSET boot_flash_off
diff --git a/recipes/u-boot/u-boot-omap3beagleboard-1.1.4/name.patch b/recipes/u-boot/u-boot-omap3beagleboard-1.1.4/name.patch
new file mode 100644
index 0000000000..b854e3d146
--- /dev/null
+++ b/recipes/u-boot/u-boot-omap3beagleboard-1.1.4/name.patch
@@ -0,0 +1,13 @@
+--- u-boot/Makefile-orig 2008-05-29 14:00:30.000000000 -0700
++++ u-boot/Makefile 2008-05-29 13:59:13.000000000 -0700
+@@ -1823,8 +1823,8 @@ omap2430sdp_config : unconfig
+ omap3430sdp_config : unconfig
+ @./mkconfig $(@:_config=) arm omap3 omap3430sdp
+
+-omap3530beagle_config : unconfig
+- @./mkconfig $(@:_config=) arm omap3 omap3530beagle
++beagleboard_config : unconfig
++ @./mkconfig omap3530beagle arm omap3 omap3530beagle
+
+ #========================================================================
+ # i386