aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-01-22 11:39:36 -0700
committerTom Rini <tom_rini@mentor.com>2011-01-22 11:40:22 -0700
commit0575bd040eb65e9daba5afec3c3dd3b1ca6b6c8a (patch)
treef837439cb63afcf221c86fe3798e202019882233 /recipes/u-boot
parentb66a04703e9a2de5e772adc669bfd5487b5f777b (diff)
downloadopenembedded-0575bd040eb65e9daba5afec3c3dd3b1ca6b6c8a.tar.gz
u-boot: Fixup mini2440 and the various 'weak' problems
Based on the existing patches for other platforms. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/u-boot-git/dont-inline-weak-symbols-mini2440.patch47
-rw-r--r--recipes/u-boot/u-boot_git.bb3
2 files changed, 49 insertions, 1 deletions
diff --git a/recipes/u-boot/u-boot-git/dont-inline-weak-symbols-mini2440.patch b/recipes/u-boot/u-boot-git/dont-inline-weak-symbols-mini2440.patch
new file mode 100644
index 0000000000..14039ca8e8
--- /dev/null
+++ b/recipes/u-boot/u-boot-git/dont-inline-weak-symbols-mini2440.patch
@@ -0,0 +1,47 @@
+Patch initially created by Ron Lee and archived in OE patchwork at
+http://patchwork.openembedded.org/patch/1534/.
+
+Index: git/lib_arm/board.c
+===================================================================
+--- git.orig/lib_arm/board.c
++++ git/lib_arm/board.c
+@@ -126,19 +126,19 @@ void *sbrk (ptrdiff_t increment)
+ * May be supplied by boards if desired
+ */
+ void inline __coloured_LED_init (void) {}
+-void inline coloured_LED_init (void) __attribute__((weak, alias("__coloured_LED_init")));
++void coloured_LED_init (void) __attribute__((weak, alias("__coloured_LED_init")));
+ void inline __red_LED_on (void) {}
+-void inline red_LED_on (void) __attribute__((weak, alias("__red_LED_on")));
++void red_LED_on (void) __attribute__((weak, alias("__red_LED_on")));
+ void inline __red_LED_off(void) {}
+-void inline red_LED_off(void) __attribute__((weak, alias("__red_LED_off")));
++void red_LED_off(void) __attribute__((weak, alias("__red_LED_off")));
+ void inline __green_LED_on(void) {}
+-void inline green_LED_on(void) __attribute__((weak, alias("__green_LED_on")));
++void green_LED_on(void) __attribute__((weak, alias("__green_LED_on")));
+ void inline __green_LED_off(void) {}
+-void inline green_LED_off(void)__attribute__((weak, alias("__green_LED_off")));
++void green_LED_off(void)__attribute__((weak, alias("__green_LED_off")));
+ void inline __yellow_LED_on(void) {}
+-void inline yellow_LED_on(void)__attribute__((weak, alias("__yellow_LED_on")));
++void yellow_LED_on(void)__attribute__((weak, alias("__yellow_LED_on")));
+ void inline __yellow_LED_off(void) {}
+-void inline yellow_LED_off(void)__attribute__((weak, alias("__yellow_LED_off")));
++void yellow_LED_off(void)__attribute__((weak, alias("__yellow_LED_off")));
+
+ /************************************************************************
+ * Init Utilities *
+Index: git/common/main.c
+===================================================================
+--- git.orig/common/main.c
++++ git/common/main.c
+@@ -48,7 +48,7 @@ DECLARE_GLOBAL_DATA_PTR;
+ * Board-specific Platform code can reimplement show_boot_progress () if needed
+ */
+ void inline __show_boot_progress (int val) {}
+-void inline show_boot_progress (int val) __attribute__((weak, alias("__show_boot_progress")));
++void show_boot_progress (int val) __attribute__((weak, alias("__show_boot_progress")));
+
+ #if defined(CONFIG_BOOT_RETRY_TIME) && defined(CONFIG_RESET_TO_RETRY)
+ extern int do_reset (cmd_tbl_t *cmdtp, int flag, int argc, char *argv[]); /* for do_reset() prototype */
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index 7a3a036c93..1c2f59d437 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -1,5 +1,5 @@
require u-boot.inc
-PR ="r69"
+PR ="r70"
FILESPATHPKG =. "u-boot-git:"
@@ -290,6 +290,7 @@ SRCREV_sequoa = "cf3b41e0c1111dbb865b6e34e9f3c3d3145a6093"
SRC_URI_sequoia = "git://www.denx.de/git/u-boot.git;protocol=git;tag=cf3b41e0c1111dbb865b6e34e9f3c3d3145a6093 "
SRC_URI_mini2440 = "git://repo.or.cz/u-boot-openmoko/mini2440.git;protocol=git;branch=dev-mini2440-stable"
+SRC_URI_mini2440 += "file://dont-inline-weak-symbols-mini2440.patch"
SRCREV_mini2440 = "3516c35fb777ca959e5cadf2156a792ca10e1cff"
SRC_URI_micro2440 = "git://repo.or.cz/u-boot-openmoko/mini2440.git;protocol=git;branch=dev-mini2440-stable"