aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2010-11-19 16:02:43 +0000
committerGraeme Gregory <dp@xora.org.uk>2010-11-19 16:03:10 +0000
commit7205d3b5e967c49cc964f4121b0623fe5cea95f7 (patch)
treee82a9e93ad9d8c178b731b5f9f88f3ab702cb0ac /recipes/u-boot
parent32dcd4f48e1ba89de478e5af79b01b4bd1a9d1a7 (diff)
downloadopenembedded-7205d3b5e967c49cc964f4121b0623fe5cea95f7.tar.gz
u-boot_git.bb : update to latest for zoom2/zoom3 machines
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/files/omapzoom2/fix-default-boot.patch44
-rw-r--r--recipes/u-boot/files/omapzoom36x/0001-OMAP3-set-L1NEON-bit-in-aux-control-register.patch40
-rw-r--r--recipes/u-boot/files/omapzoom36x/fix-default-boot.patch44
-rw-r--r--recipes/u-boot/u-boot_git.bb16
4 files changed, 139 insertions, 5 deletions
diff --git a/recipes/u-boot/files/omapzoom2/fix-default-boot.patch b/recipes/u-boot/files/omapzoom2/fix-default-boot.patch
new file mode 100644
index 0000000000..4ed1901a4e
--- /dev/null
+++ b/recipes/u-boot/files/omapzoom2/fix-default-boot.patch
@@ -0,0 +1,44 @@
+Index: git/include/configs/omap3430zoom2.h
+===================================================================
+--- git.orig/include/configs/omap3430zoom2.h
++++ git/include/configs/omap3430zoom2.h
+@@ -157,7 +157,7 @@
+ #define CONFIG_EXTRA_ENV_SETTINGS \
+ "loadaddr=0x81c00000\0" \
+ "nandloadaddr=0x81000000\0" \
+-"console=ttyS3,115200n8\0" \
++"console=ttyS0,115200n8 console=tty0\0" \
+ "mmcroot=/dev/mmcblk0p2\0" \
+ "nandroot=/dev/ram0\0" \
+ "mmcargs=setenv bootargs console=${console} " \
+@@ -175,7 +175,7 @@
+ " ${kernel_nand_size};" \
+ " run nandargs;" \
+ " bootm ${nandloadaddr}\0" \
+-"autoboot=if mmc init 0; then" \
++"autoboot=if mmcinit 0; then" \
+ " run loaduimage;" \
+ " run mmcboot;" \
+ " else run nandboot;" \
+Index: git/include/configs/omap3630zoom3.h
+===================================================================
+--- git.orig/include/configs/omap3630zoom3.h
++++ git/include/configs/omap3630zoom3.h
+@@ -177,7 +177,7 @@
+ #define CONFIG_EXTRA_ENV_SETTINGS \
+ "loadaddr=0x81c00000\0" \
+ "nandloadaddr=0x81000000\0" \
+-"console=ttyS3,115200n8\0" \
++"console=ttyS0,115200n8 console=tty0\0" \
+ "mmcroot=/dev/mmcblk0p2\0" \
+ "nandroot=/dev/ram0\0" \
+ "mmcargs=setenv bootargs console=${console} " \
+@@ -195,7 +195,7 @@
+ " ${kernel_nand_size};" \
+ " run nandargs;" \
+ " bootm ${nandloadaddr}\0" \
+-"autoboot=if mmc init 0; then" \
++"autoboot=if mmcinit 0; then" \
+ " run loaduimage;" \
+ " run mmcboot;" \
+ " else run nandboot;" \
diff --git a/recipes/u-boot/files/omapzoom36x/0001-OMAP3-set-L1NEON-bit-in-aux-control-register.patch b/recipes/u-boot/files/omapzoom36x/0001-OMAP3-set-L1NEON-bit-in-aux-control-register.patch
new file mode 100644
index 0000000000..84822a717c
--- /dev/null
+++ b/recipes/u-boot/files/omapzoom36x/0001-OMAP3-set-L1NEON-bit-in-aux-control-register.patch
@@ -0,0 +1,40 @@
+From fe048d0b6db98744888ba79b6b6551d822e19edd Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Mon, 25 Jan 2010 14:31:01 +0100
+Subject: [PATCH] OMAP3: set L1NEON bit in aux control register
+
+This is required to work around ARM erratum 621766, affecting
+Cortex-A8 r1p0-3:
+
+ When a sequence of Neon load instructions is intermixed with several
+ branches, some of which are mispredicted, it is possible for the
+ processor to deadlock due to Neon loads on the speculative path not
+ being properly flushed from the Neon load queue.
+
+Also enable ASA like recent upstream u-boots do.
+
+Based on a patch from Mans Rullgard: http://www.mail-archive.com/u-boot@lists.denx.de/msg04879.html
+---
+ cpu/omap3/cpu.c | 6 ++++--
+ 1 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/cpu/omap3/cpu.c b/cpu/omap3/cpu.c
+index 54c0ecf..0f3882a 100644
+--- a/cpu/omap3/cpu.c
++++ b/cpu/omap3/cpu.c
+@@ -252,8 +252,10 @@ void setup_auxcr(int device_type, int boot_type)
+ /* r12 = AUXCR Write function and r0 value */
+ __asm__ __volatile__("mov r12, #0x3");
+ __asm__ __volatile__("mrc p15, 0, r0, c1, c0, 1");
+- /* Enabling IBE. ASA is disabled following recommendation from ARM */
+- __asm__ __volatile__("orr r0, r0, #0x40");
++ /* Enabling ASA */
++ __asm__ __volatile__("orr r0, r0, #0x10");
++ /* Enable L1NEON */
++ __asm__ __volatile__("orr r0, r0, #1<<5");
+ /* SMI instruction to call ROM Code API */
+ __asm__ __volatile__(".word 0xE1600070");
+
+--
+1.6.5
+
diff --git a/recipes/u-boot/files/omapzoom36x/fix-default-boot.patch b/recipes/u-boot/files/omapzoom36x/fix-default-boot.patch
new file mode 100644
index 0000000000..4ed1901a4e
--- /dev/null
+++ b/recipes/u-boot/files/omapzoom36x/fix-default-boot.patch
@@ -0,0 +1,44 @@
+Index: git/include/configs/omap3430zoom2.h
+===================================================================
+--- git.orig/include/configs/omap3430zoom2.h
++++ git/include/configs/omap3430zoom2.h
+@@ -157,7 +157,7 @@
+ #define CONFIG_EXTRA_ENV_SETTINGS \
+ "loadaddr=0x81c00000\0" \
+ "nandloadaddr=0x81000000\0" \
+-"console=ttyS3,115200n8\0" \
++"console=ttyS0,115200n8 console=tty0\0" \
+ "mmcroot=/dev/mmcblk0p2\0" \
+ "nandroot=/dev/ram0\0" \
+ "mmcargs=setenv bootargs console=${console} " \
+@@ -175,7 +175,7 @@
+ " ${kernel_nand_size};" \
+ " run nandargs;" \
+ " bootm ${nandloadaddr}\0" \
+-"autoboot=if mmc init 0; then" \
++"autoboot=if mmcinit 0; then" \
+ " run loaduimage;" \
+ " run mmcboot;" \
+ " else run nandboot;" \
+Index: git/include/configs/omap3630zoom3.h
+===================================================================
+--- git.orig/include/configs/omap3630zoom3.h
++++ git/include/configs/omap3630zoom3.h
+@@ -177,7 +177,7 @@
+ #define CONFIG_EXTRA_ENV_SETTINGS \
+ "loadaddr=0x81c00000\0" \
+ "nandloadaddr=0x81000000\0" \
+-"console=ttyS3,115200n8\0" \
++"console=ttyS0,115200n8 console=tty0\0" \
+ "mmcroot=/dev/mmcblk0p2\0" \
+ "nandroot=/dev/ram0\0" \
+ "mmcargs=setenv bootargs console=${console} " \
+@@ -195,7 +195,7 @@
+ " ${kernel_nand_size};" \
+ " run nandargs;" \
+ " bootm ${nandloadaddr}\0" \
+-"autoboot=if mmc init 0; then" \
++"autoboot=if mmcinit 0; then" \
+ " run loaduimage;" \
+ " run mmcboot;" \
+ " else run nandboot;" \
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index 7e61b21dd2..6f05b1767f 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -1,5 +1,5 @@
require u-boot.inc
-PR ="r65"
+PR ="r66"
FILESPATHPKG =. "u-boot-git:"
@@ -181,8 +181,10 @@ PV_omapzoom = "2009.01+${PR}+gitr${SRCREV}"
SRC_URI_omapzoom2 = "git://dev.omapzoom.org/pub/scm/bootloader/u-boot.git;branch=master;protocol=git \
file://0001-OMAP3-set-L1NEON-bit-in-aux-control-register.patch \
- file://inline-fix.patch"
-SRCREV_omapzoom2 = "78e778e0ea884306841c6499851a1e35177d81d0"
+ file://fix-default-boot.patch \
+ "
+
+SRCREV_omapzoom2 = "fbe4cef852de5a39412234b4acd47a830d0282a2"
PV_omapzoom2 = "1.1.4+${PR}+gitr${SRCREV}"
PE_omapzoom2 = "1"
@@ -195,8 +197,12 @@ do_compile_omapzoom2 () {
oe_runmake tools
}
-SRC_URI_omapzoom36x = "git://dev.omapzoom.org/pub/scm/bootloader/u-boot.git;branch=master;protocol=git"
-SRCREV_omapzoom36x = "ab45d2a787a9674bed30542139175d8e090e0749"
+SRC_URI_omapzoom36x = "git://dev.omapzoom.org/pub/scm/bootloader/u-boot.git;branch=master;protocol=git \
+ file://0001-OMAP3-set-L1NEON-bit-in-aux-control-register.patch \
+ file://fix-default-boot.patch \
+ "
+
+SRCREV_omapzoom36x = "fbe4cef852de5a39412234b4acd47a830d0282a2"
PV_omapzoom36x = "1.1.4+${PR}+gitr${SRCREV}"
PE_omapzoom36x = "1"