aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-12-23 23:11:05 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-12-24 11:46:27 +0100
commit75527d4842223cc831b2eaaed0150f28ff467014 (patch)
treeb1def2f17f07bc3db7a1ac08525ccfa09d160d69 /recipes/u-boot
parent15821fbab349368d981b6abc2d77d1f7d2a208c9 (diff)
downloadopenembedded-75527d4842223cc831b2eaaed0150f28ff467014.tar.gz
u-boot: update env for SHR on nokia900 and use better gcc fix
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/u-boot-git/nokia900/0001-configs-nokia_rx51.h-start-shr-as-default-and-change.patch88
-rw-r--r--recipes/u-boot/u-boot-git/nokia900/0001-nokia-rx51-fix-declaration-fails-when-building-with-.patch34
-rw-r--r--recipes/u-boot/u-boot-git/nokia900/0001-nokia-rx51-use-O0-as-work-around-for-gcc-4.5.patch26
-rw-r--r--recipes/u-boot/u-boot-git/nokia900/0008-configs-nokia_rx51.h-use-ext2-instead-of-fat-for-1st.patch30
-rw-r--r--recipes/u-boot/u-boot-git/nokia900/0009-configs-nokia_rx51.h-integrate-SHR-boot.scr-to-defau.patch90
-rw-r--r--recipes/u-boot/u-boot-git/nokia900/0010-configs-nokia_rx51.h-call-mmc-init-manually-because-.patch37
-rw-r--r--recipes/u-boot/u-boot-git/nokia900/0011-configs-nokia_rx51.h-don-t-set-atags-when-booting-fr.patch37
-rw-r--r--recipes/u-boot/u-boot_git.bb7
8 files changed, 124 insertions, 225 deletions
diff --git a/recipes/u-boot/u-boot-git/nokia900/0001-configs-nokia_rx51.h-start-shr-as-default-and-change.patch b/recipes/u-boot/u-boot-git/nokia900/0001-configs-nokia_rx51.h-start-shr-as-default-and-change.patch
new file mode 100644
index 0000000000..6bc91f65db
--- /dev/null
+++ b/recipes/u-boot/u-boot-git/nokia900/0001-configs-nokia_rx51.h-start-shr-as-default-and-change.patch
@@ -0,0 +1,88 @@
+From 1b46029e60f9a40aad72fabbb5a2ef57440ead97 Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Tue, 7 Dec 2010 12:41:39 +0100
+Subject: [PATCH] configs/nokia_rx51.h: start shr as default and change expected partition layout
+
+* use layout like this:
+* boot.scr: optional on 1st ext2 partition /boot.scr
+* run shr: rootfs on 1st ext2 partition and kernel in /boot/uImage
+* run shr2: rootfs on 1st partition and kernel on 3rd fat partition /uImage
+* run p2: rootfs on 2nd partition and kernel on 3rd fat partition /uImage
+* run maemo: rootfs on eMMC and kernel provided by NOLO
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ include/configs/nokia_rx51.h | 42 ++++++++++++++++++++++++++----------------
+ 1 files changed, 26 insertions(+), 16 deletions(-)
+
+diff --git a/include/configs/nokia_rx51.h b/include/configs/nokia_rx51.h
+index 5c3b068..62770c9 100644
+--- a/include/configs/nokia_rx51.h
++++ b/include/configs/nokia_rx51.h
+@@ -187,38 +187,47 @@ int rx51_kp_getc(void);
+ "usbcon=setenv con usbtty; run setcon\0" \
+ "vgacon=setenv con vga; run setcon\0" \
+ "loadaddr=0x82000000\0" \
+- "meegoargs=setenv bootargs\0" \
+- "loadbootscript=fatload mmc 0 ${loadaddr} boot.scr\0" \
++ "loadbootscript=mmc init; ext2load mmc 0:1 ${loadaddr} boot.scr\0" \
+ "bootscript=echo Running bootscript from mmc ...; " \
+ "source ${loadaddr}\0" \
+- "loaduimage=fatload mmc 0:3 ${loadaddr} uImage\0" \
+- "mmcboot=echo Booting from mmc ...; " \
+- "run meegoargs; " \
+- "bootm ${loadaddr}\0" \
+- "noloboot=echo Booting NOLO supplied kernel ...; " \
++ "meegoargs=root=/dev/mmcblk0p2 rootwait console=tty0 omapfb.vram=0:2M,1:2M,2:2M mtdoops.mtddev=2 nosplash\0" \
++ "shrargs=snd-soc-rx51.hp_lim=42 snd-soc-tlv320aic3x.hp_dac_lim=6 console=tty1 root=/dev/mmcblk1p1 rootwait panic=20 debug\0" \
++ "boot1stcmd=mmc init; ext2load mmc 0:1 0x82000000 /boot/uImage; bootm 0x82000000\0" \
++ "boot3rdcmd=mmc init; fatload mmc 0:3 0x82000000 uImage; bootm 0x82000000\0" \
++ "shr=echo Booting SHR from uSD 1st part (/boot/uImage) ...; " \
++ "setenv bootargs ${shrargs}; " \
++ "setenv bootcmd ${boot1stcmd}; " \
++ "boot\0" \
++ "shr2=echo Booting SHR from uSD 1st part, kernel on 3rd ...; " \
++ "setenv atags ${nolo_atagaddr};" \
++ "setenv bootargs ${shrargs}; " \
++ "setenv bootcmd ${boot3rdcmd}; " \
++ "boot\0" \
++ "p2=echo Booting from uSD 2nd part, kernel on 3rd ...; " \
++ "setenv bootargs ${meegoargs}; " \
++ "setenv bootcmd ${boot3rdcmd}; " \
++ "boot\0" \
++ "maemo=echo Booting Maemo from eMMC, NOLO supplied kernel ...; " \
+ "setenv atags ${nolo_atagaddr};" \
+ "bootm ${nolo_kernaddr}\0"
+
+ #define CONFIG_PREBOOT \
+- "if test $slide_sw != open ; then run noloboot; fi ;" \
++ "if test $slide_sw != open ; then run shr; fi ;" \
+ "echo Extra commands:;" \
+ "echo run sercon - Use serial port for control.;" \
+ "echo run usbcon - Use usbtty for control.;" \
+ "echo run vgacon - Use framebuffer/keyboard.;" \
+- "echo run mmcboot - Boot from SD card slot.;" \
+- "echo run noloboot - Boot kernel loaded by NOLO."
++ "echo run shr - Boot SHR from uSD 1st part (/boot/uImage).;" \
++ "echo run shr2 - Boot SHR from uSD 1st part, kernel on 3rd.;" \
++ "echo run p2 - Boot from uSD 2nd part, kernel on 3rd.;" \
++ "echo run maemo - Boot Maemo from eMMC, kernel loaded by NOLO."
+
+ #define CONFIG_BOOTCOMMAND \
+ "if mmc init; then " \
+ "if run loadbootscript; then " \
+ "run bootscript; " \
+- "else " \
+- "if run loaduimage; then " \
+- "run mmcboot; " \
+- "else run noloboot; " \
+- "fi; " \
+ "fi; " \
+- "else run noloboot; fi"
++ "else run shr; fi"
+
+ #define CONFIG_AUTO_COMPLETE 1
+ /*
+--
+1.7.3.4
+
diff --git a/recipes/u-boot/u-boot-git/nokia900/0001-nokia-rx51-fix-declaration-fails-when-building-with-.patch b/recipes/u-boot/u-boot-git/nokia900/0001-nokia-rx51-fix-declaration-fails-when-building-with-.patch
new file mode 100644
index 0000000000..53abe21d7e
--- /dev/null
+++ b/recipes/u-boot/u-boot-git/nokia900/0001-nokia-rx51-fix-declaration-fails-when-building-with-.patch
@@ -0,0 +1,34 @@
+From 6adc07f7e71cccf86eba96467ef46a9b63eb7d84 Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Thu, 23 Dec 2010 21:04:25 +0100
+Subject: [PATCH] nokia/rx51: fix declaration, fails when building with gcc-4.5
+
+* older gcc or -O0 doesn't show it, but it's code issue
+---
+ board/nokia/rx51/rx51.c | 3 +--
+ 1 files changed, 1 insertions(+), 2 deletions(-)
+
+diff --git a/board/nokia/rx51/rx51.c b/board/nokia/rx51/rx51.c
+index 347d08a..572d352 100644
+--- a/board/nokia/rx51/rx51.c
++++ b/board/nokia/rx51/rx51.c
+@@ -43,6 +43,7 @@
+ #include "rx51.h"
+
+ GraphicDevice gdev;
++DECLARE_GLOBAL_DATA_PTR;
+
+ /*
+ * Routine: board_init
+@@ -50,8 +51,6 @@ GraphicDevice gdev;
+ */
+ int board_init(void)
+ {
+- DECLARE_GLOBAL_DATA_PTR;
+-
+ gpmc_init(); /* in SRAM or SDRAM, finish GPMC */
+ /* board id for Linux */
+ gd->bd->bi_arch_number = MACH_TYPE_NOKIA_RX51;
+--
+1.7.3.4
+
diff --git a/recipes/u-boot/u-boot-git/nokia900/0001-nokia-rx51-use-O0-as-work-around-for-gcc-4.5.patch b/recipes/u-boot/u-boot-git/nokia900/0001-nokia-rx51-use-O0-as-work-around-for-gcc-4.5.patch
deleted file mode 100644
index d3e72b8072..0000000000
--- a/recipes/u-boot/u-boot-git/nokia900/0001-nokia-rx51-use-O0-as-work-around-for-gcc-4.5.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From beda5431f747669440b52c9340bda843d6440e69 Mon Sep 17 00:00:00 2001
-From: Martin Jansa <Martin.Jansa@gmail.com>
-Date: Thu, 23 Dec 2010 21:04:25 +0100
-Subject: [PATCH] nokia/rx51: use -O0 as work around for gcc-4.5
-
----
- board/nokia/rx51/Makefile | 3 +++
- 1 files changed, 3 insertions(+), 0 deletions(-)
-
-diff --git a/board/nokia/rx51/Makefile b/board/nokia/rx51/Makefile
-index 31ad6fd..986af23 100644
---- a/board/nokia/rx51/Makefile
-+++ b/board/nokia/rx51/Makefile
-@@ -23,6 +23,9 @@
-
- include $(TOPDIR)/config.mk
-
-+# gcc-4.5 breaks generated code if -O1+ or -Os is used
-+CFLAGS += -O0
-+
- LIB = $(obj)lib$(BOARD).a
-
- COBJS := rx51.o
---
-1.7.3.4
-
diff --git a/recipes/u-boot/u-boot-git/nokia900/0008-configs-nokia_rx51.h-use-ext2-instead-of-fat-for-1st.patch b/recipes/u-boot/u-boot-git/nokia900/0008-configs-nokia_rx51.h-use-ext2-instead-of-fat-for-1st.patch
deleted file mode 100644
index 12835286dd..0000000000
--- a/recipes/u-boot/u-boot-git/nokia900/0008-configs-nokia_rx51.h-use-ext2-instead-of-fat-for-1st.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From f7b7886a7000ae2a65255d29b51578cba223a99e Mon Sep 17 00:00:00 2001
-From: Martin Jansa <Martin.Jansa@gmail.com>
-Date: Tue, 7 Dec 2010 12:41:39 +0100
-Subject: [PATCH 8/9] configs/nokia_rx51.h: use ext2 instead of fat for 1st and 3rd partition
-
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
----
- include/configs/nokia_rx51.h | 4 ++--
- 1 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/include/configs/nokia_rx51.h b/include/configs/nokia_rx51.h
-index 5c3b068..57769d0 100644
---- a/include/configs/nokia_rx51.h
-+++ b/include/configs/nokia_rx51.h
-@@ -188,10 +188,10 @@ int rx51_kp_getc(void);
- "vgacon=setenv con vga; run setcon\0" \
- "loadaddr=0x82000000\0" \
- "meegoargs=setenv bootargs\0" \
-- "loadbootscript=fatload mmc 0 ${loadaddr} boot.scr\0" \
-+ "loadbootscript=ext2load mmc 0 ${loadaddr} boot.scr\0" \
- "bootscript=echo Running bootscript from mmc ...; " \
- "source ${loadaddr}\0" \
-- "loaduimage=fatload mmc 0:3 ${loadaddr} uImage\0" \
-+ "loaduimage=ext2load mmc 0:3 ${loadaddr} uImage\0" \
- "mmcboot=echo Booting from mmc ...; " \
- "run meegoargs; " \
- "bootm ${loadaddr}\0" \
---
-1.7.3.2
-
diff --git a/recipes/u-boot/u-boot-git/nokia900/0009-configs-nokia_rx51.h-integrate-SHR-boot.scr-to-defau.patch b/recipes/u-boot/u-boot-git/nokia900/0009-configs-nokia_rx51.h-integrate-SHR-boot.scr-to-defau.patch
deleted file mode 100644
index 1b121d9962..0000000000
--- a/recipes/u-boot/u-boot-git/nokia900/0009-configs-nokia_rx51.h-integrate-SHR-boot.scr-to-defau.patch
+++ /dev/null
@@ -1,90 +0,0 @@
-From 68641f0dea622a6274337fcc1c14d1f176d3ea79 Mon Sep 17 00:00:00 2001
-From: Martin Jansa <Martin.Jansa@gmail.com>
-Date: Tue, 7 Dec 2010 13:07:57 +0100
-Subject: [PATCH 9/9] configs/nokia_rx51.h: integrate SHR boot.scr to default env
-
----
- include/configs/nokia_rx51.h | 50 +++++++++++++++++++++++++++++------------
- 1 files changed, 35 insertions(+), 15 deletions(-)
-
-diff --git a/include/configs/nokia_rx51.h b/include/configs/nokia_rx51.h
-index 57769d0..49412e7 100644
---- a/include/configs/nokia_rx51.h
-+++ b/include/configs/nokia_rx51.h
-@@ -187,38 +187,58 @@ int rx51_kp_getc(void);
- "usbcon=setenv con usbtty; run setcon\0" \
- "vgacon=setenv con vga; run setcon\0" \
- "loadaddr=0x82000000\0" \
-- "meegoargs=setenv bootargs\0" \
- "loadbootscript=ext2load mmc 0 ${loadaddr} boot.scr\0" \
- "bootscript=echo Running bootscript from mmc ...; " \
- "source ${loadaddr}\0" \
-- "loaduimage=ext2load mmc 0:3 ${loadaddr} uImage\0" \
-- "mmcboot=echo Booting from mmc ...; " \
-- "run meegoargs; " \
-- "bootm ${loadaddr}\0" \
-- "noloboot=echo Booting NOLO supplied kernel ...; " \
-+ "meegoargs=root=/dev/mmcblk0p3 rootwait console=tty0 omapfb.vram=0:2M,1:2M,2:2M mtdoops.mtddev=2 nosplash\0" \
-+ "shrargs=snd-soc-rx51.hp_lim=42 snd-soc-tlv320aic3x.hp_dac_lim=6 console=tty1 root=/dev/mmcblk1p2 rootwait panic=20 debug\0" \
-+ "shrcmd=ext2load mmc 0:1 0x82000000 uImage-shr; bootm 0x82000000\0" \
-+ "shr2cmd=ext2load mmc 0:1 0x82000000 uImage-shr2; bootm 0x82000000\0" \
-+ "meegocmd=ext2load mmc 0:1 0x82000000 uImage-meego; bootm 0x82000000\0" \
-+ "meego2cmd=ext2load mmc 0:1 0x82000000 uImage-meego2; bootm 0x82000000\0" \
-+ "meego=echo Booting Meego from 3nd partition on SD card ((uImage-meego) ...; " \
-+ "setenv atags ${nolo_atagaddr};" \
-+ "setenv bootargs ${meegoargs}; " \
-+ "setenv bootcmd ${meegocmd}; " \
-+ "boot\0" \
-+ "meego2=echo Booting Meego from 3nd partition on SD card ((uImage-meego2) ...; " \
-+ "setenv atags ${nolo_atagaddr};" \
-+ "setenv bootargs ${meegoargs}; " \
-+ "setenv bootcmd ${meego2cmd}; " \
-+ "boot\0" \
-+ "shr=echo Booting SHR from 2nd partition on SD card ((uImage-shr) ...; " \
-+ "setenv atags ${nolo_atagaddr};" \
-+ "setenv bootargs ${shrargs}; " \
-+ "setenv bootcmd ${shrcmd}; " \
-+ "boot\0" \
-+ "shr2=echo Booting SHR from 2nd partition on SD card ((uImage-shr2) ...; " \
-+ "setenv atags ${nolo_atagaddr};" \
-+ "setenv bootargs ${shrargs}; " \
-+ "setenv bootcmd ${shr2cmd}; " \
-+ "boot\0" \
-+ "maemo=echo Booting Maemo from eMMC, NOLO supplied kernel ...; " \
- "setenv atags ${nolo_atagaddr};" \
- "bootm ${nolo_kernaddr}\0"
-
- #define CONFIG_PREBOOT \
-- "if test $slide_sw != open ; then run noloboot; fi ;" \
-+ "if test $slide_sw != open ; then run maemo; fi ;" \
-+ "echo All uImage-* kernels and boot.scr are expected on ext2 mmc 0;" \
- "echo Extra commands:;" \
- "echo run sercon - Use serial port for control.;" \
- "echo run usbcon - Use usbtty for control.;" \
- "echo run vgacon - Use framebuffer/keyboard.;" \
-- "echo run mmcboot - Boot from SD card slot.;" \
-- "echo run noloboot - Boot kernel loaded by NOLO."
-+ "echo run shr - Boot SHR from 2nd partition on SD card (uImage-shr).;" \
-+ "echo run shr2 - Boot SHR from 2nd partition on SD card (uImage-shr2).;" \
-+ "echo run meego - Boot Meego from 3nd partition on SD card (uImage-meego).;" \
-+ "echo run meego2 - Boot Meego from 3nd partition on SD card (uImage-meego2).;" \
-+ "echo run maemo - Boot Maemo from eMMC, kernel loaded by NOLO."
-
- #define CONFIG_BOOTCOMMAND \
- "if mmc init; then " \
- "if run loadbootscript; then " \
- "run bootscript; " \
-- "else " \
-- "if run loaduimage; then " \
-- "run mmcboot; " \
-- "else run noloboot; " \
-- "fi; " \
- "fi; " \
-- "else run noloboot; fi"
-+ "else run maemo; fi"
-
- #define CONFIG_AUTO_COMPLETE 1
- /*
---
-1.7.3.2
-
diff --git a/recipes/u-boot/u-boot-git/nokia900/0010-configs-nokia_rx51.h-call-mmc-init-manually-because-.patch b/recipes/u-boot/u-boot-git/nokia900/0010-configs-nokia_rx51.h-call-mmc-init-manually-because-.patch
deleted file mode 100644
index 4c967f7993..0000000000
--- a/recipes/u-boot/u-boot-git/nokia900/0010-configs-nokia_rx51.h-call-mmc-init-manually-because-.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 8845d1ab756293f16c5eac7b4c575f73fe29726d Mon Sep 17 00:00:00 2001
-From: Martin Jansa <Martin.Jansa@gmail.com>
-Date: Tue, 7 Dec 2010 15:46:08 +0100
-Subject: [PATCH 10/10] configs/nokia_rx51.h: call mmc init manually, because mmc init in CONFIG_BOOTCOMMAND is called only after timeout
-
----
- include/configs/nokia_rx51.h | 10 +++++-----
- 1 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/include/configs/nokia_rx51.h b/include/configs/nokia_rx51.h
-index 49412e7..1031a8e 100644
---- a/include/configs/nokia_rx51.h
-+++ b/include/configs/nokia_rx51.h
-@@ -187,15 +187,15 @@ int rx51_kp_getc(void);
- "usbcon=setenv con usbtty; run setcon\0" \
- "vgacon=setenv con vga; run setcon\0" \
- "loadaddr=0x82000000\0" \
-- "loadbootscript=ext2load mmc 0 ${loadaddr} boot.scr\0" \
-+ "loadbootscript=mmc init; ext2load mmc 0 ${loadaddr} boot.scr\0" \
- "bootscript=echo Running bootscript from mmc ...; " \
- "source ${loadaddr}\0" \
- "meegoargs=root=/dev/mmcblk0p3 rootwait console=tty0 omapfb.vram=0:2M,1:2M,2:2M mtdoops.mtddev=2 nosplash\0" \
- "shrargs=snd-soc-rx51.hp_lim=42 snd-soc-tlv320aic3x.hp_dac_lim=6 console=tty1 root=/dev/mmcblk1p2 rootwait panic=20 debug\0" \
-- "shrcmd=ext2load mmc 0:1 0x82000000 uImage-shr; bootm 0x82000000\0" \
-- "shr2cmd=ext2load mmc 0:1 0x82000000 uImage-shr2; bootm 0x82000000\0" \
-- "meegocmd=ext2load mmc 0:1 0x82000000 uImage-meego; bootm 0x82000000\0" \
-- "meego2cmd=ext2load mmc 0:1 0x82000000 uImage-meego2; bootm 0x82000000\0" \
-+ "shrcmd=mmc init; ext2load mmc 0:1 0x82000000 uImage-shr; bootm 0x82000000\0" \
-+ "shr2cmd=mmc init; ext2load mmc 0:1 0x82000000 uImage-shr2; bootm 0x82000000\0" \
-+ "meegocmd=mmc init; ext2load mmc 0:1 0x82000000 uImage-meego; bootm 0x82000000\0" \
-+ "meego2cmd=mmc init; ext2load mmc 0:1 0x82000000 uImage-meego2; bootm 0x82000000\0" \
- "meego=echo Booting Meego from 3nd partition on SD card ((uImage-meego) ...; " \
- "setenv atags ${nolo_atagaddr};" \
- "setenv bootargs ${meegoargs}; " \
---
-1.7.3.2
-
diff --git a/recipes/u-boot/u-boot-git/nokia900/0011-configs-nokia_rx51.h-don-t-set-atags-when-booting-fr.patch b/recipes/u-boot/u-boot-git/nokia900/0011-configs-nokia_rx51.h-don-t-set-atags-when-booting-fr.patch
deleted file mode 100644
index 74e8d75cef..0000000000
--- a/recipes/u-boot/u-boot-git/nokia900/0011-configs-nokia_rx51.h-don-t-set-atags-when-booting-fr.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 1b9f7d91fd173ef3beaf5afea761e5056c027577 Mon Sep 17 00:00:00 2001
-From: Martin Jansa <Martin.Jansa@gmail.com>
-Date: Wed, 8 Dec 2010 09:20:33 +0100
-Subject: [PATCH 11/11] configs/nokia_rx51.h: don't set atags when booting from uSD except shr2
-
-* overwrites supplied bootargs ie root=
-* is needed only for old 2.6.28.10 kernel soundmodule checking revision
- so keep for shr2 option
----
- include/configs/nokia_rx51.h | 3 ---
- 1 files changed, 0 insertions(+), 3 deletions(-)
-
-diff --git a/include/configs/nokia_rx51.h b/include/configs/nokia_rx51.h
-index 1031a8e..f1858b4 100644
---- a/include/configs/nokia_rx51.h
-+++ b/include/configs/nokia_rx51.h
-@@ -197,17 +197,14 @@ int rx51_kp_getc(void);
- "meegocmd=mmc init; ext2load mmc 0:1 0x82000000 uImage-meego; bootm 0x82000000\0" \
- "meego2cmd=mmc init; ext2load mmc 0:1 0x82000000 uImage-meego2; bootm 0x82000000\0" \
- "meego=echo Booting Meego from 3nd partition on SD card ((uImage-meego) ...; " \
-- "setenv atags ${nolo_atagaddr};" \
- "setenv bootargs ${meegoargs}; " \
- "setenv bootcmd ${meegocmd}; " \
- "boot\0" \
- "meego2=echo Booting Meego from 3nd partition on SD card ((uImage-meego2) ...; " \
-- "setenv atags ${nolo_atagaddr};" \
- "setenv bootargs ${meegoargs}; " \
- "setenv bootcmd ${meego2cmd}; " \
- "boot\0" \
- "shr=echo Booting SHR from 2nd partition on SD card ((uImage-shr) ...; " \
-- "setenv atags ${nolo_atagaddr};" \
- "setenv bootargs ${shrargs}; " \
- "setenv bootcmd ${shrcmd}; " \
- "boot\0" \
---
-1.7.3.2
-
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index d9abc73215..d4dcb8d4bc 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -364,16 +364,13 @@ SRC_URI_nokia900 = "git://www.denx.de/git/u-boot.git;protocol=git \
file://0002-Make-bootm-optionally-use-pre-existing-atags-for-Lin.patch \
file://0003-Store-existing-atags-at-startup-if-chainloading.patch \
file://0004-Nokia-RX-51-aka-N900-support.patch \
- file://0001-nokia-rx51-use-O0-as-work-around-for-gcc-4.5.patch \
+ file://0001-nokia-rx51-fix-declaration-fails-when-building-with-.patch \
file://0005-fix-loading-file-from-ext2-partition-on-OMAP3-evm.patch \
file://0006-omap3_mmc.c-fix-formating.patch \
file://0007-Only-delay-boot-if-keyboard-open.patch \
"
SRC_URI_nokia900_append_shr = " \
- file://0008-configs-nokia_rx51.h-use-ext2-instead-of-fat-for-1st.patch \
- file://0009-configs-nokia_rx51.h-integrate-SHR-boot.scr-to-defau.patch \
- file://0010-configs-nokia_rx51.h-call-mmc-init-manually-because-.patch \
- file://0011-configs-nokia_rx51.h-don-t-set-atags-when-booting-fr.patch \
+ file://0001-configs-nokia_rx51.h-start-shr-as-default-and-change.patch \
"
UBOOT_MACHINE_nokia900 = "nokia_rx51_config"