aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
authorJason Kridner <jkridner@beagleboard.org>2011-04-01 09:46:53 -0500
committerSteffen Sledz <sledz@dresearch-fe.de>2011-04-29 14:08:31 +0200
commita243e101094cd6468b03b0ed30807100822d31a3 (patch)
tree1b8282d2b13e7cc5153555342ecacc6e86ec18bd /recipes/u-boot
parentebe8f46a27a1989289e007ff20ee13b6356e57cb (diff)
downloadopenembedded-a243e101094cd6468b03b0ed30807100822d31a3.tar.gz
u-boot: BeagleBoard: add rev xM-C detection
Signed-off-by: Jason Kridner <jkridner@beagleboard.org> Signed-off-by: Koen Kooi <koen@openembedded.org> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/u-boot-git/beagleboard/0017-BeagleBoard-add-xM-rev-C-to-ID-table.patch68
-rw-r--r--recipes/u-boot/u-boot_git.bb3
2 files changed, 70 insertions, 1 deletions
diff --git a/recipes/u-boot/u-boot-git/beagleboard/0017-BeagleBoard-add-xM-rev-C-to-ID-table.patch b/recipes/u-boot/u-boot-git/beagleboard/0017-BeagleBoard-add-xM-rev-C-to-ID-table.patch
new file mode 100644
index 0000000000..1125c88193
--- /dev/null
+++ b/recipes/u-boot/u-boot-git/beagleboard/0017-BeagleBoard-add-xM-rev-C-to-ID-table.patch
@@ -0,0 +1,68 @@
+From fd6e8e5ca04fea310ff4f03faa7747d061217cba Mon Sep 17 00:00:00 2001
+From: Jason Kridner <jkridner@beagleboard.org>
+Date: Wed, 30 Mar 2011 10:44:17 -0500
+Subject: [PATCH] BeagleBoard: add xM rev C to ID table
+Cc: Sandeep Paulraj <s-paulraj@ti.com>
+
+A simple addition to the revision IDs.
+
+This patch depends upon http://patchwork.ozlabs.org/patch/85303/.
+
+Signed-off-by: Jason Kridner <jkridner@beagleboard.org>
+---
+ board/ti/beagle/beagle.c | 12 ++++++++++++
+ board/ti/beagle/beagle.h | 1 +
+ 2 files changed, 13 insertions(+), 0 deletions(-)
+
+diff --git a/board/ti/beagle/beagle.c b/board/ti/beagle/beagle.c
+index 905b151..0596443 100644
+--- a/board/ti/beagle/beagle.c
++++ b/board/ti/beagle/beagle.c
+@@ -168,6 +168,7 @@ void display_init(void)
+ break;
+ case REVISION_XM_A:
+ case REVISION_XM_B:
++ case REVISION_XM_C:
+ default:
+ omap3_dss_panel_config(&dvid_cfg_xm);
+ break;
+@@ -227,6 +228,16 @@ int misc_init_r(void)
+ TWL4030_PM_RECEIVER_VAUX2_DEV_GRP,
+ TWL4030_PM_RECEIVER_DEV_GRP_P1);
+ break;
++ case REVISION_XM_C:
++ printf("Beagle xM Rev C\n");
++ setenv("beaglerev", "xMC");
++ MUX_BEAGLE_XM();
++ /* Set VAUX2 to 1.8V for EHCI PHY */
++ twl4030_pmrecv_vsel_cfg(TWL4030_PM_RECEIVER_VAUX2_DEDICATED,
++ TWL4030_PM_RECEIVER_VAUX2_VSEL_18,
++ TWL4030_PM_RECEIVER_VAUX2_DEV_GRP,
++ TWL4030_PM_RECEIVER_DEV_GRP_P1);
++ break;
+ default:
+ printf("Beagle unknown 0x%02x\n", get_board_revision());
+ MUX_BEAGLE_XM();
+@@ -372,6 +383,7 @@ int do_userbutton (cmd_tbl_t *cmdtp, int flag, int argc, char *argv[])
+ break;
+ case REVISION_XM_A:
+ case REVISION_XM_B:
++ case REVISION_XM_C:
+ default:
+ gpio = 4;
+ break;
+diff --git a/board/ti/beagle/beagle.h b/board/ti/beagle/beagle.h
+index bdf2a6f..f31ce31 100644
+--- a/board/ti/beagle/beagle.h
++++ b/board/ti/beagle/beagle.h
+@@ -41,6 +41,7 @@ const omap3_sysinfo sysinfo = {
+ #define REVISION_C4 0x5
+ #define REVISION_XM_A 0x0
+ #define REVISION_XM_B 0x1
++#define REVISION_XM_C 0x2
+
+ /*
+ * IEN - Input Enable
+--
+1.5.6.4
+
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index ad6f73e50f..61a75eab06 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -1,5 +1,5 @@
require u-boot.inc
-PR = "r74"
+PR = "r75"
FILESPATHPKG =. "u-boot-git:"
@@ -41,6 +41,7 @@ SRC_URI_beagleboard = "git://www.denx.de/git/u-boot.git;protocol=git \
file://0013-OMAP3-BeagleBoard-updated-default-configuration.patch \
file://0014-Corrected-LED-name-match-finding-avoiding-extraneous.patch \
file://0016-BeagleBoard-Load-kernel-via-MMC-ext2-not-fat.patch \
+ file://0017-BeagleBoard-add-xM-rev-C-to-ID-table.patch \
file://fw_env.config \
"
SRCREV_beagleboard = "c7977858dcf1f656cbe91ea0dc3cb9139c6a8cc8"