aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
authorMario Schuknecht <m.schuknecht@dresearch.de>2011-02-18 22:12:02 +0000
committerSteffen Sledz <sledz@dresearch.de>2011-02-19 08:56:46 +0100
commitaa23c8b7e1cb5570763d24867f966e3d952ebe4c (patch)
treee887951989242140ab93e6b6b868df32d0706b65 /recipes/u-boot
parent72a088f7e1cf2eb0b50f285301478278c616c1cd (diff)
downloadopenembedded-aa23c8b7e1cb5570763d24867f966e3d952ebe4c.tar.gz
u-boot-2009.03: use AMD fixups for AMIC too
* AMIC flashes are AMD clones and need the same fixups otherwise e.g. the u-boot command saveenv may not work (depending on the sector layout) * patch has been send upstream too: http://patchwork.ozlabs.org/patch/82763/ Signed-off-by: Mario Schuknecht <m.schuknecht@dresearch.de> Signed-off-by: Steffen Sledz <sledz@dresearch.de> Acked-by: Tom Rini <tom_rini@mentor.com> Acked-by: Paul Menzel <paulepanter@users.sourceforge.net>
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/u-boot-2009.03/cfi-amic-fixup.patch11
-rw-r--r--recipes/u-boot/u-boot-2009.03/hipox/00-hipox.patch3
-rw-r--r--recipes/u-boot/u-boot_2009.03.bb7
3 files changed, 18 insertions, 3 deletions
diff --git a/recipes/u-boot/u-boot-2009.03/cfi-amic-fixup.patch b/recipes/u-boot/u-boot-2009.03/cfi-amic-fixup.patch
new file mode 100644
index 0000000000..9d8c7ab9ca
--- /dev/null
+++ b/recipes/u-boot/u-boot-2009.03/cfi-amic-fixup.patch
@@ -0,0 +1,11 @@
+diff -Nurd u-boot-2009.03.orig//drivers/mtd/cfi_flash.c u-boot-2009.03/drivers/mtd/cfi_flash.c
+--- u-boot-2009.03.orig//drivers/mtd/cfi_flash.c 2011-02-18 14:11:24.870432001 +0100
++++ u-boot-2009.03/drivers/mtd/cfi_flash.c 2011-02-18 14:11:45.440432001 +0100
+@@ -1883,6 +1883,7 @@
+ /* Do manufacturer-specific fixups */
+ switch (info->manufacturer_id) {
+ case 0x0001:
++ case 0x0037: // AMIC
+ flash_fixup_amd(info, &qry);
+ break;
+ case 0x001f:
diff --git a/recipes/u-boot/u-boot-2009.03/hipox/00-hipox.patch b/recipes/u-boot/u-boot-2009.03/hipox/00-hipox.patch
index 5b91d28da3..20a47daf07 100644
--- a/recipes/u-boot/u-boot-2009.03/hipox/00-hipox.patch
+++ b/recipes/u-boot/u-boot-2009.03/hipox/00-hipox.patch
@@ -6190,10 +6190,11 @@ diff -Nurd u-boot-2009.03.orig/cpu/arm926ejs/start.S u-boot-2009.03/cpu/arm926ej
diff -Nurd u-boot-2009.03.orig/drivers/mtd/cfi_flash.c u-boot-2009.03/drivers/mtd/cfi_flash.c
--- u-boot-2009.03.orig/drivers/mtd/cfi_flash.c 2009-04-15 11:05:24.000000000 +0200
+++ u-boot-2009.03/drivers/mtd/cfi_flash.c 2009-04-15 11:08:18.000000000 +0200
-@@ -1883,6 +1883,7 @@
+@@ -1883,7 +1883,8 @@
/* Do manufacturer-specific fixups */
switch (info->manufacturer_id) {
case 0x0001:
+ case 0x0037: // AMIC
+ case 0x00da: // Winbond
flash_fixup_amd(info, &qry);
break;
diff --git a/recipes/u-boot/u-boot_2009.03.bb b/recipes/u-boot/u-boot_2009.03.bb
index 2cbded9a3f..4b822f19d8 100644
--- a/recipes/u-boot/u-boot_2009.03.bb
+++ b/recipes/u-boot/u-boot_2009.03.bb
@@ -6,9 +6,12 @@ DEFAULT_PREFERENCE_hipox = "1"
DEPENDS_append_hipox = " oxnas-boot-tools oxnas-boot-tools-native "
-SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 "
+SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
+ file://cfi-amic-fixup.patch \
+"
-SRC_URI_append_hipox = "file://00-hipox.patch \
+SRC_URI_append_hipox = " \
+ file://00-hipox.patch \
file://01-hipox-fix-gmac-reset.patch \
file://02-hipox-enable-mmu.patch \
file://03-hipox-direct-switch.patch \