aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-02-14 12:27:15 -0700
committerTom Rini <tom_rini@mentor.com>2011-02-14 12:29:43 -0700
commitd5157da6f32c16f23978ee96182b8d6df2d413b1 (patch)
tree6f026cbe265a1210aae6f74e8989192bae350a18 /recipes/u-boot
parentdcefe88bff8a0bcb61aa213edffc9a20eeb94ccc (diff)
downloadopenembedded-d5157da6f32c16f23978ee96182b8d6df2d413b1.tar.gz
u-boot: Make sure we use override HOSTCC for env tools
Upstream says that the right way to build a target binary of the env tools is to pass in HOSTCC=your-cross-cc. Bump the PR in u-boot_git.bb to fix as many easily fixable ones as possible, but other platforms may have been shipping bad binaries (since we had skipped testing on this package due to GNU_HASH issues when built for the target). Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/u-boot.inc2
-rw-r--r--recipes/u-boot/u-boot_git.bb4
2 files changed, 3 insertions, 3 deletions
diff --git a/recipes/u-boot/u-boot.inc b/recipes/u-boot/u-boot.inc
index 9a9528ee91..88c6a4d18f 100644
--- a/recipes/u-boot/u-boot.inc
+++ b/recipes/u-boot/u-boot.inc
@@ -26,7 +26,7 @@ do_compile () {
unset CFLAGS
unset CPPFLAGS
oe_runmake all
- oe_runmake tools env
+ oe_runmake tools env HOSTCC="${CC}"
}
do_install () {
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index 9699e8f1e8..410e0b1ca3 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -1,5 +1,5 @@
require u-boot.inc
-PR ="r71"
+PR = "r72"
FILESPATHPKG =. "u-boot-git:"
@@ -111,7 +111,7 @@ do_compile_calamari () {
oe_runmake MPC8536DS_SPIFLASH_config
oe_runmake all
mv u-boot.bin u-boot-spiflash.bin
- oe_runmake tools env
+ oe_runmake tools env HOSTCC="${CC}"
}
do_deploy_calamari () {