aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-02-15 11:40:45 -0700
committerTom Rini <tom_rini@mentor.com>2011-02-15 12:16:13 -0700
commiteaff6a9b68af367d45ac269c9a3d15095da52b0f (patch)
tree7d3f4d5e0c67373a0d284ac4fbabc8642b1b573f /recipes/u-boot
parent9993897bd4d578d4d90e13626cac46af221d926f (diff)
downloadopenembedded-eaff6a9b68af367d45ac269c9a3d15095da52b0f.tar.gz
u-boot 2009.01: Fix 'weak' issues
Based on existing patches for other boards. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/u-boot-2009.01/dont-inline-weak-symbols.patch54
-rw-r--r--recipes/u-boot/u-boot_2009.01.bb6
2 files changed, 57 insertions, 3 deletions
diff --git a/recipes/u-boot/u-boot-2009.01/dont-inline-weak-symbols.patch b/recipes/u-boot/u-boot-2009.01/dont-inline-weak-symbols.patch
new file mode 100644
index 0000000000..fd1dcab708
--- /dev/null
+++ b/recipes/u-boot/u-boot-2009.01/dont-inline-weak-symbols.patch
@@ -0,0 +1,54 @@
+Patch initially created by Ron Lee and archived in OE patchwork at
+http://patchwork.openembedded.org/patch/1534/.
+
+GCC 4.4 complains about this now.
+
+Signed-off-by: Ron Lee <ron@debian.org>
+---
+ lib_arm/board.c | 18 +++++++++---------
+ 1 files changed, 9 insertions(+), 9 deletions(-)
+
+Index: u-boot-2009.01/lib_arm/board.c
+===================================================================
+--- u-boot-2009.01.orig/lib_arm/board.c
++++ u-boot-2009.01/lib_arm/board.c
+@@ -123,19 +123,19 @@ void *sbrk (ptrdiff_t increment)
+ * May be supplied by boards if desired
+ */
+ void inline __coloured_LED_init (void) {}
+-void inline coloured_LED_init (void) __attribute__((weak, alias("__coloured_LED_init")));
++void coloured_LED_init (void) __attribute__((weak, alias("__coloured_LED_init")));
+ void inline __red_LED_on (void) {}
+-void inline red_LED_on (void) __attribute__((weak, alias("__red_LED_on")));
++void red_LED_on (void) __attribute__((weak, alias("__red_LED_on")));
+ void inline __red_LED_off(void) {}
+-void inline red_LED_off(void) __attribute__((weak, alias("__red_LED_off")));
++void red_LED_off(void) __attribute__((weak, alias("__red_LED_off")));
+ void inline __green_LED_on(void) {}
+-void inline green_LED_on(void) __attribute__((weak, alias("__green_LED_on")));
++void green_LED_on(void) __attribute__((weak, alias("__green_LED_on")));
+ void inline __green_LED_off(void) {}
+-void inline green_LED_off(void)__attribute__((weak, alias("__green_LED_off")));
++void green_LED_off(void)__attribute__((weak, alias("__green_LED_off")));
+ void inline __yellow_LED_on(void) {}
+-void inline yellow_LED_on(void)__attribute__((weak, alias("__yellow_LED_on")));
++void yellow_LED_on(void)__attribute__((weak, alias("__yellow_LED_on")));
+ void inline __yellow_LED_off(void) {}
+-void inline yellow_LED_off(void)__attribute__((weak, alias("__yellow_LED_off")));
++void yellow_LED_off(void)__attribute__((weak, alias("__yellow_LED_off")));
+
+ /************************************************************************
+ * Init Utilities *
+Index: u-boot-2009.01/common/main.c
+===================================================================
+--- u-boot-2009.01.orig/common/main.c
++++ u-boot-2009.01/common/main.c
+@@ -48,7 +48,7 @@ DECLARE_GLOBAL_DATA_PTR;
+ * Board-specific Platform code can reimplement show_boot_progress () if needed
+ */
+ void inline __show_boot_progress (int val) {}
+-void inline show_boot_progress (int val) __attribute__((weak, alias("__show_boot_progress")));
++void show_boot_progress (int val) __attribute__((weak, alias("__show_boot_progress")));
+
+ #if defined(CONFIG_BOOT_RETRY_TIME) && defined(CONFIG_RESET_TO_RETRY)
+ extern int do_reset (cmd_tbl_t *cmdtp, int flag, int argc, char *argv[]); /* for do_reset() prototype */
diff --git a/recipes/u-boot/u-boot_2009.01.bb b/recipes/u-boot/u-boot_2009.01.bb
index 4e5ca483b3..bef24646c1 100644
--- a/recipes/u-boot/u-boot_2009.01.bb
+++ b/recipes/u-boot/u-boot_2009.01.bb
@@ -14,9 +14,10 @@ DEFAULT_PREFERENCE_at91cap9adk = "1"
DEFAULT_PREFERENCE_atngw100 = "1"
DEFAULT_PREFERENCE_atstk1000 = "1"
-PR = "r1"
+PR = "r2"
-SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2"
+SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
+ file://dont-inline-weak-symbols.patch"
SRC_URI_append_at91sam9263ek = "\
file://u-boot-2009.01-exp-002-at91sam9g20ek.patch \
@@ -29,6 +30,5 @@ SRC_URI_append_at91sam9g20ek = "\
file://at91sam9g20-fix-config.patch \
"
-
SRC_URI[md5sum] = "cb11d3d74eee4d31124523d90d8c31fa"
SRC_URI[sha256sum] = "0c0afa2816482e087987f71958b656ff0c122032f5e3897a8d17daca5bc14115"