aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
authorRoger Monk <r-monk@ti.com>2010-10-13 09:13:34 +0000
committerKoen Kooi <koen@openembedded.org>2010-10-25 14:28:37 +0200
commitfcdc032623faf07c6877402ca355c6c8ce159d16 (patch)
tree998c0fbe817af0a048d682a19c4c2a276813c927 /recipes/u-boot
parentf1dac426f56e82de359d224dbd64d67a9c56629f (diff)
downloadopenembedded-fcdc032623faf07c6877402ca355c6c8ce159d16.tar.gz
u-boot: Add TI 2010.06 PSP 4.00.00.07
Signed-off-by: Roger Monk <r-monk@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/u-boot_2010.06-psp04.00.00.07.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/u-boot/u-boot_2010.06-psp04.00.00.07.bb b/recipes/u-boot/u-boot_2010.06-psp04.00.00.07.bb
new file mode 100644
index 0000000000..5a7688474f
--- /dev/null
+++ b/recipes/u-boot/u-boot_2010.06-psp04.00.00.07.bb
@@ -0,0 +1,35 @@
+require u-boot-omap3.inc
+
+DEFAULT_PREFERENCE_ti816x = "1"
+BRANCH = "ti816x-master"
+COMPATIBLE_MACHINE = "ti816x"
+
+# Corresponds to v2010.06_TI816XPSP_04.00.00.07"
+SRCREV = "5b8934eb4ed892dbb40470c143c523b5bbd20cdc"
+
+UVER = "2010.06"
+PSPREL = "04.00.00.07"
+
+PR = "r3"
+
+UBOOT_MACHINE = "ti8168_evm_config"
+
+TI_UBOOT_BINARY = "u-boot.noxip.bin"
+
+do_compile_append () {
+ unset LDFLAGS
+ unset CFLAGS
+ unset CPPFLAGS
+ oe_runmake u-boot.ti
+}
+
+do_install_append () {
+ install ${S}/${TI_UBOOT_BINARY} ${D}/boot/${TI_UBOOT_BINARY}
+}
+
+do_deploy_append () {
+ install ${S}/${TI_UBOOT_BINARY} ${DEPLOY_DIR_IMAGE}/${TI_UBOOT_BINARY}
+ package_stagefile_shell ${DEPLOY_DIR_IMAGE}/${TI_UBOOT_BINARY}
+
+}
+