aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-04-10 11:21:48 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-04-12 20:07:27 +0200
commit44985d56bc556786812a0a02d6219afd31a7381d (patch)
tree9dfeab9bd98dc6408835b7359861c8dc8ea6fffb /recipes/u-boot
parenta8e889754b1bdb261b85ac7de1c1f929ad597c09 (diff)
downloadopenembedded-44985d56bc556786812a0a02d6219afd31a7381d.tar.gz
recipes: move checksums to recipes from checksums.ini
* fetch all *.bb with patched utils.bbclass appending all checksums found only in checksums.ini to recipe Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/u-boot-mkimage-native_1.3.2.bb3
-rw-r--r--recipes/u-boot/u-boot-omap2430sdp_1.1.4.bb3
-rw-r--r--recipes/u-boot/u-boot-utils-native_1.2.0.bb3
-rw-r--r--recipes/u-boot/u-boot-utils_1.2.0.bb3
-rw-r--r--recipes/u-boot/u-boot_1.1.2.bb3
-rw-r--r--recipes/u-boot/u-boot_1.1.4.bb3
-rw-r--r--recipes/u-boot/u-boot_1.1.6.bb3
-rw-r--r--recipes/u-boot/u-boot_1.2.0.bb3
-rw-r--r--recipes/u-boot/u-boot_1.3.0.bb3
-rw-r--r--recipes/u-boot/u-boot_1.3.1.bb3
-rw-r--r--recipes/u-boot/u-boot_1.3.2.bb3
-rw-r--r--recipes/u-boot/u-boot_2009.01.bb3
-rw-r--r--recipes/u-boot/u-boot_2009.03.bb3
-rw-r--r--recipes/u-boot/u-boot_2009.06.bb3
-rw-r--r--recipes/u-boot/u-boot_2009.08.bb3
15 files changed, 45 insertions, 0 deletions
diff --git a/recipes/u-boot/u-boot-mkimage-native_1.3.2.bb b/recipes/u-boot/u-boot-mkimage-native_1.3.2.bb
index 946f48569e..cf135a5231 100644
--- a/recipes/u-boot/u-boot-mkimage-native_1.3.2.bb
+++ b/recipes/u-boot/u-boot-mkimage-native_1.3.2.bb
@@ -20,3 +20,6 @@ do_stage () {
install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/uboot-mkimage
ln -sf ${STAGING_BINDIR_NATIVE}/uboot-mkimage ${STAGING_BINDIR_NATIVE}/mkimage
}
+
+SRC_URI[md5sum] = "78b1c2722d3907b5fae2cd219dbaf927"
+SRC_URI[sha256sum] = "8ab07cd758a1775642629e624f70e376fa8e84a2f879dee4544158d9c90cde2a"
diff --git a/recipes/u-boot/u-boot-omap2430sdp_1.1.4.bb b/recipes/u-boot/u-boot-omap2430sdp_1.1.4.bb
index d7b23e119b..d29fbbe98c 100644
--- a/recipes/u-boot/u-boot-omap2430sdp_1.1.4.bb
+++ b/recipes/u-boot/u-boot-omap2430sdp_1.1.4.bb
@@ -10,3 +10,6 @@ S = "${WORKDIR}/u-boot"
#inherit base
+
+SRC_URI[md5sum] = "49c07dec9e1be69fd01d46f47ec03731"
+SRC_URI[sha256sum] = "a090786113b02647413ebc15888af269f2e6d50f73cbb94b0619cc1702911dae"
diff --git a/recipes/u-boot/u-boot-utils-native_1.2.0.bb b/recipes/u-boot/u-boot-utils-native_1.2.0.bb
index b04b366ffe..adc7ce3e1f 100644
--- a/recipes/u-boot/u-boot-utils-native_1.2.0.bb
+++ b/recipes/u-boot/u-boot-utils-native_1.2.0.bb
@@ -25,3 +25,6 @@ do_stage() {
install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/
}
+
+SRC_URI[md5sum] = "17aeee76ca4c07887bbfea8a52d40884"
+SRC_URI[sha256sum] = "62192ddf019c5d24f6538b33c9e69b6e5792bf5b0f464c0149061e2f0871108b"
diff --git a/recipes/u-boot/u-boot-utils_1.2.0.bb b/recipes/u-boot/u-boot-utils_1.2.0.bb
index f38ecbe572..828c43b00a 100644
--- a/recipes/u-boot/u-boot-utils_1.2.0.bb
+++ b/recipes/u-boot/u-boot-utils_1.2.0.bb
@@ -34,3 +34,6 @@ do_install () {
install -m 755 ${S}/tools/env/fw_printenv ${D}/sbin/fw_setenv
}
+
+SRC_URI[md5sum] = "17aeee76ca4c07887bbfea8a52d40884"
+SRC_URI[sha256sum] = "62192ddf019c5d24f6538b33c9e69b6e5792bf5b0f464c0149061e2f0871108b"
diff --git a/recipes/u-boot/u-boot_1.1.2.bb b/recipes/u-boot/u-boot_1.1.2.bb
index 8287d35a1d..2cfebe2eef 100644
--- a/recipes/u-boot/u-boot_1.1.2.bb
+++ b/recipes/u-boot/u-boot_1.1.2.bb
@@ -55,3 +55,6 @@ hwctrl kernel_conf_set bootargs "`cat $A`"
cat /dev/mtdblock/0 >/dev/null
exit 0
}
+
+SRC_URI[md5sum] = "f10b6954498bab5d08d0f50de381af50"
+SRC_URI[sha256sum] = "4f32cfd01f0678080f8e98009ba99ce37f1261d842e3af9a6b3add22005a80ca"
diff --git a/recipes/u-boot/u-boot_1.1.4.bb b/recipes/u-boot/u-boot_1.1.4.bb
index df6a357c63..2e374f9809 100644
--- a/recipes/u-boot/u-boot_1.1.4.bb
+++ b/recipes/u-boot/u-boot_1.1.4.bb
@@ -69,3 +69,6 @@ do_compile () {
oe_runmake ${UBOOT_MACHINE}
oe_runmake all
}
+
+SRC_URI[md5sum] = "096cac66046326659b97eeded007ec73"
+SRC_URI[sha256sum] = "1af9d68adfe044cb8fe1b3efa5b661c4cb57edf90f4a8daf38f0fc19692677a7"
diff --git a/recipes/u-boot/u-boot_1.1.6.bb b/recipes/u-boot/u-boot_1.1.6.bb
index b8729d2179..f7f62ecdd2 100644
--- a/recipes/u-boot/u-boot_1.1.6.bb
+++ b/recipes/u-boot/u-boot_1.1.6.bb
@@ -22,3 +22,6 @@ SRC_URI_append_mpc8323e-rdb = " file://u-boot-1.1.6-fsl-1-mpc83xx-20061206.patc
UBOOT_MACHINE_sarge-at91 = "sarge_config"
+
+SRC_URI[md5sum] = "5b1b1f7b3b1e06f75f5bfbd79891067b"
+SRC_URI[sha256sum] = "778acb0eafe1d9b94c6f5ec5f333126c40d73704920ff8b23085c6dedecfd6e8"
diff --git a/recipes/u-boot/u-boot_1.2.0.bb b/recipes/u-boot/u-boot_1.2.0.bb
index f7e7446197..e4b0efc5a7 100644
--- a/recipes/u-boot/u-boot_1.2.0.bb
+++ b/recipes/u-boot/u-boot_1.2.0.bb
@@ -41,3 +41,6 @@ http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-improve-ddr-performance.pa
http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-fix-PCI-IO-base.patch;patch=1 \
"
+
+SRC_URI[md5sum] = "17aeee76ca4c07887bbfea8a52d40884"
+SRC_URI[sha256sum] = "62192ddf019c5d24f6538b33c9e69b6e5792bf5b0f464c0149061e2f0871108b"
diff --git a/recipes/u-boot/u-boot_1.3.0.bb b/recipes/u-boot/u-boot_1.3.0.bb
index a0656baea6..48f177b425 100644
--- a/recipes/u-boot/u-boot_1.3.0.bb
+++ b/recipes/u-boot/u-boot_1.3.0.bb
@@ -4,3 +4,6 @@ DEFAULT_PREFERENCE = "-1"
SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "2298f6d6d5c52d42a90c44774ed07751"
+SRC_URI[sha256sum] = "a55d6d46120ea7625a9d2fe594f677690e7dc9e9b3151a6af0ebe25978458608"
diff --git a/recipes/u-boot/u-boot_1.3.1.bb b/recipes/u-boot/u-boot_1.3.1.bb
index 39a7b30771..3c6d642af8 100644
--- a/recipes/u-boot/u-boot_1.3.1.bb
+++ b/recipes/u-boot/u-boot_1.3.1.bb
@@ -9,3 +9,6 @@ SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
file://mpc8313e-rdb-mtdparts.patch;patch=1 \
file://mpc8313e-rdb-nand.patch;patch=1"
+
+SRC_URI[md5sum] = "8fbd29c7e70c524a42d18b9c3f3a4aa1"
+SRC_URI[sha256sum] = "64811b4ab4ca362b01a3d08f53a2dbbf059e18484b90cb5e21c0365d53b87f77"
diff --git a/recipes/u-boot/u-boot_1.3.2.bb b/recipes/u-boot/u-boot_1.3.2.bb
index d52ca1efb7..7a2f28c52c 100644
--- a/recipes/u-boot/u-boot_1.3.2.bb
+++ b/recipes/u-boot/u-boot_1.3.2.bb
@@ -45,3 +45,6 @@ do_deploy_append_mpc8313e-rdb () {
package_stagefile_shell ${DEPLOY_DIR_IMAGE}/vsc7385_load.bin
}
+
+SRC_URI[md5sum] = "78b1c2722d3907b5fae2cd219dbaf927"
+SRC_URI[sha256sum] = "8ab07cd758a1775642629e624f70e376fa8e84a2f879dee4544158d9c90cde2a"
diff --git a/recipes/u-boot/u-boot_2009.01.bb b/recipes/u-boot/u-boot_2009.01.bb
index dfb3b3a767..ca82df2d40 100644
--- a/recipes/u-boot/u-boot_2009.01.bb
+++ b/recipes/u-boot/u-boot_2009.01.bb
@@ -29,3 +29,6 @@ SRC_URI_append_at91sam9g20ek = "\
file://at91sam9g20-fix-config.patch;patch=1 \
"
+
+SRC_URI[md5sum] = "cb11d3d74eee4d31124523d90d8c31fa"
+SRC_URI[sha256sum] = "0c0afa2816482e087987f71958b656ff0c122032f5e3897a8d17daca5bc14115"
diff --git a/recipes/u-boot/u-boot_2009.03.bb b/recipes/u-boot/u-boot_2009.03.bb
index c3e9326da0..2b65948b6c 100644
--- a/recipes/u-boot/u-boot_2009.03.bb
+++ b/recipes/u-boot/u-boot_2009.03.bb
@@ -23,3 +23,6 @@ do_compile () {
oe_runmake ${UBOOT_MACHINE}
oe_runmake all
}
+
+SRC_URI[md5sum] = "285e2184d2efef50e0fe43b71d2a7b11"
+SRC_URI[sha256sum] = "a2889bee9c45575b284564dbc27cf3dc6cb9833d4ff643976a1b3dba2d763f86"
diff --git a/recipes/u-boot/u-boot_2009.06.bb b/recipes/u-boot/u-boot_2009.06.bb
index 3ea182a15f..0f7aa7b7e0 100644
--- a/recipes/u-boot/u-boot_2009.06.bb
+++ b/recipes/u-boot/u-boot_2009.06.bb
@@ -14,3 +14,6 @@ do_compile () {
oe_runmake ${UBOOT_MACHINE}
oe_runmake all
}
+
+SRC_URI[md5sum] = "dfbe65c1e31bb7de5f5b03d50de192b5"
+SRC_URI[sha256sum] = "b0037cf21b67779ef5a0c585b32e46bde3b78df889484c78bb4318c9b448f560"
diff --git a/recipes/u-boot/u-boot_2009.08.bb b/recipes/u-boot/u-boot_2009.08.bb
index 21715a07a8..f5277a5576 100644
--- a/recipes/u-boot/u-boot_2009.08.bb
+++ b/recipes/u-boot/u-boot_2009.08.bb
@@ -21,3 +21,6 @@ do_compile () {
oe_runmake ${UBOOT_MACHINE}
oe_runmake all
}
+
+SRC_URI[md5sum] = "cd4788ea1c6ac4f9b100b888a1063a6b"
+SRC_URI[sha256sum] = "858fd04efd5b98e99fd1a074998b1a8ac5fbd07b176de1d20d8eb148492d949d"