aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
authorCliff Brake <cbrake@bec-systems.com>2010-11-12 00:00:20 -0500
committerCliff Brake <cbrake@bec-systems.com>2010-11-12 00:00:20 -0500
commit3c6efe8f8abc16668ca5e9cdf7a46665dac87172 (patch)
tree642c13416b99e80f0871cdc6668e832e635dfb48 /recipes/u-boot
parentc400c874f2ac9233b8a43a73309b6e7907289c54 (diff)
parent13fbe7253c95881ede787004a4c3a1c31502e5c6 (diff)
downloadopenembedded-3c6efe8f8abc16668ca5e9cdf7a46665dac87172.tar.gz
Merge branch 'master' into testing-nexttested_2010-11-12testing
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/u-boot-topas_git.bb23
-rw-r--r--recipes/u-boot/u-boot_2009.08.bb6
2 files changed, 28 insertions, 1 deletions
diff --git a/recipes/u-boot/u-boot-topas_git.bb b/recipes/u-boot/u-boot-topas_git.bb
new file mode 100644
index 0000000000..d7ce94c5cc
--- /dev/null
+++ b/recipes/u-boot/u-boot-topas_git.bb
@@ -0,0 +1,23 @@
+require u-boot.inc
+
+PV = "2008.10+${PR}+git"
+PR ="r2"
+PE = "1"
+
+SRC_URI = "git://git.labs.kernelconcepts.de/u-boot-topas.git/;protocol=git;tag=ca81d0245469af242e9a73360e46e99235eaadbf \
+ "
+
+UBOOT_MACHINE_topas910 = "topas910_config"
+
+S = "${WORKDIR}/git/u-boot-topas910/"
+
+do_compile () {
+ unset LDFLAGS
+ unset CFLAGS
+ unset CPPFLAGS
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake all
+# oe_runmake tools env
+ oe_runmake tools
+}
+
diff --git a/recipes/u-boot/u-boot_2009.08.bb b/recipes/u-boot/u-boot_2009.08.bb
index 868e618607..65bf688fc8 100644
--- a/recipes/u-boot/u-boot_2009.08.bb
+++ b/recipes/u-boot/u-boot_2009.08.bb
@@ -6,6 +6,7 @@ DEFAULT_PREFERENCE_at91sam9g20ek = "1"
DEFAULT_PREFERENCE_at91sam9g45ek = "1"
DEFAULT_PREFERENCE_igep0020 = "1"
DEFAULT_PREFERENCE_babbage = "1"
+DEFAULT_PREFERENCE_mx25-3stack = "1"
SRC_URI = "\
ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
@@ -16,7 +17,10 @@ SRC_URI_append_igep0020 = " \
file://update-mach-types.patch \
file://add-board-support-for-IGEP-v2-series-rev-B.patch \
"
-SRC_URI_append_babbage ="\
+SRC_URI_append_babbage = " \
+ http://download.berlios.de/mx25patches/u-boot-v2009.08-imx-09.12.00.patch.bz2;patch=1;name=ubootbabbage \
+ "
+SRC_URI_append_mx25-3stack = " \
http://download.berlios.de/mx25patches/u-boot-v2009.08-imx-09.12.00.patch.bz2;patch=1;name=ubootbabbage \
"