aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/uae
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/uae
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/uae')
-rw-r--r--recipes/uae/e-uae_0.8.28.bb29
-rw-r--r--recipes/uae/files/configure.patch9
-rw-r--r--recipes/uae/files/uaerc61
3 files changed, 99 insertions, 0 deletions
diff --git a/recipes/uae/e-uae_0.8.28.bb b/recipes/uae/e-uae_0.8.28.bb
new file mode 100644
index 0000000000..388f3ccf54
--- /dev/null
+++ b/recipes/uae/e-uae_0.8.28.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Amiga Emulator based on SDL"
+SECTION = "base"
+PRIORITY = "optional"
+DEPENDS = "virtual/libsdl zlib"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://rcdrummond.net/uae/e-uae-${PV}/e-uae-${PV}.tar.bz2 \
+ file://configure.patch;patch=1"
+
+inherit autotools
+
+export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
+
+EXTRA_OECONF = "--with-hostcc=gcc --disable-ui --without-x \
+ --without-gtk --enable-jit --disable-natmem \
+ --with-zlib=${STAGING_LIBDIR}/.."
+
+CFLAGS_append = " -DSTAT_STATFS2_BSIZE=1 "
+CXXFLAGS_append = " -DSTAT_STATFS2_BSIZE=1 "
+PARALLEL_MAKE = ""
+
+export S
+export PKG_CONFIG="${STAGING_BINDIR_NATIVE}/pkg-config"
+
+do_configure_prepend () {
+ sed -i -e s:getline:etline:g ./src/gui-none/nogui.c
+ touch NEWS AUTHORS ChangeLog
+}
diff --git a/recipes/uae/files/configure.patch b/recipes/uae/files/configure.patch
new file mode 100644
index 0000000000..23df6b93e9
--- /dev/null
+++ b/recipes/uae/files/configure.patch
@@ -0,0 +1,9 @@
+--- tmp/base/uae-0.8.23-20040129-r0/uae-0.8.23-20040129/configure.in 2004-01-29 00:38:18.000000000 -0500
++++ uae-0.8.23-20040129/configure.in 2004-03-05 17:26:12.000000000 -0500
+@@ -1032,5 +1032,5 @@
+ export CC=$CC_FOR_BUILD
+ export CFLAGS=$CFLAGS_FOR_BUILD
+ mkdir -p src/tools
+- cd src/tools && ../../"$srcdir"/src/tools/configure --cache-file=/dev/null --host=$build --target=$host
++ cd src/tools && "$S"/src/tools/configure --cache-file=/dev/null --host=$build --target=$host
+ fi
diff --git a/recipes/uae/files/uaerc b/recipes/uae/files/uaerc
new file mode 100644
index 0000000000..7a21f286e4
--- /dev/null
+++ b/recipes/uae/files/uaerc
@@ -0,0 +1,61 @@
+config_description=UAE default configuration
+32bit_blits=true
+32bit_blits=true
+x11.rom_path=./
+x11.floppy_path=./
+x11.hardfile_path=./
+x11.low_bandwidth=false
+x11.use_mitshm=false
+x11.hide_cursor=true
+use_gui=yes
+use_debugger=false
+kickstart_rom_file=kick.rom
+kickstart_ext_rom_file=
+kickstart_key_file=
+kickshifter=false
+floppy0=
+floppy1=
+floppy2=
+floppy3=
+nr_floppies=4
+parallel_on_demand=false
+serial_on_demand=false
+sound_output=normal
+sound_channels=mono
+sound_bits=8
+sound_min_buff=1024
+sound_max_buff=1024
+sound_frequency=16000
+sound_interpol=none
+sound_pri_time=0
+sound_pri_cutoff=0
+joyport0=mouse
+joyport1=kbd2
+bsdsocket_emu=false
+gfx_framerate=4
+gfx_width=640
+gfx_height=480
+gfx_lores=true
+gfx_linemode=none
+gfx_correct_aspect=false
+gfx_fullscreen_amiga=false
+gfx_fullscreen_picasso=false
+gfx_center_horizontal=smart
+gfx_center_vertical=smart
+gfx_colour_mode=16bit
+immediate_blits=true
+ntsc=true
+chipset=ocs
+collision_level=sprites
+fastmem_size=2
+a3000mem_size=0
+z3mem_size=0
+bogomem_size=0
+gfxcard_size=0
+chipmem_size=1
+cpu_speed=real
+cpu_type=68000
+cpu_compatible=false
+accuracy=2
+log_illegal_mem=false
+kbd_lang=us