aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ubahnnav
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ubahnnav
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ubahnnav')
-rw-r--r--recipes/ubahnnav/ubahnnav/qmake.patch48
-rw-r--r--recipes/ubahnnav/ubahnnav_0.4.1.bb34
2 files changed, 82 insertions, 0 deletions
diff --git a/recipes/ubahnnav/ubahnnav/qmake.patch b/recipes/ubahnnav/ubahnnav/qmake.patch
new file mode 100644
index 0000000000..86c57b235a
--- /dev/null
+++ b/recipes/ubahnnav/ubahnnav/qmake.patch
@@ -0,0 +1,48 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- /dev/null
++++ ubahnnav-0.3.1/src.pro
+@@ -0,0 +1,3 @@
++TEMPLATE = subdirs
++SUBDIRS = src/libsubwaymap src/ubahnnav
++
+--- /dev/null
++++ ubahnnav-0.3.1/src/libsubwaymap/libsubwaymap.pro
+@@ -0,0 +1,34 @@
++######################################################################
++# Automatically generated by qmake (1.06c) Sat Aug 28 18:47:05 2004
++######################################################################
++
++TEMPLATE = lib
++TARGET = subwaymap
++CONFIG = qt
++INCLUDEPATH += .
++
++# Input
++HEADERS += baseclasses.h \
++ debug.h \
++ Dijkstra.h \
++ Exceptions.h \
++ RouteFinder.h \
++ RouteFinderBase.h \
++ SMError.h \
++ SMXMLSubwayMapParser.h \
++ SMXMLSubwayMapParser_Qt.h \
++ SMXMLWriter.h \
++ SubwayGraph.h \
++ SubwayMap.h \
++ XMLBase.h
++SOURCES += baseclasses.cpp \
++ debug.cpp \
++ Dijkstra.cpp \
++ RouteFinder.cpp \
++ RouteFinderBase.cpp \
++ SMXMLSubwayMapParser.cpp \
++ SMXMLSubwayMapParser_Qt.cpp \
++ SMXMLWriter.cpp \
++ SubwayGraph.cpp \
++ SubwayMap.cpp \
++ XMLBase.cpp
diff --git a/recipes/ubahnnav/ubahnnav_0.4.1.bb b/recipes/ubahnnav/ubahnnav_0.4.1.bb
new file mode 100644
index 0000000000..9d6f85889e
--- /dev/null
+++ b/recipes/ubahnnav/ubahnnav_0.4.1.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "U-Bahn Navigator helps you navigating through foreign public \
+transport networks. It finds the shortest or direct route from a start to a \
+destination station of the loaded subway map. U-Bahn Navigator is extensible \
+to support each public transport network."
+PRIORITY = "optional"
+SECTION = "opie/applications"
+AUTHOR = "Dimitri Brukakis"
+HOMEPAGE = "http://ubahnstation.net"
+LICENSE = "GPL"
+APPNAME = "ubahnnav"
+APPTYPE = "binary"
+APPDESKTOP = "${S}/src/ubahnnav"
+PR = "r0"
+
+SRC_URI = "http://ubahnstation.net/source/ubahnnav-${PV}.tar.gz \
+ file://qmake.patch;patch=1"
+S = "${WORKDIR}/ubahnnav-${PV}"
+
+inherit opie
+
+export OE_QMAKE_LINK="${CXX}"
+EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${S}/src/libsubwaymap LIBS+=-L${S} LIBS-=-lqtopia"
+
+do_configure_prepend() {
+ find . -name "Makefile"|xargs rm -f
+}
+
+do_install() {
+ oe_libinstall -so libsubwaymap ${D}${palmtopdir}/lib
+ install -d ${D}${palmtopdir}/pics
+ install -d ${D}${palmtopdir}/ubahn/maps
+ touch ${D}${palmtopdir}/ubahn/maps/.empty
+ install -m 0644 src/ubahnnav/images/u-logo.png ${D}${palmtopdir}/pics/ubahnnav.png
+}