aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/uclibc
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2010-08-05 12:05:35 +0200
committerHenning Heinold <heinold@inf.fu-berlin.de>2010-08-05 15:23:33 +0200
commitacd7fb9deb4719232ada3bb25d75d9bb86fb8cf8 (patch)
tree8a23a03eed78c33c9ccde915adc62dd673569e85 /recipes/uclibc
parent52d472c5971b466b112bcff40abab80007ae0c52 (diff)
downloadopenembedded-acd7fb9deb4719232ada3bb25d75d9bb86fb8cf8.tar.gz
uclibc: use GENERIC_ARM, because we override the cpu flags anyway, bump PR
Diffstat (limited to 'recipes/uclibc')
-rw-r--r--recipes/uclibc/uclibc-git/arm/uClibc.machine4
-rw-r--r--recipes/uclibc/uclibc-git/armv5te/uClibc.machine4
-rw-r--r--recipes/uclibc/uclibc_git.bb2
3 files changed, 5 insertions, 5 deletions
diff --git a/recipes/uclibc/uclibc-git/arm/uClibc.machine b/recipes/uclibc/uclibc-git/arm/uClibc.machine
index 898b73a33b..293f384363 100644
--- a/recipes/uclibc/uclibc-git/arm/uClibc.machine
+++ b/recipes/uclibc/uclibc-git/arm/uClibc.machine
@@ -34,12 +34,12 @@ FORCE_OPTIONS_FOR_ARCH=y
# CONFIG_ARM_OABI is not set
CONFIG_ARM_EABI=y
USE_BX=y
-# CONFIG_GENERIC_ARM is not set
+CONFIG_GENERIC_ARM=y
# CONFIG_ARM610 is not set
# CONFIG_ARM710 is not set
# CONFIG_ARM7TDMI is not set
# CONFIG_ARM720T is not set
-CONFIG_ARM920T=y
+# CONFIG_ARM920T is not set
# CONFIG_ARM922T is not set
# CONFIG_ARM926T is not set
# CONFIG_ARM10T is not set
diff --git a/recipes/uclibc/uclibc-git/armv5te/uClibc.machine b/recipes/uclibc/uclibc-git/armv5te/uClibc.machine
index 7154278f88..eb76f34c4e 100644
--- a/recipes/uclibc/uclibc-git/armv5te/uClibc.machine
+++ b/recipes/uclibc/uclibc-git/armv5te/uClibc.machine
@@ -37,14 +37,14 @@ FORCE_OPTIONS_FOR_ARCH=y
# CONFIG_ARM_OABI is not set
CONFIG_ARM_EABI=y
USE_BX=y
-# CONFIG_GENERIC_ARM is not set
+CONFIG_GENERIC_ARM=y
# CONFIG_ARM610 is not set
# CONFIG_ARM710 is not set
# CONFIG_ARM7TDMI is not set
# CONFIG_ARM720T is not set
# CONFIG_ARM920T is not set
# CONFIG_ARM922T is not set
-CONFIG_ARM926T=y
+# CONFIG_ARM926T is not set
# CONFIG_ARM10T is not set
# CONFIG_ARM1136JF_S is not set
# CONFIG_ARM1176JZ_S is not set
diff --git a/recipes/uclibc/uclibc_git.bb b/recipes/uclibc/uclibc_git.bb
index 66e39960fe..691af8143a 100644
--- a/recipes/uclibc/uclibc_git.bb
+++ b/recipes/uclibc/uclibc_git.bb
@@ -14,7 +14,7 @@ DEFAULT_PREFERENCE = "-1"
# precedence.
require uclibc.inc
-PR = "${INC_PR}.2"
+PR = "${INC_PR}.3"
PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc"
#recent versions uclibc require real kernel headers