aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/udev/udev-compat-static_124.bb
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2010-05-29 00:06:54 +0200
committerAndrea Adami <andrea.adami@gmail.com>2010-05-29 00:49:11 +0200
commitc027cfceec87f66e5996f098a1ede9f5a33e88fa (patch)
tree99ff595b4dcc4cc7710ed09ea5c42624cd1012ba /recipes/udev/udev-compat-static_124.bb
parenta291b86743282ab9d7ea6c5363d77500ce89e7a3 (diff)
downloadopenembedded-c027cfceec87f66e5996f098a1ede9f5a33e88fa.tar.gz
udev-static: rename recipe to udev-compat to avoid packaging clash
Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'recipes/udev/udev-compat-static_124.bb')
-rw-r--r--recipes/udev/udev-compat-static_124.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/udev/udev-compat-static_124.bb b/recipes/udev/udev-compat-static_124.bb
new file mode 100644
index 0000000000..7348a6ca63
--- /dev/null
+++ b/recipes/udev/udev-compat-static_124.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Static version of udev for devices with an old (e.g. <2.6.27) kernel"
+
+require udev.inc
+
+SRC_URI += "file://noasmlinkage.patch \
+ file://flags.patch \
+ file://vol_id_ld.patch \
+ file://udevtrigger_add_devname_filtering.patch \
+ file://libvolume-id-soname.patch \
+ file://mtd-exclude-persistent.patch \
+ "
+
+PR = "${INC_PR}.0"
+
+LD = "${CC}"
+
+S = "${WORKDIR}/udev-${PV}"
+
+export USE_STATIC = "true"
+
+CFLAGS += "-DUSE_STATIC"
+LDFLAGS += "-static"
+
+# Overriding PACKAGES is bad, but we only want ${PN}
+PACKAGES = "${PN}"
+FILES_${PN} = "${base_sbindir}/*-${PV}-static"
+
+
+UDEV_EXTRAS = "extras/firmware/ extras/scsi_id/ extras/volume_id/"
+EXTRA_OEMAKE += "libudevdir=/lib/udev libdir=${base_libdir} prefix="
+
+do_install () {
+ install -d ${D}${usrsbindir} \
+ ${D}${sbindir}
+ oe_runmake 'DESTDIR=${D}' INSTALL=install install
+
+ mv ${D}${base_sbindir}/udevd ${D}${base_sbindir}/udevd-${PV}-static
+ mv ${D}${base_sbindir}/udevadm ${D}${base_sbindir}/udevadm-${PV}-static
+}
+
+SRC_URI[md5sum] = "2ea9229208154229c5d6df6222f74ad7"
+SRC_URI[sha256sum] = "cc9f58ff58fbd3f5868e1f1e368e3c93e1f441afd0ac1dcbd5d01a9ce5b5b0d7"