summaryrefslogtreecommitdiffstats
path: root/recipes/udev/udev-compat141_141.bb
diff options
context:
space:
mode:
authorStanislav Brabec <sbrabec@suse.cz>2010-07-24 15:47:26 +0200
committerStanislav Brabec <sbrabec@suse.cz>2010-07-24 15:47:26 +0200
commitcb83d228243cd792ed044c4f0a76fdd263eb1b9d (patch)
treefef6ee760f21c0e65729823136812f5862b65160 /recipes/udev/udev-compat141_141.bb
parentefc1b721a617a3a895bc4c1ff17d02258e5458e2 (diff)
downloadopenembedded-cb83d228243cd792ed044c4f0a76fdd263eb1b9d.tar.gz
udev: Fix sanity_check errors of requires/provides in udev-compat introduction.
* http://lists.linuxtogo.org/pipermail/openembedded-devel/2010-July/021848.html Signed-off-by: Stanislav Brabec <utx@penguin.cz>
Diffstat (limited to 'recipes/udev/udev-compat141_141.bb')
-rw-r--r--recipes/udev/udev-compat141_141.bb19
1 files changed, 12 insertions, 7 deletions
diff --git a/recipes/udev/udev-compat141_141.bb b/recipes/udev/udev-compat141_141.bb
index 3eb99e8a9a..2411fc6f72 100644
--- a/recipes/udev/udev-compat141_141.bb
+++ b/recipes/udev/udev-compat141_141.bb
@@ -1,18 +1,23 @@
# To use this package, you need:
-# - udev main package with init scrit that supports udev-compat-wrapper (enable per-platform in the udev.inc and udev*.bb files)
-# - this package must be embedded into the image (otherwise system will refuse to boot)
-# - only one compat package is supported (pick the newest udev that supports your oldest kernel)
+# - udev main package with init script that supports udev-compat-wrapper
+# (enable per-platform in the udev.inc and udev*.bb files)
+# - this package must be embedded into the image
+# (otherwise system will refuse to boot)
+# - only one compat package is supported (pick the newest udev that
+# supports your oldest kernel and set is as
+# PREFERRED_PROVIDER_udev-compat in your machine config)
#
FILESPATHPKG =. "udev-${PV}:udev:"
require udev_141.bb
S = "${WORKDIR}/udev-${PV}"
DESCRIPTION = "udev compatibility helper package for systems that run old kernels"
PACKAGES = "${PN} ${PN}-dbg"
+PROVIDES = "udev-compat"
-# Need udev with udev-compat-wrapper support.
-RDEPENDS_${PN} += "udev-compat-wrapper"
+# Need udev with udev-compat-wrapper support and nothing else.
+RDEPENDS_${PN} = "udev-compat-wrapper"
# Remove hotplug RPROVIDES
-RPROVIDES_${PN} = ""
+RPROVIDES_${PN} = "udev-compat"
# We cannot use newer library: udev_monitor_new_from_netlink_compat() will fail.
# We cannot use older udev_monitor_new_from_netlink_compat(): Structures are incompatible.
@@ -28,5 +33,5 @@ do_install_append () {
rmdir ${D}${prefix} 2>/dev/null || true
}
-# Remove udev init script installation
+# Remove udev init script installation.
INITSCRIPT_PACKAGES = ""