aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/udev/udev-static-124/flags.patch
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-04-17 15:35:36 +0200
committerKoen Kooi <koen@openembedded.org>2010-04-17 15:38:06 +0200
commitdc17170c1cd3138f575b52dc537b94f47da13a2b (patch)
treef5ee31f8d927b65d9b618c7b8cf7631f82f72019 /recipes/udev/udev-static-124/flags.patch
parent0fb52aef77c21a68de87cfc922e2cd6a265ebf25 (diff)
downloadopenembedded-dc17170c1cd3138f575b52dc537b94f47da13a2b.tar.gz
udev-static 124: prototype for a static udevd and udevadm that can be used as fallback on old kernels (e.g. 2.6.26 or earlier)
Diffstat (limited to 'recipes/udev/udev-static-124/flags.patch')
-rw-r--r--recipes/udev/udev-static-124/flags.patch56
1 files changed, 56 insertions, 0 deletions
diff --git a/recipes/udev/udev-static-124/flags.patch b/recipes/udev/udev-static-124/flags.patch
new file mode 100644
index 0000000000..13f20eb6a8
--- /dev/null
+++ b/recipes/udev/udev-static-124/flags.patch
@@ -0,0 +1,56 @@
+---
+ Makefile | 16 ++++++++--------
+ 1 file changed, 8 insertions(+), 8 deletions(-)
+
+Index: udev-115/Makefile
+===================================================================
+--- udev-115.orig/Makefile 2007-08-24 01:29:54.000000000 +0200
++++ udev-115/Makefile 2007-09-20 17:21:45.000000000 +0200
+@@ -112,39 +112,39 @@
+ AR = $(CROSS_COMPILE)ar
+ RANLIB = $(CROSS_COMPILE)ranlib
+
+-CFLAGS += -g -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
++override CFLAGS = -g -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+ WARNINGS = -Wstrict-prototypes -Wsign-compare -Wshadow \
+ -Wchar-subscripts -Wmissing-declarations -Wnested-externs \
+ -Wpointer-arith -Wcast-align -Wsign-compare -Wmissing-prototypes
+-CFLAGS += $(WARNINGS)
++override CFLAGS += $(WARNINGS)
+
+ LDFLAGS += -Wl,-warn-common,--as-needed
+
+ OPTFLAGS = -Os
+-CFLAGS += $(OPTFLAGS)
++override CFLAGS += $(OPTFLAGS)
+
+ ifeq ($(strip $(USE_LOG)),true)
+- CFLAGS += -DUSE_LOG
++ override CFLAGS += -DUSE_LOG
+ endif
+
+ # if DEBUG is enabled, then we do not strip
+ ifeq ($(strip $(DEBUG)),true)
+- CFLAGS += -DDEBUG
++ override CFLAGS += -DDEBUG
+ endif
+
+ ifeq ($(strip $(USE_GCOV)),true)
+- CFLAGS += -fprofile-arcs -ftest-coverage
++ override CFLAGS += -fprofile-arcs -ftest-coverage
+ LDFLAGS += -fprofile-arcs
+ endif
+
+ ifeq ($(strip $(USE_SELINUX)),true)
+ UDEV_OBJS += udev_selinux.o
+ LIB_OBJS += -lselinux -lsepol
+- CFLAGS += -DUSE_SELINUX
++ override CFLAGS += -DUSE_SELINUX
+ endif
+
+ ifeq ($(strip $(USE_STATIC)),true)
+- CFLAGS += -DUSE_STATIC
++ override CFLAGS += -DUSE_STATIC
+ LDFLAGS += -static
+ endif
+