aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/udev
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-11-12 22:15:19 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-11-12 22:15:19 +0000
commitf2d481cd787cb7a721439a535835c1af10090374 (patch)
tree2a91b476c6946040d4330bd89f9a2884f377a822 /recipes/udev
parent25b75bb6dc288337c5a44074cf7652515be71df5 (diff)
downloadopenembedded-f2d481cd787cb7a721439a535835c1af10090374.tar.gz
udev-141: Fix staging of .pc file due to exec_prefix being ''
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'recipes/udev')
-rw-r--r--recipes/udev/udev_141.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes/udev/udev_141.bb b/recipes/udev/udev_141.bb
index a0e0381549..006be64545 100644
--- a/recipes/udev/udev_141.bb
+++ b/recipes/udev/udev_141.bb
@@ -6,7 +6,7 @@ LICENSE = "GPL"
# Untested
DEFAULT_PREFERENCE = "-1"
-PR = "r13"
+PR = "r14"
# needed for init.d script
RDEPENDS_${PN} += "udev-utils"
@@ -104,4 +104,9 @@ do_stage_append() {
install -m 0644 ${S}/extras/volume_id/lib/libvolume_id.h ${STAGING_INCDIR}
oe_libinstall -C extras/volume_id/lib -so libvolume_id ${STAGING_LIBDIR}
oe_libinstall -C udev/lib -so libudev ${STAGING_LIBDIR}
+ # Since we change exec_prefix above, autotools_stage_all will not see the .pc files
+ # When we upgrade to 145 with the path bugs fixed we can drop all this (see poky)
+ install -d ${STAGING_DIR_TARGET}${prefix}${libdir}/pkgconfig/
+ install ${S}/extras/volume_id/lib/libvolume_id.pc ${STAGING_DIR_TARGET}${prefix}${libdir}/pkgconfig/
+ install ${S}/udev/lib/libudev.pc ${STAGING_DIR_TARGET}${prefix}${libdir}/pkgconfig/
}