aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/udns
diff options
context:
space:
mode:
authorMichael Lippautz <michael.lippautz@gmail.com>2010-03-14 20:24:12 +0100
committerMichael Lippautz <michael.lippautz@gmail.com>2010-03-15 13:42:00 +0100
commit5ae3348001d680637744864037c8425159bfbc7b (patch)
tree836859b04ac645b124799600a709f34e954ce2ba /recipes/udns
parent777e10ed24f420cbba22c4850bd514f8d039ca36 (diff)
downloadopenembedded-5ae3348001d680637744864037c8425159bfbc7b.tar.gz
udns: New recipe
* udns is a stub DNS resolver library for sync and async DNS queries
Diffstat (limited to 'recipes/udns')
-rw-r--r--recipes/udns/files/fix-cc-check.patch36
-rw-r--r--recipes/udns/udns_0.0.9.bb31
2 files changed, 67 insertions, 0 deletions
diff --git a/recipes/udns/files/fix-cc-check.patch b/recipes/udns/files/fix-cc-check.patch
new file mode 100644
index 0000000000..0811849d0a
--- /dev/null
+++ b/recipes/udns/files/fix-cc-check.patch
@@ -0,0 +1,36 @@
+--- a/configure.lib 2007-01-07 21:59:09.000000000 +0100
++++ b/configure.lib 2010-03-04 11:38:32.000000000 +0100
+@@ -125,7 +125,7 @@
+ echo 'int main(int argc, char **argv) { return 0; }' >conftest.c
+
+ if [ -n "$CC" ]; then
+- if ac_run $CC -o conftest conftest.c && ac_run ./conftest; then
++ if ac_run $CC -o conftest conftest.c; then
+ ac_result "\$CC ($CC)"
+ else
+ ac_result no
+@@ -133,7 +133,7 @@
+ fi
+ else
+ for cc in gcc cc ; do
+- if ac_run $cc -o conftest conftest.c && ac_run ./conftest; then
++ if ac_run $cc -o conftest conftest.c; then
+ ac_result "$cc"
+ CC=$cc
+ break
+@@ -161,15 +161,6 @@
+ ccld="$cc"
+ if [ -n "$LDFLAGS" ]; then ccld="$ccld $LDFLAGS"; fi
+ if [ -n "$LIBS" ]; then ccld="$ccld $LIBS"; fi
+- if ac_yesno "whenever the C compiler ($ccld)
+- can produce executables" \
+- ac_compile_run <<EOF
+-int main() { return 0; }
+-EOF
+- then :
+- else
+- ac_fatal "no working C compiler found"
+- fi
+ LD='$(CC)'
+ [ -n "$AR" ] || AR=ar
+ [ -n "$ARFLAGS" ] || ARFLAGS=rv
diff --git a/recipes/udns/udns_0.0.9.bb b/recipes/udns/udns_0.0.9.bb
new file mode 100644
index 0000000000..ba95652855
--- /dev/null
+++ b/recipes/udns/udns_0.0.9.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "DNS Resolver Library"
+HOMEPAGE = "http://www.corpit.ru/mjt/udns.html"
+PR = "r0"
+
+SRC_URI = " \
+ http://www.corpit.ru/mjt/${PN}/${PN}_${PV}.tar.gz;name=udns \
+ file://fix-cc-check.patch;patch=1 \
+"
+SRC_URI[udns.md5sum] = "78843added6f6b690bc6019ab8ef03c9"
+SRC_URI[udns.sha256sum] = "cfc5f9b5387f96e48fc9c7aa5ef6511809e6c72c0df0d533cf150016816eaad2"
+
+S = ${WORKDIR}/${PN}-${PV}
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+# Package is using configure and Makefile.in, but not autotools in general ...
+
+do_configure() {
+ ./configure --disable-ipv6
+}
+
+do_compile() {
+ oe_runmake shared static
+}
+
+do_install() {
+ oe_libinstall -so -a libudns ${D}${libdir}
+ ln -s libudns.so.0 ${D}${libdir}/libudns_s.so
+ install -d ${D}${includedir}
+ install -m 0644 ${S}/udns.h ${D}${includedir}
+}