aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/uhd
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2010-12-03 06:18:57 -0500
committerPhilip Balister <philip@balister.org>2010-12-03 06:20:39 -0500
commit4b6f049e488b0e85f317d64b70af06920a1e2c47 (patch)
tree1187018f2e6a2c8d0dcc26aefb45920af0470764 /recipes/uhd
parent2abf626614c2baa2ca1e48c031d0641ce5c7cb2c (diff)
downloadopenembedded-4b6f049e488b0e85f317d64b70af06920a1e2c47.tar.gz
uhd-firmware : Convert to inc file and update recipe.
Recipe can now easily be updates when new fpga images are released. Package is arch all, since it the fpga firmware is not machine dependent in general.
Diffstat (limited to 'recipes/uhd')
-rw-r--r--recipes/uhd/uhd-firmware.inc20
-rw-r--r--recipes/uhd/uhd-firmware_0.1.bb20
-rw-r--r--recipes/uhd/uhd-firmware_0001.20101124013843.905f426.bb7
3 files changed, 27 insertions, 20 deletions
diff --git a/recipes/uhd/uhd-firmware.inc b/recipes/uhd/uhd-firmware.inc
new file mode 100644
index 0000000000..763aa6ca56
--- /dev/null
+++ b/recipes/uhd/uhd-firmware.inc
@@ -0,0 +1,20 @@
+DESCRIPTION = "Universal Hardware Driver Firmware"
+HOMEPAGE = "http://www.ettus.com"
+LICENSE = "GPLv3"
+
+INC_PR = "r0"
+
+PACKAGE_ARCH = "all"
+
+SRC_URI = "http://www.ettus.com/downloads/uhd_images/UHD-images-${PV}/UHD-images-${PV}-Linux.tar.gz"
+
+S = ${WORKDIR}/UHD-images-${PV}-Linux
+
+do_install() {
+ install -d ${D}${datadir}/uhd/images
+ install -m 0644 ${S}/share/uhd/images/* ${D}${datadir}/uhd/images
+}
+
+PACKAGES = "${PN}"
+FILES_${PN} = ${datadir}/uhd/images
+
diff --git a/recipes/uhd/uhd-firmware_0.1.bb b/recipes/uhd/uhd-firmware_0.1.bb
deleted file mode 100644
index aaedbc61c9..0000000000
--- a/recipes/uhd/uhd-firmware_0.1.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-DESCRIPTION = "Universal Hardware Driver Firmware"
-HOMEPAGE = "http://www.ettus.com"
-LICENSE = "GPLv3"
-
-SRC_URI = "http://www.ettus.com/downloads/uhd_images/UHD-images-20100901.003255.b5461fc%20--%20most%20recent/UHD-images-20100901.003255.b5461fc-Linux.tar.gz"
-
-# Yes, matching the directory name to package version is annoying
-S = ${WORKDIR}/UHD-images-20100901.003255.b5461fc-Linux
-
-do_install() {
- install -d ${D}${datadir}/uhd/images
- install -m 0644 ${S}/share/uhd/images/* ${D}${datadir}/uhd/images
-}
-
-PACKAGES = "${PN}"
-FILES_${PN} = ${datadir}/uhd/images
-
-SRC_URI[md5sum] = "8945f57993da07f18568145f17bb5927"
-SRC_URI[sha256sum] = "2a19fa33d5461b44ab25c2f80f4916269d320b8f58988d2d72a0865c1da93132"
-
diff --git a/recipes/uhd/uhd-firmware_0001.20101124013843.905f426.bb b/recipes/uhd/uhd-firmware_0001.20101124013843.905f426.bb
new file mode 100644
index 0000000000..c0e808dc53
--- /dev/null
+++ b/recipes/uhd/uhd-firmware_0001.20101124013843.905f426.bb
@@ -0,0 +1,7 @@
+require openembedded/recipes/uhd/uhd-firmware.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI[md5sum] = "6db20f93e3c4646395bd6e8260e2261f"
+SRC_URI[sha256sum] = "4c73655519cd9f4e49e5727f094b463850b03db13d91a8b0429b789e74a9deea"
+