aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ulxmlrpcpp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ulxmlrpcpp
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ulxmlrpcpp')
-rw-r--r--recipes/ulxmlrpcpp/files/disable-docs.patch15
-rw-r--r--recipes/ulxmlrpcpp/files/remove-local-includes.patch13
-rw-r--r--recipes/ulxmlrpcpp/ulxmlrpcpp_1.7.3.bb25
3 files changed, 53 insertions, 0 deletions
diff --git a/recipes/ulxmlrpcpp/files/disable-docs.patch b/recipes/ulxmlrpcpp/files/disable-docs.patch
new file mode 100644
index 0000000000..959e559c15
--- /dev/null
+++ b/recipes/ulxmlrpcpp/files/disable-docs.patch
@@ -0,0 +1,15 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- ulxmlrpcpp-1.5.2/ulxmlrpcpp/Makefile.am~disable-docs
++++ ulxmlrpcpp-1.5.2/ulxmlrpcpp/Makefile.am
+@@ -1,6 +1,6 @@
+ INCLUDES = -I. -I $(top_srcdir) $(all_includes) $(EA_EXTRA_INC)
+
+-SUBDIRS = . contrib docs tests po apps httpd
++SUBDIRS = . contrib tests po apps httpd
+
+ AM_CXXFLAGS = -DULXR_DATADIR=\"$(datadir)\" -DULXR_HAVE_CONFIG_H
+
diff --git a/recipes/ulxmlrpcpp/files/remove-local-includes.patch b/recipes/ulxmlrpcpp/files/remove-local-includes.patch
new file mode 100644
index 0000000000..13083c24aa
--- /dev/null
+++ b/recipes/ulxmlrpcpp/files/remove-local-includes.patch
@@ -0,0 +1,13 @@
+Index: ulxmlrpcpp-1.7.3/configure.in
+===================================================================
+--- ulxmlrpcpp-1.7.3.orig/configure.in
++++ ulxmlrpcpp-1.7.3/configure.in
+@@ -326,8 +326,6 @@ else
+ echo "*** ssl (OpenSSL) found."
+ echo "********************************************************"
+ AC_DEFINE(ULXR_INCLUDE_SSL_STUFF, 1, [Define to compile with ssl support.])
+- dnl should fix RedHat problem
+- EA_EXTRA_INC="$EA_EXTRA_INC -I/usr/include/kerberos/"
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <openssl/ssl.h>]], [[unsigned x = SSL_ERROR_WANT_ACCEPT; ]])],[AC_DEFINE(ULXR_HAVE_SSL_ERROR_WANT_ACCEPT, 1, Define if your ssl has SSL_ERROR_WANT_ACCEPT)
+ ],[])
+ fi
diff --git a/recipes/ulxmlrpcpp/ulxmlrpcpp_1.7.3.bb b/recipes/ulxmlrpcpp/ulxmlrpcpp_1.7.3.bb
new file mode 100644
index 0000000000..5ef98de4b2
--- /dev/null
+++ b/recipes/ulxmlrpcpp/ulxmlrpcpp_1.7.3.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "A lightweight C++ based library for XMLRPC applications"
+HOMEPAGE = "http://ulxmlrpcpp.sf.net"
+LICENSE = "LGPL"
+SECTION = "libs"
+DEPENDS = "expat"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/ulxmlrpcpp/ulxmlrpcpp-${PV}-src.tar.bz2 \
+ file://disable-docs.patch;patch=1 \
+ file://remove-local-includes.patch;patch=1"
+
+inherit autotools
+
+do_configure_append() {
+ echo "#define ulxr_snprintf snprintf" >>ulxmlrpcpp/ulxmlrpcpp.h
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+LEAD_SONAME = "libulxmlrpcpp.so"
+PACKAGES =+ "${PN}-examples ${PN}-contrib"
+FILES_${PN}-examples = "${bindir}/*"
+FILES_${PN}-contrib = "${libdir}/*contrib.so.*"