aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/unicap
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/unicap
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/unicap')
-rw-r--r--recipes/unicap/files/cross.patch12
-rw-r--r--recipes/unicap/files/pkgconfig.patch9
-rw-r--r--recipes/unicap/ucview_0.22.bb13
-rw-r--r--recipes/unicap/unicap_0.9.3.bb24
-rw-r--r--recipes/unicap/unicap_0.9.4.bb24
5 files changed, 82 insertions, 0 deletions
diff --git a/recipes/unicap/files/cross.patch b/recipes/unicap/files/cross.patch
new file mode 100644
index 0000000000..b8d01f2095
--- /dev/null
+++ b/recipes/unicap/files/cross.patch
@@ -0,0 +1,12 @@
+--- ucview-0.22/src/Makefile.am~ 2008-12-09 18:05:26.000000000 +0100
++++ ucview-0.22/src/Makefile.am 2008-12-09 18:05:26.000000000 +0100
+@@ -11,8 +11,7 @@
+
+
+ INCLUDES = \
+- -I$(top_srcdir) \
+- -I$(includedir)
++ -I$(top_srcdir)
+
+
+ BUILT_SOURCES = $(ucview_dbus_built_sources)
diff --git a/recipes/unicap/files/pkgconfig.patch b/recipes/unicap/files/pkgconfig.patch
new file mode 100644
index 0000000000..ce5ac2085f
--- /dev/null
+++ b/recipes/unicap/files/pkgconfig.patch
@@ -0,0 +1,9 @@
+--- unicap-0.9.3/libucil/libucil.pc.in~ 2008-10-17 21:40:01.000000000 +0200
++++ unicap-0.9.3/libucil/libucil.pc.in 2008-10-17 21:40:01.000000000 +0200
+@@ -5,5 +5,5 @@
+ Description: Unicap Imaging Library is a set of simple image processing functions
+ Version: @dist_version@
+ Libs: -L@libdir@ -lucil @GLIB_PACKAGE_LIBS@ @PANGO_PACKAGE_LIBS@ @AVCODEC_PACKAGE_LIBS@ @THEORA_PACKAGE_LIBS@ @PNG_PACKAGE_LIBS@ -lm
+-Cflags: -I@includedir@/unicap @GLIB_PACKAGE_CFLAGS@ @PANGO_PACKAGE_CFLAGS@ @AVCODEC_PACKAGE_CFLAGS@ @THEORA_PACKAGE_CFLAGS@ @PNG_PACKAGE_CFLAGS@
++Cflags: -I@includedir@/unicap
+ Requires: libunicap pangoft2 glib-2.0
diff --git a/recipes/unicap/ucview_0.22.bb b/recipes/unicap/ucview_0.22.bb
new file mode 100644
index 0000000000..e1f22b48c1
--- /dev/null
+++ b/recipes/unicap/ucview_0.22.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Simple camera capture GUI based on unicap."
+SECTION = "graphics"
+LICENSE = "GPL"
+DEPENDS = "intltool-native gtk+ libpng unicap gconf libglade gdk-pixbuf-csource-native"
+PR = "r1"
+
+SRC_URI = "http://www.unicap-imaging.org/downloads/${P}.tar.gz \
+ file://cross.patch;patch=1"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += " ${datadir}/dbus-1 ${datadir}/icons"
+FILES_${PN}-dbg += " ${libdir}/ucview/plugins/.debug"
diff --git a/recipes/unicap/unicap_0.9.3.bb b/recipes/unicap/unicap_0.9.3.bb
new file mode 100644
index 0000000000..7a1caa264f
--- /dev/null
+++ b/recipes/unicap/unicap_0.9.3.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "A uniform interface to video capture devices."
+SECTION = "graphics"
+LICENSE = "GPL"
+DEPENDS = "intltool-native gtk+ libpng libxv"
+PR = "r2"
+
+SRC_URI = "http://www.unicap-imaging.org/downloads/unicap-${PV}.tar.gz \
+ file://pkgconfig.patch;patch=1"
+
+inherit autotools pkgconfig
+
+do_stage () {
+ autotools_stage_all
+}
+
+PACKAGES += "libucil unicapgtk"
+
+FILES_${PN} = "${libdir}/libunicap.*so.* ${libdir}/unicap2/cpi/lib*.*so.* ${libdir}/unicap2/cpi/lib*.*so"
+FILES_${PN}-dev += " ${libdir}/unicap2/cpi/lib*.*a"
+FILES_${PN}-dbg += " ${libdir}/unicap2/cpi/.debug"
+FILES_libucil = "${libdir}/libucil*so.*"
+FILES_libucil-dev = "${libdir}/libucil*.so ${libdir}/libucil*.*a"
+FILES_unicapgtk = "${libdir}/libunicapgtk*so.*"
+FILES_unicapgtk-dev = "${libdir}/libunicapgtk*so.* ${libdir}/libunicapgtk*.*a"
diff --git a/recipes/unicap/unicap_0.9.4.bb b/recipes/unicap/unicap_0.9.4.bb
new file mode 100644
index 0000000000..0539318c29
--- /dev/null
+++ b/recipes/unicap/unicap_0.9.4.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "A uniform interface to video capture devices."
+SECTION = "graphics"
+LICENSE = "GPL"
+DEPENDS = "intltool-native gtk+ libpng libxv"
+PR = "r0"
+
+SRC_URI = "http://www.unicap-imaging.org/downloads/tisCMOS/unicap-${PV}.tar.gz \
+ file://pkgconfig.patch;patch=1"
+
+inherit autotools pkgconfig
+
+do_stage () {
+ autotools_stage_all
+}
+
+PACKAGES += "libucil unicapgtk"
+
+FILES_${PN} = "${libdir}/libunicap.*so.* ${libdir}/unicap2/cpi/lib*.*so.* ${libdir}/unicap2/cpi/lib*.*so"
+FILES_${PN}-dev += " ${libdir}/unicap2/cpi/lib*.*a"
+FILES_${PN}-dbg += " ${libdir}/unicap2/cpi/.debug"
+FILES_libucil = "${libdir}/libucil*so.*"
+FILES_libucil-dev = "${libdir}/libucil*.so ${libdir}/libucil*.*a"
+FILES_unicapgtk = "${libdir}/libunicapgtk*so.*"
+FILES_unicapgtk-dev = "${libdir}/libunicapgtk*so.* ${libdir}/libunicapgtk*.*a"