aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/unzip/unzip_552.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/unzip/unzip_552.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/unzip/unzip_552.bb')
-rw-r--r--recipes/unzip/unzip_552.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/unzip/unzip_552.bb b/recipes/unzip/unzip_552.bb
new file mode 100644
index 0000000000..2f06e1b1c6
--- /dev/null
+++ b/recipes/unzip/unzip_552.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "A (de)compression library for the ZIP format"
+SECTION = "console/utils"
+LICENSE = "Info-ZIP"
+PR = "r1"
+
+SRC_URI = "http://ftp.info-zip.org/pub/infozip/src/unzip${PV}.tar.gz"
+S = "${WORKDIR}/unzip-5.52"
+
+export LD = "${CC}"
+
+do_compile() {
+ oe_runmake -f unix/Makefile generic
+}
+
+do_install() {
+ oe_runmake -f unix/Makefile install prefix=${D}${prefix}
+ install -d ${D}${mandir}
+ mv ${D}${prefix}/man/* ${D}${mandir}
+}
+
+