aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/unzip
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2010-05-14 23:01:52 +0200
committerHenning Heinold <heinold@inf.fu-berlin.de>2010-05-14 23:05:07 +0200
commite0da0c67aab40f30d0cdefa5e51501c124320bf3 (patch)
treed11fa497f4c3e257091cd6a2ecfe420007d0857a /recipes/unzip
parent380b38b1afac8d6de049fc4e16b88b956667d45c (diff)
downloadopenembedded-e0da0c67aab40f30d0cdefa5e51501c124320bf3.tar.gz
unzip: use BBCLASSEXTEND now
* kudos to kergoth for the EXTRA_OEMAKE hint * no functional change so no PR bump
Diffstat (limited to 'recipes/unzip')
-rw-r--r--recipes/unzip/unzip-native_552.bb11
-rw-r--r--recipes/unzip/unzip_552.bb11
2 files changed, 9 insertions, 13 deletions
diff --git a/recipes/unzip/unzip-native_552.bb b/recipes/unzip/unzip-native_552.bb
deleted file mode 100644
index fcd5930368..0000000000
--- a/recipes/unzip/unzip-native_552.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-SECTION = "console/utils"
-inherit native
-require unzip_${PV}.bb
-
-do_stage() {
- install -d ${STAGING_BINDIR}
- install unzip ${STAGING_BINDIR}
-}
-
-SRC_URI[md5sum] = "9d23919999d6eac9217d1f41472034a9"
-SRC_URI[sha256sum] = "145d95e2ef1ef9add2e3c97d1340907e33ab8749eb1235372e7f0b7af600a8e9"
diff --git a/recipes/unzip/unzip_552.bb b/recipes/unzip/unzip_552.bb
index 87c284305e..de58ccd206 100644
--- a/recipes/unzip/unzip_552.bb
+++ b/recipes/unzip/unzip_552.bb
@@ -5,7 +5,11 @@ PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/project/infozip/UnZip%205.x%20and%20earlier/5.52/unzip${PV}.tar.gz"
S = "${WORKDIR}/unzip-5.52"
-export LD = "${CC} ${LDFLAGS}"
+BBCLASSEXTEND = "native"
+
+NATIVE_INSTALL_WORKS = "1"
+
+EXTRA_OEMAKE += "'LD=${CCLD} ${LDFLAGS}'"
do_compile() {
oe_runmake -f unix/Makefile generic
@@ -17,7 +21,10 @@ do_install() {
mv ${D}${prefix}/man/* ${D}${mandir}
}
-
+do_stage_virtclass-native() {
+ install -d ${STAGING_BINDIR}
+ install unzip ${STAGING_BINDIR}
+}
SRC_URI[md5sum] = "9d23919999d6eac9217d1f41472034a9"
SRC_URI[sha256sum] = "145d95e2ef1ef9add2e3c97d1340907e33ab8749eb1235372e7f0b7af600a8e9"