aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/update-rc.d
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/update-rc.d
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/update-rc.d')
-rw-r--r--recipes/update-rc.d/files/add-verbose.patch47
-rw-r--r--recipes/update-rc.d/update-rc.d_0.7.bb23
2 files changed, 70 insertions, 0 deletions
diff --git a/recipes/update-rc.d/files/add-verbose.patch b/recipes/update-rc.d/files/add-verbose.patch
new file mode 100644
index 0000000000..0f068308f6
--- /dev/null
+++ b/recipes/update-rc.d/files/add-verbose.patch
@@ -0,0 +1,47 @@
+--- update-rc.d/update-rc.d.org 2005-01-03 00:30:47.000000000 +0200
++++ update-rc.d/update-rc.d 2007-12-01 19:41:08.000000000 +0200
+@@ -19,6 +19,7 @@
+ notreally=0
+ force=0
+ dostart=0
++verbose=0
+
+ usage()
+ {
+@@ -28,6 +29,7 @@
+ update-rc.d [-n] [-r <root>] [-s] <basename> start|stop NN runlvl [runlvl] [...] .
+ -n: not really
+ -f: force
++ -v: verbose
+ -r: alternate root path (default is /)
+ -s: invoke start methods if appropriate to current runlevel
+ EOF
+@@ -69,7 +71,7 @@
+ lev=`echo $2 | cut -d/ -f1`
+ nn=`echo $2 | cut -d/ -f2`
+ fn="${etcd}${lev}.d/${startstop}${nn}${bn}"
+- echo " $fn -> ../init.d/$bn"
++ [ $verbose -eq 1 ] && echo " $fn -> ../init.d/$bn"
+ if [ $notreally -eq 0 ]; then
+ mkdir -p `dirname $fn`
+ ln -s ../init.d/$bn $fn
+@@ -89,7 +91,7 @@
+ exit 0
+ fi
+
+- echo " Adding system startup for $initd/$bn ..."
++ echo " Adding system startup for $initd/$bn."
+
+ for i in $startlinks; do
+ dolink S $i
+@@ -105,6 +107,10 @@
+ shift
+ continue
+ ;;
++ -v) verbose=1
++ shift
++ continue
++ ;;
+ -f) force=1
+ shift
+ continue
diff --git a/recipes/update-rc.d/update-rc.d_0.7.bb b/recipes/update-rc.d/update-rc.d_0.7.bb
new file mode 100644
index 0000000000..dd370e6ff8
--- /dev/null
+++ b/recipes/update-rc.d/update-rc.d_0.7.bb
@@ -0,0 +1,23 @@
+SECTION = "base"
+PRIORITY = "standard"
+DESCRIPTION = "Manage symlinks in /etc/rcN.d"
+LICENSE = "GPL"
+S = "${WORKDIR}/update-rc.d"
+PR = "r1"
+
+SRC_URI = "${HANDHELDS_CVS};module=apps/update-rc.d;tag=r0_7 \
+ file://add-verbose.patch;patch=1"
+
+PACKAGE_ARCH = "all"
+
+do_compile() {
+}
+
+do_stage() {
+ install -m 0755 ${S}/update-rc.d ${STAGING_BINDIR_NATIVE}/
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 ${S}/update-rc.d ${D}${sbindir}/update-rc.d
+}