aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/upslug
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/upslug
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/upslug')
-rw-r--r--recipes/upslug/upslug-native_1.0.bb28
-rw-r--r--recipes/upslug/upslug-native_cvs.bb27
-rw-r--r--recipes/upslug/upslug2-cvs.inc10
-rw-r--r--recipes/upslug/upslug2-native_11.bb2
-rw-r--r--recipes/upslug/upslug2-native_8.bb2
-rw-r--r--recipes/upslug/upslug2.inc30
-rw-r--r--recipes/upslug/upslug2_10.bb1
-rw-r--r--recipes/upslug/upslug2_11.bb1
-rw-r--r--recipes/upslug/upslug2_8.bb1
9 files changed, 102 insertions, 0 deletions
diff --git a/recipes/upslug/upslug-native_1.0.bb b/recipes/upslug/upslug-native_1.0.bb
new file mode 100644
index 0000000000..02c41eb42b
--- /dev/null
+++ b/recipes/upslug/upslug-native_1.0.bb
@@ -0,0 +1,28 @@
+# This package builds the 'upslug' binary upload/flash tool
+# for the NSLU2. It is not useful for anything else.
+PR = "r1"
+DESCRIPTION = "NSLU2 binary upload tool"
+HOMEPAGE = "http://www.nslu2-linux.org/wiki/Main/UpSlug"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+COMPATIBLE_MACHINE = "nslu2"
+
+SRC_TAG = "UPSLUG_${@'_'.join(bb.data.getVar('PV',d,1).split('.'))}"
+SRC_URI = "cvs://anonymous@nslu.cvs.sourceforge.net/cvsroot/nslu;method=pserver;module=upslug;tag=${SRC_TAG}"
+# For testing use this (tags and other changes take a day to
+# propogate on sourceforge). Change 'jbowler' to your login name!
+#SRC_URI = "cvs://jbowler@cvs.sourceforge.net/cvsroot/nslu;method=ext;rsh=ssh;tag=${SRC_TAG};module=upslug"
+
+inherit native
+
+S = "${WORKDIR}/upslug"
+
+# Dumb compile script
+do_compile() {
+ oe_runmake "CC=${CC}" "CFLAGS=${CFLAGS}"
+}
+
+do_stage() {
+ oe_runmake "DESTDIR=${STAGING_BINDIR}" install
+}
diff --git a/recipes/upslug/upslug-native_cvs.bb b/recipes/upslug/upslug-native_cvs.bb
new file mode 100644
index 0000000000..e0d7f2b708
--- /dev/null
+++ b/recipes/upslug/upslug-native_cvs.bb
@@ -0,0 +1,27 @@
+# This package builds the 'upslug' binary upload/flash tool
+# for the NSLU2. It is not useful for anything else.
+PR = "r1"
+DESCRIPTION = "NSLU2 binary upload tool"
+HOMEPAGE = "http://www.nslu2-linux.org/wiki/Main/UpSlug"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+COMPATIBLE_MACHINE = "nslu2"
+
+# Use releases in preference
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "cvs://anonymous@nslu.cvs.sourceforge.net/cvsroot/nslu;method=pserver;module=upslug"
+
+inherit native
+
+S = "${WORKDIR}/upslug"
+
+# Dumb compile script
+do_compile() {
+ oe_runmake "CC=${CC}" "CFLAGS=${CFLAGS}"
+}
+
+do_stage() {
+ oe_runmake "DESTDIR=${STAGING_BINDIR}" install
+}
diff --git a/recipes/upslug/upslug2-cvs.inc b/recipes/upslug/upslug2-cvs.inc
new file mode 100644
index 0000000000..995f9dc5ab
--- /dev/null
+++ b/recipes/upslug/upslug2-cvs.inc
@@ -0,0 +1,10 @@
+# Overrides for a CVS build
+include upslug2.inc
+
+SRC_TAG = "upslug2_${@'_'.join(bb.data.getVar('PV',d,1).split('.'))}"
+SRC_URI = "cvs://anonymous@nslu.cvs.sourceforge.net/cvsroot/nslu;method=pserver;module=upslug2;tag=${SRC_TAG}"
+# For testing use this (tags and other changes take a day to
+# propogate on sourceforge). Change 'jbowler' to your login name!
+#SRC_URI = "cvs://jbowler@nslu.cvs.sourceforge.net/cvsroot/nslu;method=ext;rsh=ssh;module=upslug2;tag=${SRC_TAG}"
+
+S = "${WORKDIR}/upslug2"
diff --git a/recipes/upslug/upslug2-native_11.bb b/recipes/upslug/upslug2-native_11.bb
new file mode 100644
index 0000000000..51b660b4f3
--- /dev/null
+++ b/recipes/upslug/upslug2-native_11.bb
@@ -0,0 +1,2 @@
+require upslug2_${PV}.bb
+inherit native
diff --git a/recipes/upslug/upslug2-native_8.bb b/recipes/upslug/upslug2-native_8.bb
new file mode 100644
index 0000000000..42d2c64dcb
--- /dev/null
+++ b/recipes/upslug/upslug2-native_8.bb
@@ -0,0 +1,2 @@
+require upslug2_8.bb
+inherit native
diff --git a/recipes/upslug/upslug2.inc b/recipes/upslug/upslug2.inc
new file mode 100644
index 0000000000..1450cf26a0
--- /dev/null
+++ b/recipes/upslug/upslug2.inc
@@ -0,0 +1,30 @@
+# This package builds the 'upslug2' binary upload/flash tool
+# for the NSLU2. It is not useful for anything else.
+PR = "r1"
+DESCRIPTION = "NSLU2 binary upload tool (version 2)"
+HOMEPAGE = "http://www.nslu2-linux.org/wiki/Main/UpSlug2"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "MIT"
+COMPATIBLE_MACHINE = "nslu2"
+
+# On Linux libpcap does not work. Using libpcap is sub-optimal - it
+# is intended for packet capture not management of a new protocol
+# stream - so you may want to try the linux options on other operating
+# systems.
+LIBPCAP_OECONF = "--with-libpcap"
+LIBPCAP_OECONF_linux = ""
+LIBPCAP_OECONF_linux-uclibc = ""
+LIBPCAP_RDEPENDS = "libpcap"
+LIBPCAP_RDEPENDS_linux = ""
+LIBPCAP_RDEPENDS_linux-uclibc = ""
+
+RDEPENDS += "${LIBPCAP_RDEPENDS}"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/nslu/upslug2-${PV}.tar.gz"
+
+inherit autotools
+
+S = "${WORKDIR}/upslug2-${PV}"
+
+EXTRA_OECONF += "${LIBPCAP_OECONF}"
diff --git a/recipes/upslug/upslug2_10.bb b/recipes/upslug/upslug2_10.bb
new file mode 100644
index 0000000000..e4f834083d
--- /dev/null
+++ b/recipes/upslug/upslug2_10.bb
@@ -0,0 +1 @@
+require upslug2.inc
diff --git a/recipes/upslug/upslug2_11.bb b/recipes/upslug/upslug2_11.bb
new file mode 100644
index 0000000000..e4f834083d
--- /dev/null
+++ b/recipes/upslug/upslug2_11.bb
@@ -0,0 +1 @@
+require upslug2.inc
diff --git a/recipes/upslug/upslug2_8.bb b/recipes/upslug/upslug2_8.bb
new file mode 100644
index 0000000000..e4f834083d
--- /dev/null
+++ b/recipes/upslug/upslug2_8.bb
@@ -0,0 +1 @@
+require upslug2.inc