summaryrefslogtreecommitdiffstats
path: root/recipes/uqm/uqm_0.5.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/uqm/uqm_0.5.0.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/uqm/uqm_0.5.0.bb')
-rw-r--r--recipes/uqm/uqm_0.5.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/uqm/uqm_0.5.0.bb b/recipes/uqm/uqm_0.5.0.bb
new file mode 100644
index 0000000000..089922a472
--- /dev/null
+++ b/recipes/uqm/uqm_0.5.0.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Star Control 2 source port using SDL (see sc2.sourceforge.net)"
+SECTION = "games"
+PRIORITY = "optional"
+DEPENDS = "virtual/libsdl libsdl-image libsdl-net libvorbis libogg zlib"
+SECTION = "games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+PR = "r2"
+
+S = "${WORKDIR}/uqm-${PV}"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/sc2/uqm-${PV}-source.tar.gz \
+ file://build-opts.sh \
+ file://build-oe.patch;patch=1;pnum=0 \
+"
+
+do_configure() {
+ install ${WORKDIR}/build-opts.sh ${S}/
+ ./build-opts.sh ${STAGING_DIR_HOST}${layout_prefix} ${STAGING_BINDIR} ${STAGING_LIBDIR}
+}
+
+do_compile() {
+ export ARCH="${TARGET_ARCH}"
+ export CC="${CC}"
+ export STAGING_INCDIR="${STAGING_INCDIR}"
+ export STAGING_LIBDIR="${STAGING_LIBDIR}"
+ ./build.sh uqm
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 uqm ${D}${bindir}
+}