aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/usb-modeswitch
diff options
context:
space:
mode:
authorEvan Doiron <edoiron@cbnco.com>2009-08-26 08:14:27 +0000
committerMichael Smith <msmith@cbnco.com>2009-08-31 11:57:56 -0400
commit72834ed878dae08dd62c68e14dcebfe3c9bad791 (patch)
tree1d934f4b7e53341ee0040947bcbb076a0aed128f /recipes/usb-modeswitch
parent91c6116d7fc0d138eccb979f1135ee686fe38bbb (diff)
downloadopenembedded-72834ed878dae08dd62c68e14dcebfe3c9bad791.tar.gz
usb-modeswitch: add v1.0.2
Signed-off-by: Evan Doiron <edoiron@cbnco.com> Signed-off-by: Michael Smith <msmith@cbnco.com> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/usb-modeswitch')
-rw-r--r--recipes/usb-modeswitch/usb-modeswitch_1.0.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/usb-modeswitch/usb-modeswitch_1.0.2.bb b/recipes/usb-modeswitch/usb-modeswitch_1.0.2.bb
new file mode 100644
index 0000000000..3919106a95
--- /dev/null
+++ b/recipes/usb-modeswitch/usb-modeswitch_1.0.2.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "A mode switching tool for controlling 'flip flop' (multiple device) USB gear"
+SECTION = "base"
+PRIORITY = "required"
+LICENSE = "GPLv2"
+DEPENDS = "virtual/libusb0"
+
+SRC_URI = "http://www.draisberghof.de/usb_modeswitch/usb_modeswitch-${PV}.tar.bz2"
+
+S = "${WORKDIR}/usb_modeswitch-${PV}"
+
+PACKAGES = "${PN}"
+FILES_${PN} = "${bindir} ${sysconfdir}"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${sysconfdir}
+ install -m 0755 ${S}/usb_modeswitch ${D}${bindir}/usb_modeswitch
+ install -m 0644 ${S}/usb_modeswitch.conf ${D}${sysconfdir}/usb_modeswitch.conf
+}