aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/usbview
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/usbview
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/usbview')
-rw-r--r--recipes/usbview/usbview/gtk2.patch21
-rw-r--r--recipes/usbview/usbview_1.0.bb15
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes/usbview/usbview/gtk2.patch b/recipes/usbview/usbview/gtk2.patch
new file mode 100644
index 0000000000..e0ec4e9940
--- /dev/null
+++ b/recipes/usbview/usbview/gtk2.patch
@@ -0,0 +1,21 @@
+--- usbview-1.0/configure.in.orig 2006-07-18 14:31:32.000000000 -0600
++++ usbview-1.0/configure.in 2006-07-18 14:31:58.000000000 -0600
+@@ -9,7 +9,7 @@
+ AM_PROG_CC_STDC
+ AC_HEADER_STDC
+
+-AM_PATH_GTK(1.2.0, ,
++AM_PATH_GTK_2_0(1.2.0, ,
+ AC_MSG_ERROR(Cannot find GTK: Is gtk-config in path?))
+
+
+--- usbview-1.0/usbtree.c.orig 2006-07-18 14:36:39.996545080 -0600
++++ usbview-1.0/usbtree.c 2006-07-18 14:36:54.531335456 -0600
+@@ -31,6 +31,7 @@
+ #include <sys/stat.h>
+ #include <unistd.h>
+ #include <errno.h>
++#define GTK_ENABLE_BROKEN
+ #include <gtk/gtk.h>
+
+ #include "usbtree.h"
diff --git a/recipes/usbview/usbview_1.0.bb b/recipes/usbview/usbview_1.0.bb
new file mode 100644
index 0000000000..27d3c713dd
--- /dev/null
+++ b/recipes/usbview/usbview_1.0.bb
@@ -0,0 +1,15 @@
+# usbview .bb build file
+# Copyright (C) 2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see /COPYING)
+
+DESCRIPTION="USBView is a GTK program that displays the topography of the \
+ devices that are plugged into the USB bus on a Linux machine."
+HOMEPAGE="http://www.kroah.com/linux-usb/"
+LICENSE="GPL"
+
+SRC_URI="http://www.kroah.com/linux-usb/${PN}-${PV}.tar.gz \
+ file://gtk2.patch;patch=1"
+
+DEPENDS="gtk+ pango glib-2.0 cairo atk"
+
+inherit autotools