aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/util-linux-ng/files/fix-make-c.patch
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-05-18 13:01:00 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-18 14:00:43 +0200
commit3d1136959ad0b77bdb37a418f17925bd5b8bcd05 (patch)
tree1f9ad00734ec3e5dacd0181f471c4f5916e4123a /recipes/util-linux-ng/files/fix-make-c.patch
parent7790e2eda389c53cdad3568785581669579f51ed (diff)
downloadopenembedded-3d1136959ad0b77bdb37a418f17925bd5b8bcd05.tar.gz
util-linux-ng 2.15: stage libblkid (yes, this used to be in e2fsprogs(-libs))
Diffstat (limited to 'recipes/util-linux-ng/files/fix-make-c.patch')
-rw-r--r--recipes/util-linux-ng/files/fix-make-c.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes/util-linux-ng/files/fix-make-c.patch b/recipes/util-linux-ng/files/fix-make-c.patch
new file mode 100644
index 0000000000..bf1082e85c
--- /dev/null
+++ b/recipes/util-linux-ng/files/fix-make-c.patch
@@ -0,0 +1,41 @@
+From: Karel Zak <kzak@redhat.com>
+Date: Mon, 11 May 2009 09:49:00 +0000 (+0200)
+Subject: build-sys: fix "make -C" bug
+X-Git-Url: http://git.kernel.org/?p=utils%2Futil-linux-ng%2Futil-linux-ng.git;a=commitdiff_plain;h=2ef7d41e6bbb7c842c06e911ffc562335a467b5d
+
+build-sys: fix "make -C" bug
+
+Running:
+
+./configure --with-fsprobe=builtin
+make -C mount mount
+
+causes the following error:
+
+gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I.. -include ../config.h
+-I../include -DLOCALEDIR=\"/home/matthew/util-linux-ng/share/locale\"
+-fsigned-char -I../libs/blkid/src -g -O2 -MT mount-setproctitle.o
+-MD -MP -MF .deps/mount-setproctitle.Tpo -c -o mount-setproctitle.o
+`test -f '../lib/setproctitle.c' || echo './'`../lib/setproctitle.c mv
+-f .deps/mount-setproctitle.Tpo .deps/mount-setproctitle.Po
+make -C
+make: option requires an argument -- 'C'
+Usage: make [options] [target] ...
+...
+
+Reported-by: Matthew Burgess <matthew@linuxfromscratch.org>
+Signed-off-by: Karel Zak <kzak@redhat.com>
+---
+
+diff --git a/config/include-Makefile.am b/config/include-Makefile.am
+index b42a0c3..d5da619 100644
+--- a/config/include-Makefile.am
++++ b/config/include-Makefile.am
+@@ -17,6 +17,7 @@ dist_noinst_DATA = $(dist_man_MANS)
+ # Paths to in-tree libraries (use ul_ prefix to avoid possible collisions)
+ #
+ ul_libblkid_srcdir = $(top_srcdir)/libs/blkid/src
++ul_libblkid_builddir = $(top_builddir)/libs/blkid/src
+ ul_libblkid_la = $(top_builddir)/libs/blkid/src/libblkid.la
+
+ $(ul_libblkid_la):