aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/util-linux-ng
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2009-07-02 00:08:40 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2009-07-02 00:18:38 +0200
commit08e6f4644209958239e9bc745ada27a7eb2e4882 (patch)
tree525c3f6684944a759d73ea949f50f5f9298f36de /recipes/util-linux-ng
parent11ac596fc326167f02186b8b50026c401896a137 (diff)
downloadopenembedded-08e6f4644209958239e9bc745ada27a7eb2e4882.tar.gz
util-linux-ng: Fix compile of 2.15 for uclibc
Unconditionally include stdarg.h to introduce va_list to the compiler. uclibc has langinfo but not these kind of attributes. Guard the usage of these attribute similar to how the uclibc locale test program is doing it.
Diffstat (limited to 'recipes/util-linux-ng')
-rw-r--r--recipes/util-linux-ng/files/uclibc-compile.patch25
-rw-r--r--recipes/util-linux-ng/util-linux-ng_2.15.bb1
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes/util-linux-ng/files/uclibc-compile.patch b/recipes/util-linux-ng/files/uclibc-compile.patch
new file mode 100644
index 0000000000..def2336047
--- /dev/null
+++ b/recipes/util-linux-ng/files/uclibc-compile.patch
@@ -0,0 +1,25 @@
+Index: util-linux-ng-2.15/libs/blkid/src/blkidP.h
+===================================================================
+--- util-linux-ng-2.15.orig/libs/blkid/src/blkidP.h 2009-07-01 23:09:57.000000000 +0200
++++ util-linux-ng-2.15/libs/blkid/src/blkidP.h 2009-07-01 23:10:09.000000000 +0200
+@@ -18,6 +18,7 @@
+
+ #include <sys/types.h>
+ #include <stdio.h>
++#include <stdarg.h>
+
+ #include "bitops.h" /* $(top_srcdir)/include/ */
+ #include "blkid.h"
+Index: util-linux-ng-2.15/misc-utils/cal.c
+===================================================================
+--- util-linux-ng-2.15.orig/misc-utils/cal.c 2009-07-01 23:16:54.000000000 +0200
++++ util-linux-ng-2.15/misc-utils/cal.c 2009-07-01 23:17:08.000000000 +0200
+@@ -291,7 +291,7 @@
+ * the locale database, which can be overridden with the
+ * -s (Sunday) or -m (Monday) options.
+ */
+-#ifdef HAVE_LANGINFO_H
++#if defined(HAVE_LANGINFO_H) && !defined(__UCLIBC__)
+ /*
+ * You need to use 2 locale variables to get the first day of the week.
+ * This is needed to support first_weekday=2 and first_workday=1 for
diff --git a/recipes/util-linux-ng/util-linux-ng_2.15.bb b/recipes/util-linux-ng/util-linux-ng_2.15.bb
index 1e36dd3ffc..0c2416fd16 100644
--- a/recipes/util-linux-ng/util-linux-ng_2.15.bb
+++ b/recipes/util-linux-ng/util-linux-ng_2.15.bb
@@ -4,6 +4,7 @@ PR = "${INC_PR}"
SRC_URI += "file://fix-make-c.patch;patch=1 \
file://optional-uuid.patch;patch=1 \
+ file://uclibc-compile.patch;patch=1 \
"
LDFLAGS_append = " -luuid"