aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/util-linux-ng
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-06-20 11:06:21 +0200
committerKoen Kooi <koen@openembedded.org>2009-06-20 11:06:21 +0200
commit4926fc282489d6dcd8c618100a74f6f24897dbfe (patch)
tree1bf3e3ec96ab2686df9f550176dfd89b857ddf03 /recipes/util-linux-ng
parentb52781c95e58c89e20f68c3f5cceccd85761aa2b (diff)
downloadopenembedded-4926fc282489d6dcd8c618100a74f6f24897dbfe.tar.gz
util-linux-ng: fix packaging, u-a and replace hardcoded paths
* also switch to INC_PR to make Tom happy
Diffstat (limited to 'recipes/util-linux-ng')
-rw-r--r--recipes/util-linux-ng/util-linux-ng.inc21
-rw-r--r--recipes/util-linux-ng/util-linux-ng_2.13.1.bb2
-rw-r--r--recipes/util-linux-ng/util-linux-ng_2.14.bb2
-rw-r--r--recipes/util-linux-ng/util-linux-ng_2.15.bb2
4 files changed, 15 insertions, 12 deletions
diff --git a/recipes/util-linux-ng/util-linux-ng.inc b/recipes/util-linux-ng/util-linux-ng.inc
index 8b526efd95..9bfcc03e43 100644
--- a/recipes/util-linux-ng/util-linux-ng.inc
+++ b/recipes/util-linux-ng/util-linux-ng.inc
@@ -8,6 +8,8 @@ AUTOTOOLS_STAGE_PKGCONFIG = "1"
DEFAULT_PREFERENCE = "-1"
+INC_PR = "r6"
+
# allows for a release candidate
RC ?= ""
@@ -19,14 +21,14 @@ PACKAGES_DYNAMIC = "libblkid*"
FILES_${PN}-doc += "/usr/share/misc/getopt/getopt-*.*"
FILES_${PN} = "${bindir} ${sbindir} ${base_bindir} ${base_sbindir}"
-FILES_util-linux-ng-fdisk = "/sbin/fdisk.${PN}"
-FILES_util-linux-ng-cfdisk = "/sbin/cfdisk"
-FILES_util-linux-ng-sfdisk = "/sbin/sfdisk"
-FILES_util-linux-ng-swaponoff = "/sbin/swapon.${PN} /sbin/swapoff.${PN}"
-FILES_util-linux-ng-losetup = "/sbin/losetup.${PN}"
-FILES_util-linux-ng-mount = "/bin/mount.${PN} ${sysconfdir}/default/mountall"
-FILES_util-linux-ng-umount = "/bin/umount.${PN}"
-FILES_util-linux-ng-readprofile = "/usr/sbin/readprofile.${PN}"
+FILES_util-linux-ng-fdisk = "${base_sbindir}/fdisk.${PN}"
+FILES_util-linux-ng-cfdisk = "${base_sbindir}/cfdisk"
+FILES_util-linux-ng-sfdisk = "${base_sbindir}/sfdisk"
+FILES_util-linux-ng-swaponoff = "${base_sbindir}/swapon.${PN} ${base_sbindir}/swapoff.${PN}"
+FILES_util-linux-ng-losetup = "${base_sbindir}/losetup.${PN}"
+FILES_util-linux-ng-mount = "${base_bindir}/mount.${PN} ${sysconfdir}/default/mountall"
+FILES_util-linux-ng-umount = "${base_bindir}/umount.${PN}"
+FILES_util-linux-ng-readprofile = "${sbindir}/readprofile.${PN}"
PACKAGES =+ "${PN}-mountall"
FILES_${PN}-mountall = "${sysconfdir}/default/mountall"
@@ -129,7 +131,8 @@ do_install () {
install -d ${D}${sysconfdir}/default/
echo 'MOUNTALL="-t nonfs,nosmbfs,noncpfs"' > ${D}${sysconfdir}/default/mountall
- ln -sf ${sbindir}/swapon ${D}${sbindir}/swapoff.${PN}
+ rm ${D}${sbindir}/swap* -f
+ ln -sf ${base_sbindir}/swapon.${PN} ${D}${base_sbindir}/swapoff.${PN}
ln -sf ${sbindir}/shutdown ${D}${sbindir}/reboot.${PN}
ln -sf ${sbindir}/shutdown ${D}${sbindir}/halt.${PN}
ln -sf ${sbindir}/shutdown ${D}${sbindir}/fastboot
diff --git a/recipes/util-linux-ng/util-linux-ng_2.13.1.bb b/recipes/util-linux-ng/util-linux-ng_2.13.1.bb
index 8fded14fbe..c239b15226 100644
--- a/recipes/util-linux-ng/util-linux-ng_2.13.1.bb
+++ b/recipes/util-linux-ng/util-linux-ng_2.13.1.bb
@@ -5,4 +5,4 @@ SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/util-linux-ng/v2.13/util-linux-ng
#SRC_URI += "file://glibc-fix.patch;patch=1"
#SRC_URI += "file://glibc-umount2.patch;patch=1"
-PR = "r1"
+PR = "${INC_PR}"
diff --git a/recipes/util-linux-ng/util-linux-ng_2.14.bb b/recipes/util-linux-ng/util-linux-ng_2.14.bb
index 6ba26304c0..d7eafd3602 100644
--- a/recipes/util-linux-ng/util-linux-ng_2.14.bb
+++ b/recipes/util-linux-ng/util-linux-ng_2.14.bb
@@ -1,6 +1,6 @@
require util-linux-ng.inc
-PR = "r5"
+PR = "${INC_PR}"
SRC_URI += "file://util-linux-ng-uclibc-versionsort.patch;patch=1 \
file://util-linux-ng-replace-siginterrupt.patch;patch=1 \
diff --git a/recipes/util-linux-ng/util-linux-ng_2.15.bb b/recipes/util-linux-ng/util-linux-ng_2.15.bb
index c52fc75e34..1e36dd3ffc 100644
--- a/recipes/util-linux-ng/util-linux-ng_2.15.bb
+++ b/recipes/util-linux-ng/util-linux-ng_2.15.bb
@@ -1,6 +1,6 @@
require util-linux-ng.inc
-PR = "r3"
+PR = "${INC_PR}"
SRC_URI += "file://fix-make-c.patch;patch=1 \
file://optional-uuid.patch;patch=1 \