aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/util-linux-ng
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-05-18 14:39:35 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-18 14:39:35 +0200
commit61f0ac5601f6c03871d084f879ef618664d9b2c6 (patch)
tree6af40b2415192d7f53e706e6f2678a0557dc25eb /recipes/util-linux-ng
parent38cea1ff24566d5f50bcaa4a208947b7ee14b7e8 (diff)
downloadopenembedded-61f0ac5601f6c03871d084f879ef618664d9b2c6.tar.gz
util-linux-ng: split out libs to avoid collision with e2fsprog-libs
Diffstat (limited to 'recipes/util-linux-ng')
-rw-r--r--recipes/util-linux-ng/util-linux-ng.inc17
-rw-r--r--recipes/util-linux-ng/util-linux-ng_2.15.bb2
2 files changed, 16 insertions, 3 deletions
diff --git a/recipes/util-linux-ng/util-linux-ng.inc b/recipes/util-linux-ng/util-linux-ng.inc
index b49a0b2e21..ea5808160d 100644
--- a/recipes/util-linux-ng/util-linux-ng.inc
+++ b/recipes/util-linux-ng/util-linux-ng.inc
@@ -1,9 +1,10 @@
DESCRIPTION = "Util-linux-ng is a suite of essential utilities for any Linux system."
SECTION = "base"
LICENSE = "GPL"
-DEPENDS = "udev zlib ncurses e2fsprogs-libs virtual/libintl"
+DEPENDS = "udev zlib ncurses util-linux-ng virtual/libintl"
inherit autotools_stage
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
DEFAULT_PREFERENCE = "-1"
@@ -15,6 +16,7 @@ SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/util-linux-ng/v${PV}/util-linux-n
PACKAGES =+ "util-linux-ng-fdisk util-linux-ng-cfdisk util-linux-ng-sfdisk util-linux-ng-swaponoff util-linux-ng-losetup util-linux-ng-umount util-linux-ng-mount util-linux-ng-readprofile "
FILES_${PN}-doc += "/usr/share/misc/getopt/getopt-*.*"
+FILES_${PN} = "${bindir} ${sbindir} ${base_bindir} ${base_sbindir}"
FILES_util-linux-ng-fdisk = "/sbin/fdisk.${PN}"
FILES_util-linux-ng-cfdisk = "/sbin/cfdisk"
@@ -30,7 +32,8 @@ RDEPENDS_${PN} = "util-linux-ng-umount util-linux-ng-swaponoff util-linux-ng-los
EXTRA_OECONF = "--disable-use-tty-group --disable-makeinstall-chown \
--enable-kill --enable-last --enable-mesg --enable-raw --enable-login-utils \
---enable-arch --enable-init"
+--enable-arch --enable-init --enable-partx --enable-schedutils \
+--with-fsprobe=builtin"
S = "${WORKDIR}/util-linux-ng-${PV}${RC}"
@@ -118,6 +121,16 @@ do_install () {
ln -sf ${sbindir}/shutdown ${D}${sbindir}/fasthalt
}
+python populate_packages_prepend () {
+ cv_libdir = bb.data.expand('${libdir}', d)
+ cv_libdir_dbg = bb.data.expand('${libdir}/.debug', d)
+ do_split_packages(d, cv_libdir, '^lib(.*)\.so$', 'lib%s-dev', 'util-linux-ng %s development package', extra_depends='${PN}-dev', allow_links=True)
+ do_split_packages(d, cv_libdir, '^lib(.*)\.la$', 'lib%s-dev', 'util-linux-ng %s development package', extra_depends='${PN}-dev')
+ do_split_packages(d, cv_libdir, '^lib(.*)\.a$', 'lib%s-dev', 'util-linux-ng %s development package', extra_depends='${PN}-dev')
+ do_split_packages(d, cv_libdir, '^lib(.*)\.so\.*', 'lib%s', 'util-linux-ng %s library', extra_depends='', allow_links=True)
+}
+
+
pkg_postinst_${PN} () {
update-alternatives --install ${base_bindir}/dmesg dmesg dmesg.${PN} 100
update-alternatives --install ${base_bindir}/kill kill kill.${PN} 100
diff --git a/recipes/util-linux-ng/util-linux-ng_2.15.bb b/recipes/util-linux-ng/util-linux-ng_2.15.bb
index 2486e402f0..c4971b1404 100644
--- a/recipes/util-linux-ng/util-linux-ng_2.15.bb
+++ b/recipes/util-linux-ng/util-linux-ng_2.15.bb
@@ -1,6 +1,6 @@
require util-linux-ng.inc
-PR = "r1"
+PR = "r2"
SRC_URI += "file://fix-make-c.patch;patch=1 \
file://optional-uuid.patch;patch=1 \