aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/vim/vim_7.2.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@buglabs.net>2010-04-01 19:06:55 +0200
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-04-01 19:12:07 +0200
commit53c1e459d24cffbcb4b7e4886a69f91fa5c7c4b7 (patch)
tree5a9361d7b81fcd7880ee68119016eaefa3bf3e73 /recipes/vim/vim_7.2.bb
parent90a0e239a579edbd7747e610a85c9e5b556263e8 (diff)
downloadopenembedded-53c1e459d24cffbcb4b7e4886a69f91fa5c7c4b7.tar.gz
vim: updated to 7.2.394, dropped older versions, cleaned recipes
I added 394 upstream patches to vim into metadata as checksums for them would be bigger then patch itself. Older (6.2, 6.4, 7.0) versions got dropped as they can have security problems and no one maintains them. Recipes for 7.2 got cleaned - we have gvim, vim-tiny and vim now. Main code is split between vim.inc and vim_7.2.bb files. Adding new variants is now easier due to VIMFEATURES, VIMX and VIMGUI variables. EXTRA_OECONF variables were generated by running vim configure script on BUG 2.0 device. Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Diffstat (limited to 'recipes/vim/vim_7.2.bb')
-rw-r--r--recipes/vim/vim_7.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/vim/vim_7.2.bb b/recipes/vim/vim_7.2.bb
new file mode 100644
index 0000000000..37bdfb8809
--- /dev/null
+++ b/recipes/vim/vim_7.2.bb
@@ -0,0 +1,27 @@
+VIMVER = "72"
+
+# vim-tiny sets that too
+VIMFEATURES ?= "big"
+
+# GUI type - gvim recipe sets "gtk2"
+VIMGUI ?= "none"
+
+# gvim recipes uses "--with-x"
+VIMX ?= "--without-x"
+
+require vim.inc
+
+PR = "${INC_PR}.0"
+
+# 001-394.diff contains 394 patches fetched from upstream
+SRC_URI += "file://001-394.diff"
+
+# we need to apply patches in other dir then ${S}
+do_applypatch() {
+ cd ${WORKDIR}/vim${VIMVER}
+ patch -p1 <${WORKDIR}/001-394.diff
+}
+
+addtask applypatch after do_unpack before do_patch
+
+RCONFLICTS_${PN} = "gvim vim-tiny"