aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/vincent
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/vincent
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/vincent')
-rw-r--r--recipes/vincent/vincent_svn.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/vincent/vincent_svn.bb b/recipes/vincent/vincent_svn.bb
new file mode 100644
index 0000000000..f872f727be
--- /dev/null
+++ b/recipes/vincent/vincent_svn.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Vincent OpenGL-ES library "
+HOMEPAGE = "http://sourceforge.net/projects/ogl-es/"
+LICENSE = "BSD"
+
+PV = "0.0+svn${SRCDATE}"
+PR = "r0"
+
+SRC_URI = "svn://ogl-es.svn.sourceforge.net/svnroot/ogl-es/branches;module=linux_nokia_770;proto=https"
+
+S = "${WORKDIR}/linux_nokia_770/ogles/projects/linux-x11"
+
+TOP = "${WORKDIR}/linux_nokia_770/ogles/"
+
+inherit autotools pkgconfig
+
+# PACKAGES = ${PN}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/GLES
+
+ install -m 0644 ${TOP}/include/ug.h ${STAGING_INCDIR}
+ install -m 0644 ${TOP}/include/GLES/* ${STAGING_INCDIR}/GLES/
+
+ oe_libinstall -so libvincent ${STAGING_LIBDIR}
+}