aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/visiscript/visiscript_0.4.3.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/visiscript/visiscript_0.4.3.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/visiscript/visiscript_0.4.3.bb')
-rw-r--r--recipes/visiscript/visiscript_0.4.3.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/visiscript/visiscript_0.4.3.bb b/recipes/visiscript/visiscript_0.4.3.bb
new file mode 100644
index 0000000000..c50da04249
--- /dev/null
+++ b/recipes/visiscript/visiscript_0.4.3.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "VisiScript is a simple graphical frontend for \
+scripting languages like minscript, Python,Ruby, Perl or others. \
+VisiScript runs on the Qtopia desktop environment of the Zaurus."
+SECTION = "opie/applications"
+DEPENDS = "qscintilla"
+LICENSE = "GPL"
+APPNAME = "visiscript"
+APPTYPE = "binary"
+APPDESKTOP = "${S}"
+
+BROKEN = "1"
+
+SRC_URI = "http://www.mneuroth.de/privat/zaurus/visiscript_src_${PV}.tar.gz \
+ file://qptrlist.h file://qcleanuphandler.h"
+
+S = "${WORKDIR}/visiscript-${PV}"
+
+inherit opie
+
+QMAKE_PROFILES = "zvisiscript.pro"
+PARALLEL_MAKE = ""
+
+EXTRA_QMAKEVARS_POST += "LIBS-=../qscintilla-1.65-gpl-1.6/qt/libqscintilla.a LIBS+=-lqscintilla LIBS+=-ldl"
+export OE_QMAKE_LINK="${CXX}"
+
+do_compile_prepend() {
+ install -m 0644 ${WORKDIR}/*.h ${S}
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/
+ install -m 0644 Visiscript.png ${D}${palmtopdir}/pics
+}
+
+#FIXME: package help and translation