aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/vlan/vlan_1.8.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/vlan/vlan_1.8.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/vlan/vlan_1.8.bb')
-rw-r--r--recipes/vlan/vlan_1.8.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/vlan/vlan_1.8.bb b/recipes/vlan/vlan_1.8.bb
new file mode 100644
index 0000000000..2b8d1d18a8
--- /dev/null
+++ b/recipes/vlan/vlan_1.8.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "802.1q vlan support program"
+RRECOMMENDS = "kernel-module-8021q"
+PR = "r2"
+
+S = "${WORKDIR}/vlan/"
+
+SRC_URI = "http://scry.wanfear.com/~greear/vlan/vlan.1.8.tar.gz \
+ "
+
+inherit base
+
+CCFLAGS = "-g -D_GNU_SOURCE -Wall -I${STAGING_INCDIR}"
+LDLIBS = ""
+
+do_compile() {
+ ${CC} ${CCFLAGS} -c vconfig.c
+ ${CC} ${CCFLAGS} ${LDFLAGS} -o vconfig vconfig.o ${LDLIBS}
+ ${STRIP} vconfig
+}
+
+do_install() {
+ install -d "${D}/usr/sbin"
+ install -m 755 "${S}/vconfig" "${D}/usr/sbin/vconfig"
+}
+