aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/vlc
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-11-30 11:41:30 +1030
committerStefan Schmidt <stefan@buglabs.net>2010-12-02 16:47:17 +0100
commitcb3d42b5032c4e3959d5789022d1552e77a8e571 (patch)
tree37d47e620d2b5e4d4ef676c2ab8e8a0f33d1a01a /recipes/vlc
parent0e224d2c7eeba2d0df846d1627337a61f0283668 (diff)
downloadopenembedded-cb3d42b5032c4e3959d5789022d1552e77a8e571.tar.gz
x264_r2245.bb: Fix build when DISTRO_FEATURES lacks "largefile".
mipsel-oe-linux-uclibc-gcc -march=mips32 -O3 -ffast-math -isystem/mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include -fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os -Wall -I. -fPIC -std=gnu99 -s -fomit-frame-pointer -isystem/mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include -c -o common/mc.o common/mc.c In file included from /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/stdio.h:28:0, from common/osdep.h:29, from common/common.h:76, from common/mc.c:24: /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/features.h:216:5: error: #error It appears you have defined _FILE_OFFSET_BITS=64. Unfortunately, uClibc was built without large file support enabled. Signed-off-by: Graham Gower <graham.gower@gmail.com> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/vlc')
-rw-r--r--recipes/vlc/x264_r2245.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes/vlc/x264_r2245.bb b/recipes/vlc/x264_r2245.bb
index f533bfcc82..e507d32db6 100644
--- a/recipes/vlc/x264_r2245.bb
+++ b/recipes/vlc/x264_r2245.bb
@@ -25,4 +25,8 @@ DEPENDS_x86 = "yasm-native"
EXTRA_OECONF = '--enable-shared ${X264_DISABLE_ASM} --extra-cflags="${X264_ECFLAGS}"'
+do_configure_append() {
+ eval "${@base_contains('DISTRO_FEATURES', 'largefile', '', 'sed -i -e "/_LARGEFILE_SOURCE/d" ${S}/common/osdep.h', d)}"
+ eval "${@base_contains('DISTRO_FEATURES', 'largefile', '', 'sed -i -e "/_FILE_OFFSET_BITS/d" ${S}/common/osdep.h', d)}"
+}