aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/vlc
diff options
context:
space:
mode:
authorLeon Woestenberg <leon@witty.(none)>2009-03-29 00:06:23 +0100
committerLeon Woestenberg <leon@witty.(none)>2009-03-29 00:12:10 +0100
commit0ee45495fb0e27961b5d5cdb5dd192b314908833 (patch)
treeae8b55e9175cdfc4a54f9e9134b0e5b0165ddca4 /recipes/vlc
parente5df9d634bd69a864fe72f521a41d7c7821c7dac (diff)
downloadopenembedded-0ee45495fb0e27961b5d5cdb5dd192b314908833.tar.gz
x264: Enable using yasm-native for x86 machine.
Results in using optimized assembler functions instead of their C equivalent. The x264 encoder has many x86/SSE optimizations, this will increase its performance much.
Diffstat (limited to 'recipes/vlc')
-rw-r--r--recipes/vlc/x264_r2245.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes/vlc/x264_r2245.bb b/recipes/vlc/x264_r2245.bb
index e16e96b8b6..a662b56240 100644
--- a/recipes/vlc/x264_r2245.bb
+++ b/recipes/vlc/x264_r2245.bb
@@ -16,7 +16,8 @@ X264_ECFLAGS = ""
# disable use of assembler written functions
X264_DISABLE_ASM = "--disable-asm"
# use assembler written functions for those archs supporting this
-#X264_DISABLE_ASM_x86 = ""
+X264_DISABLE_ASM_x86 = ""
+DEPENDS_x86 = "yasm-native"
EXTRA_OECONF = '--enable-shared ${X264_DISABLE_ASM} --extra-cflags="${X264_ECFLAGS}"'