aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/vtun
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/vtun
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/vtun')
-rw-r--r--recipes/vtun/files/init46
-rw-r--r--recipes/vtun/vtun-2.6/makefile.in-ldflags.patch11
-rw-r--r--recipes/vtun/vtun_2.6.bb29
3 files changed, 86 insertions, 0 deletions
diff --git a/recipes/vtun/files/init b/recipes/vtun/files/init
new file mode 100644
index 0000000000..2f6ef2f6f0
--- /dev/null
+++ b/recipes/vtun/files/init
@@ -0,0 +1,46 @@
+#! /bin/sh
+
+PATH=/bin:/usr/bin:/sbin:/usr/sbin
+DAEMON=/usr/sbin/vtund
+CONFFILE=/etc/vtund-start.conf
+PIDPREFIX=/var/run/vtund
+
+test -f $DAEMON || exit 0
+
+case "$1" in
+ start)
+ test -d /var/lock/vtund || mkdir -p /var/lock/vtund
+ # find all the defined tunnels
+ egrep -v '^[:space:]*(#.*)?$' $CONFFILE | while true;
+ do
+ read i
+ # no more lines available? done, then.
+ if [ $? != 0 ] ; then break; fi
+ SARGS=`echo $i|sed -ne 's/--server--\s*/-s -P /p'`;
+ if [ -n "$SARGS" ]; then
+ echo "Starting vtund server."
+ start-stop-daemon -S -x $DAEMON -- $SARGS;
+ else
+ # split args into host and rest
+ HOST=`echo $i|cut -f 1 -d " "`;
+ TARGET=`echo $i|cut -f 2 -d " "`;
+ echo "Starting vtund client $HOST to $TARGET.";
+ start-stop-daemon -S -x $DAEMON -- $i;
+ fi
+ done
+ ;;
+ stop)
+ echo "Stopping vtund.";
+ killall $(basename $DAEMON);
+ ;;
+ reload|force-reload|restart)
+ echo "Restarting vtund.";
+ $0 stop || true;
+ $0 start;
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart|reload|force-reload}" >&2
+ exit 1
+ ;;
+esac
+exit 0 \ No newline at end of file
diff --git a/recipes/vtun/vtun-2.6/makefile.in-ldflags.patch b/recipes/vtun/vtun-2.6/makefile.in-ldflags.patch
new file mode 100644
index 0000000000..942e194fc8
--- /dev/null
+++ b/recipes/vtun/vtun-2.6/makefile.in-ldflags.patch
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2004-09-17 11:01:23.885914688 +0200
++++ Makefile.in 2004-09-17 11:01:45.441637720 +0200
+@@ -19,7 +19,7 @@
+ #
+ CC = @CC@
+ CFLAGS = @CFLAGS@ @CPPFLAGS@
+-LDFLAGS = @LIBS@
++LDFLAGS = @LDFLAGS@ @LIBS@
+
+ YACC = @YACC@
+ YACCFLAGS = -d
diff --git a/recipes/vtun/vtun_2.6.bb b/recipes/vtun/vtun_2.6.bb
new file mode 100644
index 0000000000..72dd3a4b9f
--- /dev/null
+++ b/recipes/vtun/vtun_2.6.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Virtual Tunnels over TCP/IP networks with traffic shaping, compression and encryption."
+HOMEPAGE = "http://vtun.sourceforge.net/"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "zlib lzo"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/vtun/vtun-${PV}.tar.gz \
+ file://init \
+ file://makefile.in-ldflags.patch;patch=1;pnum=0"
+
+S = "${WORKDIR}/vtun"
+
+inherit autotools
+
+do_configure() {
+ export BLOWFISH_HDR_DIR=${STAGING_INCDIR}/openssl
+ oe_runconf --with-lzo-headers=${STAGING_INCDIR} --with-ssl-headers=${STAGING_INCDIR}/openssl
+}
+
+do_install() {
+ oe_runmake INSTALL_OWNER="" DESTDIR=${D} install
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/vtund
+ install ${S}/scripts/vtund-start.conf ${D}${sysconfdir}
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/vtund-start.conf ${sysconfdir}/vtund.conf"