aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/w3cam
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/w3cam
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/w3cam')
-rw-r--r--recipes/w3cam/files/staticpaths.patch50
-rw-r--r--recipes/w3cam/w3cam_0.7.2.bb30
2 files changed, 80 insertions, 0 deletions
diff --git a/recipes/w3cam/files/staticpaths.patch b/recipes/w3cam/files/staticpaths.patch
new file mode 100644
index 0000000000..005b60ac88
--- /dev/null
+++ b/recipes/w3cam/files/staticpaths.patch
@@ -0,0 +1,50 @@
+diff -urN w3cam-0.7.2.orig/configure w3cam-0.7.2/configure
+--- w3cam-0.7.2.orig/configure 2001-10-26 07:10:41.000000000 -1000
++++ w3cam-0.7.2/configure 2005-03-20 03:12:24.592016401 -1000
+@@ -771,8 +771,8 @@
+ fi
+
+
+-LDFLAGS="$LDFLAGS -L/usr/local/lib -L/usr/local/X11/lib"
+-CFLAGS="$CFLAGS -I/usr/local/include"
++LDFLAGS="$LDFLAGS"
++CFLAGS="$CFLAGS"
+
+ echo $ac_n "checking for pow in -lm""... $ac_c" 1>&6
+ echo "configure:779: checking for pow in -lm" >&5
+diff -urN w3cam-0.7.2.orig/configure.in w3cam-0.7.2/configure.in
+--- w3cam-0.7.2.orig/configure.in 2001-10-26 07:10:40.000000000 -1000
++++ w3cam-0.7.2/configure.in 2005-03-20 03:12:08.447121775 -1000
+@@ -1,8 +1,8 @@
+ AC_INIT()
+ AC_ISC_POSIX
+
+-LDFLAGS="$LDFLAGS -L/usr/local/lib -L/usr/local/X11/lib"
+-CFLAGS="$CFLAGS -I/usr/local/include"
++LDFLAGS="$LDFLAGS"
++CFLAGS="$CFLAGS"
+
+ AC_CHECK_LIB(m, pow)
+ AC_CHECK_LIB(z, gzopen)
+diff -urN w3cam-0.7.2.orig/w3camd/Makefile.in w3cam-0.7.2/w3camd/Makefile.in
+--- w3cam-0.7.2.orig/w3camd/Makefile.in 2000-05-01 04:59:20.000000000 -1000
++++ w3cam-0.7.2/w3camd/Makefile.in 2005-03-20 02:44:40.623003906 -1000
+@@ -4,7 +4,8 @@
+ prefix=@prefix@
+ sbindir=@prefix@/sbin
+
+-CFLAGS = @CFLAGS@ -I.. -I. -I@prefix@/include -g -DDEBUG -DCAM_PORT=8999 -D_REENTRANT
++CFLAGS = @CFLAGS@ -g -DDEBUG -DCAM_PORT=8999 -D_REENTRANT
++LDFLAGS = @LDFLAGS@
+ CC = @CC@
+
+ default: w3camd
+@@ -15,7 +16,7 @@
+ $(CC) $(CFLAGS) -c $<
+
+ w3camd: $(OBJ)
+- $(CC) -o $@ $(OBJ) -lpthread -ljpeg
++ $(CC) -o $@ $(OBJ) $(LDFLAGS) -lpthread -ljpeg
+
+ install:
+ install w3camd $(sbindir)/
diff --git a/recipes/w3cam/w3cam_0.7.2.bb b/recipes/w3cam/w3cam_0.7.2.bb
new file mode 100644
index 0000000000..73fa406c6f
--- /dev/null
+++ b/recipes/w3cam/w3cam_0.7.2.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "a small and fast cgi program to retrieve images from a V4L device."
+SECTION = "console/network"
+PRIORITY = "optional"
+DEPENDS="jpeg"
+LICENSE = "GPLV2"
+PR = "r0"
+
+SRC_URI = "http://mpx.freeshell.net/w3cam-0.7.2.tar.gz \
+ file://staticpaths.patch;patch=1"
+
+S = "${WORKDIR}/w3cam-0.7.2/"
+
+inherit autotools
+
+LDFLAGS += "-L${STAGING_LIBDIR}"
+CFLAGS += "-L${STAGING_LIBDIR} -I${STAGING_INCDIR}"
+
+EXTRA_OECONF = "--without-x --without-ttf-inc"
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man1
+ install -d ${D}usr/cgi-bin
+ install -m 0755 ${S}w3camd/w3camd ${D}${sbindir}/w3camd
+ install -m 0755 ${S}w3cam.cgi ${D}usr/cgi-bin/w3camd.cgi
+ install -m 0755 ${S}vidcat ${D}${bindir}/vidcat
+ install -m 0644 ${S}vidcat.1 ${D}${mandir}/man1/vidcat.1
+}
+