aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/watchdog/files
diff options
context:
space:
mode:
authorKlaus Kurzmann <mok@fluxnetz.de>2010-09-14 17:54:06 +0200
committerKlaus Kurzmann <mok@fluxnetz.de>2010-09-14 17:55:42 +0200
commita54c780914ea4a12c3e14c0aec406f81b8928b14 (patch)
treee0bf876aab5c701f28682e85c5195c7169021778 /recipes/watchdog/files
parentd374d1c754828f5b983b6b5fbfa60d702719b078 (diff)
downloadopenembedded-a54c780914ea4a12c3e14c0aec406f81b8928b14.tar.gz
watchdog_5.6.bb: add config for the nokia900 machine
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
Diffstat (limited to 'recipes/watchdog/files')
-rw-r--r--recipes/watchdog/files/nokia900/init34
-rw-r--r--recipes/watchdog/files/nokia900/watchdog-omap.conf4
-rw-r--r--recipes/watchdog/files/nokia900/watchdog.conf4
3 files changed, 42 insertions, 0 deletions
diff --git a/recipes/watchdog/files/nokia900/init b/recipes/watchdog/files/nokia900/init
new file mode 100644
index 0000000000..9d07871a63
--- /dev/null
+++ b/recipes/watchdog/files/nokia900/init
@@ -0,0 +1,34 @@
+#!/bin/sh
+DAEMON="/usr/sbin/watchdog"
+NAME="watchdog"
+DESC="watchdog daemon"
+OPTIONS=""
+
+test -f $DAEMON || exit 0
+
+case "$1" in
+ start)
+ echo -n "Starting $DESC: $NAME... "
+ start-stop-daemon -S -x $DAEMON -- $OPTIONS
+ /usr/sbin/wd_keepalive -c /etc/watchdog-omap.conf &
+ echo "done."
+ ;;
+ stop)
+ echo -n "Stopping $DESC: $NAME... "
+ start-stop-daemon -K -x $DAEMON
+ echo "done."
+ ;;
+ restart)
+ echo "Restarting $DESC: $NAME... "
+ $0 stop
+ sleep 1
+ $0 start
+ echo "done."
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart}"
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes/watchdog/files/nokia900/watchdog-omap.conf b/recipes/watchdog/files/nokia900/watchdog-omap.conf
new file mode 100644
index 0000000000..43c5896942
--- /dev/null
+++ b/recipes/watchdog/files/nokia900/watchdog-omap.conf
@@ -0,0 +1,4 @@
+watchdog-device = /dev/watchdog
+interval = 10
+realtime = yes
+priority = 1
diff --git a/recipes/watchdog/files/nokia900/watchdog.conf b/recipes/watchdog/files/nokia900/watchdog.conf
new file mode 100644
index 0000000000..48855ab2e8
--- /dev/null
+++ b/recipes/watchdog/files/nokia900/watchdog.conf
@@ -0,0 +1,4 @@
+watchdog-device = /dev/twl4030_wdt
+interval = 10
+realtime = yes
+priority = 1