aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/webif
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-04-25 09:47:56 +0200
committerKoen Kooi <koen@openembedded.org>2009-04-25 09:47:56 +0200
commita4a7d90f3e9eabb1dd99762391a26c5687b5b80a (patch)
tree75c0241882af9486c65aa3dff4593f52de3acff1 /recipes/webif
parent0f4089d1702a2722d7124511937f96c3e469c516 (diff)
downloadopenembedded-a4a7d90f3e9eabb1dd99762391a26c5687b5b80a.tar.gz
webif: add recipe to build the webif binary and package support files
* still needs tweaking to work with some OE config files
Diffstat (limited to 'recipes/webif')
-rw-r--r--recipes/webif/webif_svn.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/webif/webif_svn.bb b/recipes/webif/webif_svn.bb
new file mode 100644
index 0000000000..8e84293c2d
--- /dev/null
+++ b/recipes/webif/webif_svn.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Web interface"
+LICENSE = "GPL"
+
+PV = "0.0.3+svnr${SRCREV}"
+SRCREV = "4737"
+
+SRC_URI = "svn://x-wrt.googlecode.com/svn;module=trunk;proto=http"
+
+S = "${WORKDIR}/trunk"
+
+do_compile() {
+ cd ${S}/package/webif/
+ ${CC} ${CFLAGS} \
+ -D_METAPACK \
+ -I${STAGING_INCDIR} -include endian.h \
+ ${LDFLAGS} \
+ -o ${S}/webifmetabin \
+ src/int2human/main.c src/int2human/human_readable.c \
+ src/wepkeygen/keygen.c src/wepkeygen/md5.c \
+ src/webif-page.c src/bstrip.c src/webifmetabin.c
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/webifmetabin ${D}${bindir}/
+
+ install -d ${D}${sysconfdir}
+ cp -dPr ${S}/package/webif/files/etc/* ${D}${sysconfdir}/
+
+ install -d ${D}${libdir}
+ cp -dPr ${S}/package/webif/files/usr/lib/* ${D}${libdir}/
+
+ find ${D} -name ".svn" | xargs rm -r || true
+}
+
+
+RDEPENDS_${PN} = "haserl ${IPKG_VARIANT} cron"