aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/webkit
diff options
context:
space:
mode:
authorThomas Zimmermann <ml@vdm-design.de>2010-02-26 11:27:10 +0100
committerThomas Zimmermann <ml@vdm-design.de>2010-02-26 11:38:30 +0100
commit7d7cad11afe5e73ca8972c4e1ac280c4ef49c220 (patch)
treeb6f38ee1782b33bb615ad6e6c7558c0c166c54fc /recipes/webkit
parentc0729ac69d3ea886b68bf875934bc910175b81d8 (diff)
downloadopenembedded-7d7cad11afe5e73ca8972c4e1ac280c4ef49c220.tar.gz
webkit-efl: fix build for evas > 46211
* Evas_Point is defined in Evas.h since EFL_SRCREV 46211 Signed-off-by: Thomas Zimmermann <ml@vdm-design.de>
Diffstat (limited to 'recipes/webkit')
-rw-r--r--recipes/webkit/webkit-efl/fix-build-with-newer-evas.patch26
-rw-r--r--recipes/webkit/webkit-efl_git.bb5
2 files changed, 29 insertions, 2 deletions
diff --git a/recipes/webkit/webkit-efl/fix-build-with-newer-evas.patch b/recipes/webkit/webkit-efl/fix-build-with-newer-evas.patch
new file mode 100644
index 0000000000..6adf0dd24b
--- /dev/null
+++ b/recipes/webkit/webkit-efl/fix-build-with-newer-evas.patch
@@ -0,0 +1,26 @@
+--- git/WebCore/platform/graphics/IntPoint.h 2009-11-16 19:14:36.000000000 +0100
++++ webkit-efl/WebCore/platform/graphics/IntPoint.h 2010-02-26 10:32:48.000000000 +0100
+@@ -33,6 +33,10 @@
+ #include <QDataStream>
+ #endif
+
++#if PLATFORM(EFL)
++#include <Evas.h>
++#endif
++
+ #if PLATFORM(CG)
+ typedef struct CGPoint CGPoint;
+ #endif
+@@ -55,12 +59,6 @@
+ QT_END_NAMESPACE
+ #elif PLATFORM(GTK)
+ typedef struct _GdkPoint GdkPoint;
+-#elif PLATFORM(EFL)
+-typedef struct _Evas_Point Evas_Point;
+-struct _Evas_Point{
+- int x;
+- int y;
+-};
+ #endif
+
+ #if PLATFORM(WX)
diff --git a/recipes/webkit/webkit-efl_git.bb b/recipes/webkit/webkit-efl_git.bb
index b9dda3f5be..0ca70a00fd 100644
--- a/recipes/webkit/webkit-efl_git.bb
+++ b/recipes/webkit/webkit-efl_git.bb
@@ -5,9 +5,10 @@ DEPENDS = "icu flex gst-plugins-base gstreamer jpeg libpng libxml2 pango \
sqlite3 libxslt gperf-native libxt"
PV = "1.1.11+gitr${SRCREV}"
-PR = "r3"
+PR = "r4"
-SRC_URI = "git://gitorious.org/webkit-efl/webkit-efl.git;protocol=git;branch=master"
+SRC_URI = "git://gitorious.org/webkit-efl/webkit-efl.git;protocol=git;branch=master \
+ file://fix-build-with-newer-evas.patch;patch=1"
S = "${WORKDIR}/git"