aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/webkit
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-06-05 13:07:17 +0200
committerKoen Kooi <koen@Powerbook-3.local>2009-06-05 17:48:14 +0200
commit33fdd6399af61722a5283a329e0a6b6e0a4b06a0 (patch)
treef39ead9b82d8a70157f099e25b16fcbc57413d5a /recipes/webkit
parent9e51e58bd4afba5696959e9ffb0822b81bef7241 (diff)
downloadopenembedded-33fdd6399af61722a5283a329e0a6b6e0a4b06a0.tar.gz
webkit: bump SRCREV
Diffstat (limited to 'recipes/webkit')
-rw-r--r--recipes/webkit/webkit-gtk/GNUmakefile.am298
-rw-r--r--recipes/webkit/webkit-gtk/autogen.sh10
-rw-r--r--recipes/webkit/webkit-gtk/configure.ac49
-rw-r--r--recipes/webkit/webkit-gtk/unicode-fixes.diff22
-rw-r--r--recipes/webkit/webkit-gtk_svn.bb6
5 files changed, 230 insertions, 155 deletions
diff --git a/recipes/webkit/webkit-gtk/GNUmakefile.am b/recipes/webkit/webkit-gtk/GNUmakefile.am
index 957078fb12..c87ee49c14 100644
--- a/recipes/webkit/webkit-gtk/GNUmakefile.am
+++ b/recipes/webkit/webkit-gtk/GNUmakefile.am
@@ -36,47 +36,93 @@ GENPROGRAMS := $(top_builddir)/Programs
# Script for creating hash tables
CREATE_HASH_TABLE = $(srcdir)/JavaScriptCore/create_hash_table
+# Programs to run the WebKitGtk unit tests
+GTESTER = gtester
+GTESTER_REPORT = gtester-report
+
# Libraries and support components
bin_PROGRAMS :=
-
noinst_PROGRAMS :=
-
noinst_HEADERS :=
-
lib_LIBRARIES :=
-
IDL_BINDINGS :=
-
TEST_PROGS :=
-
-# Gettext stuff
POFILES :=
-
MOFILES :=
-
-# Global flags to CPP
+javascriptcore_h_api :=
+javascriptcore_cppflags:=
+javascriptcore_sources :=
+javascriptcore_built_sources :=
+javascriptcore_built_nosources :=
+javascriptcore_dist :=
+webcore_cppflags :=
+webcore_sources :=
+webcore_libadd :=
+webcore_built_sources :=
+webcore_built_nosources :=
+webcore_dist :=
+webcoregtk_cppflags :=
+webcoregtk_sources :=
+webkitgtk_h_api :=
+webkitgtk_sources :=
+webkitgtk_cppflags :=
+webkitgtk_built_sources :=
+webkitgtk_built_nosources :=
+webkitgtk_cleanfiles :=
global_cppflags :=
+global_cflags :=
+global_cxxflags :=
+corekit_cflags :=
+corekit_cppflags :=
-global_cppflags += \
- -DWTF_USE_ICU_UNICODE=1
+# CFLAGS/CXXFLAGS used by WebCore and WebKit
+#
+# gtk+.pc already include glib, cairo, freetype and pango CFLAGS
+# Don't include them for now to reduce the noise when compiling
+# $(GLIB_CFLAGS) $(CAIRO_CFLAGS) $(PANGO_CFLAGS) $(FREETYPE_CFLAGS)
+corekit_cflags += \
+ -fno-strict-aliasing \
+ $(COVERAGE_CFLAGS) \
+ $(ENCHANT_CFLAGS) \
+ $(GEOCLUE_CFLAGS) \
+ $(GLIB_CFLAGS) \
+ $(GNOMEKEYRING_CFLAGS) \
+ $(GSTREAMER_CFLAGS) \
+ $(GTK_CFLAGS) \
+ $(HILDON_CFLAGS) \
+ $(LIBSOUP_CFLAGS) \
+ $(LIBXML_CFLAGS) \
+ $(LIBXSLT_CFLAGS) \
+ $(SQLITE3_CFLAGS) \
+ $(UNICODE_CFLAGS) \
+ $(XT_CFLAGS)
+
+# When building webcore/webkit, we want WebCore/config.h and NOT
+# JavaScriptCore/config.h, hence, it's important that WebCore/ should come first
+# before JavaScriptCore in the include path.
+corekit_cppflags += \
+ $(global_cppflags) \
+ $(webcore_cppflags) \
+ $(webcoregtk_cppflags) \
+ $(javascriptcore_cppflags)
+
+if TARGET_X11
+corekit_cppflags += -DXP_UNIX
+endif
# Default compiler flags
-global_cflags := \
+global_cflags += \
-Wall -W -Wcast-align -Wchar-subscripts -Wreturn-type \
-Wformat -Wformat-security -Wno-format-y2k -Wundef \
-Wmissing-format-attribute -Wpointer-arith -Wwrite-strings \
-Wno-unused-parameter -Wno-parentheses \
-fno-exceptions
-global_cxxflags := \
+global_cxxflags += \
+ $(global_cflags) \
$(SYMBOL_VISIBILITY_INLINES) \
-fno-rtti
-if !ENABLE_DEBUG
-global_cflags += \
- $(SYMBOL_VISIBILITY)
-endif
-
# -no-undefined required for building DLLs on Windows
# It breaks the build on other platforms, so we use it conditionally
if OS_WIN32
@@ -96,24 +142,13 @@ noinst_LTLIBRARIES = \
libJavaScriptCore.la \
libWebCore.la
-#
# JavaScriptCore
-javascriptcore_h_api :=
-javascriptcore_cppflags:=
-javascriptcore_sources :=
-javascriptcore_built_sources :=
-javascriptcore_built_nosources :=
-javascriptcore_dist :=
-
javascriptcore_cppflags += \
- -I$(srcdir)/JavaScriptCore \
-I$(srcdir)/JavaScriptCore/ForwardingHeaders \
-I$(srcdir)/JavaScriptCore/parser \
-I$(srcdir)/JavaScriptCore/wtf \
-I$(top_builddir)/DerivedSources
-# The variables above are already included below so no need to touch
-# these variables unless you really have to
nodist_EXTRA_libJavaScriptCore_la_SOURCES = \
$(javascriptcore_built_nosources)
@@ -146,17 +181,7 @@ libJavaScriptCore_la_CPPFLAGS = \
$(global_cppflags) \
$(javascriptcore_cppflags)
-#
# WebCore
-webcore_cppflags :=
-webcore_sources :=
-webcore_libadd :=
-webcore_built_sources :=
-webcore_built_nosources :=
-webcore_dist :=
-webcoregtk_cppflags :=
-webcoregtk_sources :=
-
nodist_EXTRA_libWebCore_la_SOURCES = \
$(webcore_built_nosources)
@@ -169,65 +194,16 @@ libWebCore_la_SOURCES = \
libWebCore_la_CXXFLAGS = \
$(global_cxxflags) \
- $(libWebCore_la_CFLAGS)
+ $(corekit_cflags)
libWebCore_la_CFLAGS = \
- -fno-strict-aliasing \
$(global_cflags) \
- $(GLIB_CFLAGS) \
- $(UNICODE_CFLAGS) \
- $(LIBXML_CFLAGS) \
- $(CAIRO_CFLAGS) \
- $(PANGO_CFLAGS) \
- $(GTK_CFLAGS) \
- $(XT_CFLAGS) \
- $(LIBSOUP_CFLAGS) \
- $(FREETYPE_CFLAGS) \
- $(SQLITE3_CFLAGS) \
- $(GSTREAMER_CFLAGS) \
- $(LIBXSLT_CFLAGS) \
- $(COVERAGE_CFLAGS) \
- $(HILDON_CFLAGS) \
- $(ENCHANT_CFLAGS) \
- $(GEOCLUE_CFLAGS)
+ $(corekit_cflags)
libWebCore_la_CPPFLAGS = \
- $(global_cppflags) \
- $(webcore_cppflags) \
- $(javascriptcore_cppflags) \
- $(webcoregtk_cppflags) \
- $(HILDON_CPPFLAGS)
-
-libWebCore_la_LIBADD = \
- libJavaScriptCore.la \
- libWebCoreJS.la \
- $(webcore_libadd) \
- $(GLIB_LIBS) \
- $(LIBXML_LIBS) \
- $(CAIRO_LIBS) \
- $(PANGO_LIBS) \
- $(GTK_LIBS) \
- $(XT_LIBS) \
- $(LIBSOUP_LIBS) \
- $(FREETYPE_LIBS) \
- $(UNICODE_LIBS) \
- $(SQLITE3_LIBS) \
- $(GSTREAMER_LIBS) \
- $(LIBXSLT_LIBS) \
- $(HILDON_LIBS) \
- $(JPEG_LIBS) \
- $(PNG_LIBS) \
- $(GEOCLUE_LIBS) \
- -lpthread
+ $(corekit_cppflags)
# WebKit
-webkitgtk_h_api :=
-webkitgtk_sources :=
-webkitgtk_cppflags :=
-webkitgtk_built_sources :=
-webkitgtk_built_nosources :=
-webkitgtk_cleanfiles :=
-
nodist_libwebkit_1_0_la_SOURCES = \
$(webkitgtk_built_sources)
@@ -240,46 +216,83 @@ libwebkit_1_0_la_SOURCES = \
$(webkitgtk_sources)
libwebkit_1_0_la_CXXFLAGS = \
- $(libWebCore_la_CXXFLAGS)
+ $(global_cxxflags) \
+ $(corekit_cflags)
libwebkit_1_0_la_CFLAGS = \
- $(libWebCore_la_CFLAGS) \
- $(GNOMEKEYRING_CFLAGS)
+ $(global_cflags) \
+ $(corekit_cflags)
libwebkit_1_0_la_CPPFLAGS = \
- $(libWebCore_la_CPPFLAGS) \
- $(webkitgtk_cppflags)
+ $(corekit_cppflags) \
+ $(webkitgtk_cppflags) \
+ $(HILDON_CPPFLAGS)
libwebkit_1_0_la_LDFLAGS = \
- $(COVERAGE_LDFLAGS) \
-version-info @LIBWEBKITGTK_VERSION@ \
$(version_script) \
$(no_undefined)
libwebkit_1_0_la_LIBADD = \
+ -lpthread \
+ libJavaScriptCore.la \
libWebCore.la \
+ libWebCoreJS.la \
+ $(webcore_ldflags) \
+ $(CAIRO_LIBS) \
+ $(COVERAGE_LDFLAGS) \
$(ENCHANT_LIBS) \
- $(GNOMEKEYRING_LIBS)
+ $(FREETYPE_LIBS) \
+ $(GEOCLUE_LIBS) \
+ $(GLIB_LIBS) \
+ $(GNOMEKEYRING_LIBS) \
+ $(GSTREAMER_LIBS) \
+ $(GTK_LIBS) \
+ $(HILDON_LIBS) \
+ $(JPEG_LIBS) \
+ $(LIBSOUP_LIBS) \
+ $(LIBXML_LIBS) \
+ $(LIBXSLT_LIBS) \
+ $(PANGO_LIBS) \
+ $(PNG_LIBS) \
+ $(SQLITE3_LIBS) \
+ $(UNICODE_LIBS) \
+ $(XT_LIBS)
#
# Extra checks and flags
global_cppflags += \
-DBUILDING_CAIRO__=1 \
-DBUILDING_GTK__=1 \
- -DWTF_CHANGES \
- -DPACKAGE_LOCALE_DIR=\"$(localedir)\"
+ -DWTF_CHANGES
-if !ENABLE_FAST_MALLOC
+if USE_ICU_UNICODE
global_cppflags += \
- -DUSE_SYSTEM_MALLOC
+ -DWTF_USE_ICU_UNICODE=1
endif
-if TARGET_X11
-global_cppflags += -DXP_UNIX
+if USE_GLIB_UNICODE
+# https://bugs.webkit.org/show_bug.cgi?id=15914
+# In patch 1/4 we are compiling a hybrid version of GLib WTF Unicode
+# functionality mixed with ICU-based text codecs and TextBreakIterator.
+# For the transition, introducing an interim HYBRID macro.
+# This macro is required for compiling WTF with GLib Unicode backend,
+# but at the same time keeping ICU dependency for codecs and break iterator.
+# It will be removed with patch 3/4 of the above bug.
+global_cppflags += \
+ -DWTF_USE_GLIB_UNICODE=1 \
+ -DWTF_USE_GLIB_ICU_UNICODE_HYBRID=1
+endif
+
+if !ENABLE_FAST_MALLOC
+global_cppflags += \
+ -DUSE_SYSTEM_MALLOC
endif
if !ENABLE_DEBUG
global_cppflags += -DNDEBUG
+global_cflags += $(SYMBOL_VISIBILITY)
+
else
webcoregtk_cppflags += \
-DG_DISABLE_DEPRECATED \
@@ -293,24 +306,12 @@ webcoregtk_cppflags += \
# -DGTK_MULTIHEAD_SAFE
endif
-if !ENABLE_DATABASE
-global_cppflags += -DENABLE_DATABASE=0
-endif
-
-if !ENABLE_ICONDATABASE
-global_cppflags += -DENABLE_ICONDATABASE=0
-endif
-
if ENABLE_COVERAGE
global_cppflags += \
-DGCC_GENERATE_TEST_COVERAGE_FILES \
-DGCC_INSTRUMENT_PROGRAM_FLOW_ARCS
endif
-if ENABLE_VIDEO
-webcore_libadd += -lgstinterfaces-0.10 -lgstvideo-0.10
-endif
-
webkitgtk_h_api += \
WebKit/gtk/webkit/webkit.h \
WebKit/gtk/webkit/webkitdefines.h \
@@ -369,15 +370,25 @@ webkitgtk_sources += \
webkitgtk_cppflags += \
-DBUILDING_WEBKIT \
+ -DPACKAGE_LOCALE_DIR=\"$(localedir)\" \
+ -DDATA_DIR=\"${datadir}\" \
-I$(srcdir)/WebKit/gtk \
-I$(srcdir)/WebKit/gtk/WebCoreSupport \
-I$(srcdir)/WebKit/gtk/webkit \
-I$(top_builddir)/WebKit/gtk/webkit
+if USE_GNOMEKEYRING
+webkitgtk_cppflags += \
+ -DWTF_USE_GNOMEKEYRING=1
+endif
+
webkitgtk_cleanfiles += \
+ $(top_builddir)/WebKit/gtk/docs/version.xml \
+ $(top_builddir)/WebKit/gtk/docs/GNUmakefile \
$(top_builddir)/Programs/GtkLauncher \
$(top_builddir)/WebKit/gtk/webkit-1.0.pc \
- $(top_builddir)/WebKit/gtk/webkit/webkitenumtypes.h
+ $(top_builddir)/WebKit/gtk/webkit/webkitenumtypes.h \
+ $(top_builddir)/WebKit/gtk/webkit/webkitversion.h
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = WebKit/gtk/webkit-1.0.pc
@@ -479,9 +490,9 @@ dist_resources_DATA = \
# END WEBKIT GTK+
# Files that will be cleaned
-MAINTAINERCLEANFILES := $(stamp_files) $(BUILT_SOURCES) doltcompile doltlibtool WebKit/gtk/docs/version.xml WebKit/gtk/docs/GNUmakefile
-DISTCLEANFILES := $(stamp_files) $(BUILT_SOURCES) doltcompile doltlibtool WebKit/gtk/docs/version.xml WebKit/gtk/docs/GNUmakefile
-CLEANFILES := $(stamp_files) $(BUILT_SOURCES) WebKit/gtk/docs/GNUmakefile
+MAINTAINERCLEANFILES := $(stamp_files) $(BUILT_SOURCES) doltcompile doltlibtool
+DISTCLEANFILES := $(stamp_files) $(BUILT_SOURCES) doltcompile doltlibtool
+CLEANFILES := $(stamp_files) $(BUILT_SOURCES)
# Include module makefiles
include JavaScriptCore/GNUmakefile.am
@@ -494,7 +505,6 @@ noinst_PROGRAMS += $(TEST_PROGS)
webkit_tests_cflags = \
-fno-strict-aliasing \
- -O2 \
-I$(srcdir)/JavaScriptCore/ForwardingHeaders \
-I$(srcdir)/WebKit/gtk \
-I$(top_builddir)/WebKit/gtk \
@@ -509,27 +519,47 @@ webkit_tests_ldadd = \
$(GLIB_LIBS) \
$(LIBSOUP_LIBS)
-TEST_PROGS += Programs/unittests/testwebframe \
+webkit_tests_ldflags = \
+ -no-install \
+ -no-fast-install
+
+TEST_PROGS += Programs/unittests/testhttpbackend \
+ Programs/unittests/testwebframe \
Programs/unittests/testwebbackforwardlist \
Programs/unittests/testwebhistoryitem \
- Programs/unittests/testdownload
+ Programs/unittests/testdownload \
+ Programs/unittests/testatk
# Add additional tests here
+Programs_unittests_testhttpbackend_SOURCES = WebKit/gtk/tests/testhttpbackend.c
+Programs_unittests_testhttpbackend_CFLAGS = $(webkit_tests_cflags)
+Programs_unittests_testhttpbackend_LDADD = $(webkit_tests_ldadd)
+Programs_unittests_testhttpbackend_LDFLAGS = $(webkit_tests_ldflags)
+
Programs_unittests_testwebframe_SOURCES = WebKit/gtk/tests/testwebframe.c
Programs_unittests_testwebframe_CFLAGS = $(webkit_tests_cflags)
Programs_unittests_testwebframe_LDADD = $(webkit_tests_ldadd)
+Programs_unittests_testwebframe_LDFLAGS = $(webkit_tests_ldflags)
Programs_unittests_testwebbackforwardlist_SOURCES = WebKit/gtk/tests/testwebbackforwardlist.c
Programs_unittests_testwebbackforwardlist_CFLAGS = $(webkit_tests_cflags)
Programs_unittests_testwebbackforwardlist_LDADD = $(webkit_tests_ldadd)
+Programs_unittests_testwebbackforwardlist_LDFLAGS = $(webkit_tests_ldflags)
Programs_unittests_testwebhistoryitem_SOURCES = WebKit/gtk/tests/testwebhistoryitem.c
Programs_unittests_testwebhistoryitem_CFLAGS = $(webkit_tests_cflags)
Programs_unittests_testwebhistoryitem_LDADD = $(webkit_tests_ldadd)
+Programs_unittests_testwebhistoryitem_LDFLAGS = $(webkit_tests_ldflags)
Programs_unittests_testdownload_SOURCES = WebKit/gtk/tests/testdownload.c
Programs_unittests_testdownload_CFLAGS = $(webkit_tests_cflags)
Programs_unittests_testdownload_LDADD = $(webkit_tests_ldadd)
+Programs_unittests_testdownload_LDFLAGS = $(webkit_tests_ldflags)
+
+Programs_unittests_testatk_SOURCES = WebKit/gtk/tests/testatk.c
+Programs_unittests_testatk_CFLAGS = $(webkit_tests_cflags)
+Programs_unittests_testatk_LDADD = $(webkit_tests_ldadd)
+Programs_unittests_testatk_LDFLAGS = $(webkit_tests_ldflags)
# Autogenerated sources
BUILT_SOURCES := \
@@ -576,3 +606,23 @@ install-data-local: po-install-data-local
installdirs-data-local: po-installdirs-data-local
uninstall-local: po-uninstall-local
+
+# Run all tests in cwd
+# FIXME: we should run this under xvfb
+test: $(TEST_PROGS)
+ $(GTESTER) --verbose $(TEST_PROGS);
+
+# test-report: run tests in cwd and generate report
+# full-report: run tests in cwd with -m perf and -m slow and generate report
+# perf-report: run tests in cwd with -m perf and generate report
+test-report full-report perf-report: $(TEST_PROGS)
+ @ case $@ in \
+ test-report) test_options="-k";; \
+ full-report) test_options="-k -m=perf";; \
+ perf-report) test_options="-k -m=perf -m=slow";; \
+ esac ; \
+ $(GTESTER) --verbose $$test_options -o test-report.xml $(TEST_PROGS); \
+ $(GTESTER_REPORT) test-report.xml > test-report.html ;
+
+.PHONY: test test-report perf-report full-report
+check-local: test
diff --git a/recipes/webkit/webkit-gtk/autogen.sh b/recipes/webkit/webkit-gtk/autogen.sh
index d32b73eb61..97beb209d2 100644
--- a/recipes/webkit/webkit-gtk/autogen.sh
+++ b/recipes/webkit/webkit-gtk/autogen.sh
@@ -15,14 +15,6 @@ AUTOMAKE_FLAGS="--foreign --add-missing"
DIE=0
-(gtkdocize --version) < /dev/null > /dev/null 2>&1 || {
- echo
- echo "You must have gtkdocize installed to compile $PROJECT."
- echo "Install the appropriate package for your distribution,"
- echo "or get the source tarball at http://ftp.gnome.org/pub/GNOME/sources/gtk-doc/"
- DIE=1
-}
-
(autoconf --version) < /dev/null > /dev/null 2>&1 || {
echo
echo "You must have autoconf installed to compile $PROJECT."
@@ -59,7 +51,7 @@ rm -rf $top_srcdir/autom4te.cache
touch README INSTALL
-gtkdocize $GTKDOCIZE_FLAGS || exit $?
+gtkdocize $GTKDOCIZE_FLAGS > /dev/null 2>&1 || echo "Warning: not running gtk-docize."
aclocal $ACLOCAL_FLAGS || exit $?
$LIBTOOLIZE $LIBTOOLIZE_FLAGS || exit $?
autoheader || exit $?
diff --git a/recipes/webkit/webkit-gtk/configure.ac b/recipes/webkit/webkit-gtk/configure.ac
index ffd36afd0d..2ee8210695 100644
--- a/recipes/webkit/webkit-gtk/configure.ac
+++ b/recipes/webkit/webkit-gtk/configure.ac
@@ -2,7 +2,7 @@ AC_PREREQ(2.59)
m4_define([webkit_major_version], [1])
m4_define([webkit_minor_version], [1])
-m4_define([webkit_micro_version], [7])
+m4_define([webkit_micro_version], [8])
AC_INIT([WebKit],[webkit_major_version.webkit_minor_version.webkit_micro_version],[http://bugs.webkit.org/])
@@ -11,7 +11,7 @@ AC_CONFIG_AUX_DIR([autotools])
AC_SUBST(ACLOCAL_AMFLAGS, "-I autotools")
AC_CONFIG_HEADERS([autotoolsconfig.h])
-AC_CANONICAL_SYSTEM
+AC_CANONICAL_HOST
WEBKIT_MAJOR_VERSION=webkit_major_version
WEBKIT_MINOR_VERSION=webkit_minor_version
@@ -24,7 +24,7 @@ AC_CONFIG_SRCDIR([WebCore/config.h])
dnl # Libtool library version, not to confuse with API version
dnl # see http://www.gnu.org/software/libtool/manual/html_node/Libtool-versioning.html#Libtool-versioning
-LIBWEBKITGTK_VERSION=7:0:5
+LIBWEBKITGTK_VERSION=8:0:6
AC_SUBST([LIBWEBKITGTK_VERSION])
AM_INIT_AUTOMAKE([foreign subdir-objects tar-ustar])
@@ -404,7 +404,6 @@ AC_MSG_RESULT([$enable_web_workers])
# turn off svg features if --disable-svg is requested
if test "$enable_svg" = "no"; then
enable_svg_animation=no
- enable_svg_filters=no
enable_svg_fonts=no
enable_svg_foreign_object=no
enable_svg_as_image=no
@@ -419,13 +418,13 @@ AC_ARG_ENABLE(svg_animation,
[],[enable_svg_animation="yes"])
AC_MSG_RESULT([$enable_svg_animation])
-# check whether to enable support for SVG filters
-AC_MSG_CHECKING([whether to enable support for SVG filters])
-AC_ARG_ENABLE(svg_filters,
- AC_HELP_STRING([--enable-svg-filters],
- [enable support for SVG filters (experimental) [default=no]]),
- [],[enable_svg_filters="no"])
-AC_MSG_RESULT([$enable_svg_filters])
+# check whether to enable support for filters
+AC_MSG_CHECKING([whether to enable support for filters])
+AC_ARG_ENABLE(filters,
+ AC_HELP_STRING([--enable-filters],
+ [enable support for filters (experimental) [default=no]]),
+ [],[enable_filters="no"])
+AC_MSG_RESULT([$enable_filters])
# check whether to enable support for SVG fonts
AC_MSG_CHECKING([whether to enable support for SVG fonts])
@@ -461,7 +460,6 @@ AC_MSG_RESULT([$enable_svg_use_element])
# check for SVG features, enabling SVG if necessary
if test "$enable_svg_animation" = "yes" || \
- test "$enable_svg_filters" = "yes" || \
test "$enable_svg_fonts" = "yes" || \
test "$enable_svg_foreign_object" = "yes" || \
test "$enable_svg_as_image" = "yes" || \
@@ -495,14 +493,15 @@ AC_ARG_ENABLE([jit],
[Enable JIT compilation default=yes]),
[],[enable_jit="yes"])
if test "$enable_jit" = "yes"; then
- case "$target_cpu" in
+ case "$host_cpu" in
i*86|x86_64)
AC_DEFINE([ENABLE_JIT], [1], [Define to enable JIT])
- AC_DEFINE([ENABLE_WREC], [1], [Define to enable WREC])
+ AC_DEFINE([ENABLE_YARR], [1], [Define to enable YARR])
+ AC_DEFINE([ENABLE_YARR_JIT], [1], [Define to enable YARR JIT])
AC_DEFINE([ENABLE_JIT_OPTIMIZE_CALL], [1], [Define to enable optimizing calls])
AC_DEFINE([ENABLE_JIT_OPTIMIZE_PROPERTY_ACCESS], [1], [Define to enable optimized property access])
AC_DEFINE([ENABLE_JIT_OPTIMIZE_ARITHMETIC], [1], [Define to enable optimized arithmetic])
- case "$target_cpu" in
+ case "$host_cpu" in
i*86)
AC_DEFINE([WTF_USE_JIT_STUB_ARGUMENT_VA_LIST], [1], [Use stub va_list])
;;
@@ -513,7 +512,7 @@ if test "$enable_jit" = "yes"; then
esac
;;
*)
- enable_jit="no (CPU '$target_cpu' not supported)"
+ enable_jit="no (CPU '$host_cpu' not supported)"
;;
esac
fi
@@ -606,7 +605,8 @@ if test "$enable_video" = "yes"; then
PKG_CHECK_MODULES([GSTREAMER],
[gstreamer-0.10 >= $GSTREAMER_REQUIRED_VERSION
gstreamer-base-0.10,
- gstreamer-plugins-base-0.10])
+ gstreamer-plugins-base-0.10,
+ gstreamer-video-0.10])
AC_SUBST([GSTREAMER_CFLAGS])
AC_SUBST([GSTREAMER_LIBS])
fi
@@ -639,6 +639,10 @@ AM_CONDITIONAL([TARGET_WIN32], [test "$with_target" = "win32"])
AM_CONDITIONAL([TARGET_QUARTZ], [test "$with_target" = "quartz"])
AM_CONDITIONAL([TARGET_DIRECTFB], [test "$with_target" = "directfb"])
+# Unicode backend conditionals
+AM_CONDITIONAL([USE_ICU_UNICODE], [test "$with_unicode_backend" = "icu"])
+AM_CONDITIONAL([USE_GLIB_UNICODE], [test "$with_unicode_backend" = "glib"])
+
# Auth backend conditionals
AM_CONDITIONAL([USE_GNOMEKEYRING], [test "$enable_gnomekeyring" = "yes"])
@@ -658,11 +662,11 @@ AM_CONDITIONAL([ENABLE_DATABASE],[test "$enable_database" = "yes"])
AM_CONDITIONAL([ENABLE_ICONDATABASE],[test "$enable_icon_database" = "yes"])
AM_CONDITIONAL([ENABLE_XPATH],[test "$enable_xpath" = "yes"])
AM_CONDITIONAL([ENABLE_XSLT],[test "$enable_xslt" = "yes"])
+AM_CONDITIONAL([ENABLE_FILTERS],[test "$enable_filters" = "yes"])
AM_CONDITIONAL([ENABLE_GEOLOCATION], [test "$enable_geolocation" = "yes"])
AM_CONDITIONAL([ENABLE_VIDEO],[test "$enable_video" = "yes"])
AM_CONDITIONAL([ENABLE_SVG],[test "$enable_svg" = "yes"])
AM_CONDITIONAL([ENABLE_SVG_ANIMATION],[test "$enable_svg_animation" = "yes"])
-AM_CONDITIONAL([ENABLE_SVG_FILTERS],[test "$enable_svg_filters" = "yes"])
AM_CONDITIONAL([ENABLE_SVG_FONTS],[test "$enable_svg_fonts" = "yes"])
AM_CONDITIONAL([ENABLE_SVG_FOREIGN_OBJECT],[test "$enable_svg_foreign_object" = "yes"])
AM_CONDITIONAL([ENABLE_SVG_AS_IMAGE],[test "$enable_svg_as_image" = "yes"])
@@ -692,13 +696,14 @@ Build configuration:
Enable debugging (slow) : $enable_debug
Enable GCC build optimization : $enable_optimizations
Code coverage support : $enable_coverage
- Unicode backend : $unicode_backend
+ Unicode backend : $with_unicode_backend
Font backend : $with_font_backend
Optimized memory allocator : $enable_fast_malloc
Features:
3D Transforms : $enable_3D_transforms
JIT compilation : $enable_jit
Dashboard support : $enable_dashboard_support
+ Filters support : $enable_filters
Geolocation support : $enable_geolocation
GNOME Keyring support : $enable_gnomekeyring
JavaScript debugger/profiler support : $enable_javascript_debugger
@@ -710,7 +715,6 @@ Features:
Icon database support : $enable_icon_database
SVG support : $enable_svg
SVG animation support : $enable_svg_animation
- SVG filters support : $enable_svg_filters
SVG fonts support : $enable_svg_fonts
SVG foreign object support : $enable_svg_foreign_object
SVG as image support : $enable_svg_as_image
@@ -723,3 +727,8 @@ GTK+ configuration:
GDK target : $with_target
Hildon UI extensions : $with_hildon
"
+if test "$with_unicode_backend" = "glib"; then
+ echo " >> WARNING: the glib-based unicode backend is slow and incomplete <<"
+ echo
+ echo
+fi
diff --git a/recipes/webkit/webkit-gtk/unicode-fixes.diff b/recipes/webkit/webkit-gtk/unicode-fixes.diff
new file mode 100644
index 0000000000..03dbc0f3d1
--- /dev/null
+++ b/recipes/webkit/webkit-gtk/unicode-fixes.diff
@@ -0,0 +1,22 @@
+Index: wtf/unicode/glib/UnicodeMacrosFromICU.h
+===================================================================
+--- a/JavaScriptCore/wtf/unicode/glib/UnicodeMacrosFromICU.h (revision 44458)
++++ b/JavaScriptCore/wtf/unicode/glib/UnicodeMacrosFromICU.h (working copy)
+@@ -41,6 +41,17 @@
+ #define U16_IS_SURROGATE(c) U_IS_SURROGATE(c)
+ #define U16_IS_SURROGATE_LEAD(c) (((c)&0x400)==0)
+
++#define U16_PREV(s, start, i, c) { \
++ (c)=(s)[--(i)]; \
++ if(U16_IS_TRAIL(c)) { \
++ uint16_t __c2; \
++ if((i)>(start) && U16_IS_LEAD(__c2=(s)[(i)-1])) { \
++ --(i); \
++ (c)=U16_GET_SUPPLEMENTARY(__c2, (c)); \
++ } \
++ } \
++}
++
+ #define U16_NEXT(s, i, length, c) { \
+ (c)=(s)[(i)++]; \
+ if(U16_IS_LEAD(c)) { \
diff --git a/recipes/webkit/webkit-gtk_svn.bb b/recipes/webkit/webkit-gtk_svn.bb
index ec76d23ceb..db0838630c 100644
--- a/recipes/webkit/webkit-gtk_svn.bb
+++ b/recipes/webkit/webkit-gtk_svn.bb
@@ -20,6 +20,7 @@ SRC_URI = "\
file://symbols.filter \
file://GNUmakefile.am \
file://gtk-doc.make \
+ file://unicode-fixes.diff;patch=1;maxrev=44459 \
"
S = "${WORKDIR}/"
@@ -33,7 +34,8 @@ EXTRA_OECONF = "\
--enable-svg \
--enable-icon-database=yes \
--with-http-backend=soup \
- "
+# --with-unicode-backend=glib \
+"
EXTRA_AUTORECONF = " -I autotools "
@@ -67,5 +69,5 @@ FILES_${PN}launcher = "${bindir}/GtkLauncher"
FILES_${PN}launcher-dbg = "${bindir}/.debug/GtkLauncher"
FILES_libjavascriptcore = "${libdir}/libJavaScriptCore.so.*"
FILES_${PN}-webinspector = "${datadir}/webkit-1.0/webinspector/"
-FILES_${PN} += "${datadir}/webkit-1.0/resources/error.html"
+FILES_${PN} += "${datadir}/webkit-1.0/resources/error.html ${datadir}/webkit-1.0/images"