aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/webkit
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-01-23 10:37:18 +0100
committerKoen Kooi <koen@openembedded.org>2010-01-24 10:11:29 +0100
commit6167a6d60b27474cb6ed3a649390f901879cb940 (patch)
treea35737c4b26ca6da12a72ae455ecfa2542d30b48 /recipes/webkit
parent38c5accb336c53a27cb3fba1d8dd48ec56be4869 (diff)
downloadopenembedded-6167a6d60b27474cb6ed3a649390f901879cb940.tar.gz
webkit: bump SRCREV to get a fix for servers that always send gzip compressed data
Diffstat (limited to 'recipes/webkit')
-rw-r--r--recipes/webkit/webkit-gtk/GNUmakefile.am39
-rw-r--r--recipes/webkit/webkit-gtk/configure.ac24
-rw-r--r--recipes/webkit/webkit-gtk_svn.bb2
3 files changed, 25 insertions, 40 deletions
diff --git a/recipes/webkit/webkit-gtk/GNUmakefile.am b/recipes/webkit/webkit-gtk/GNUmakefile.am
index 3a0e398aa4..f9ad21c334 100644
--- a/recipes/webkit/webkit-gtk/GNUmakefile.am
+++ b/recipes/webkit/webkit-gtk/GNUmakefile.am
@@ -48,6 +48,7 @@ GTESTER_REPORT = gtester-report
bin_PROGRAMS :=
noinst_PROGRAMS :=
noinst_HEADERS :=
+noinst_LTLIBRARIES :=
lib_LIBRARIES :=
IDL_BINDINGS :=
TEST_PROGS :=
@@ -152,9 +153,8 @@ lib_LTLIBRARIES = \
libwebkit-1.0.la
# Convenience libraries
-noinst_LTLIBRARIES = \
- libJavaScriptCore.la \
- libWebCore.la
+noinst_LTLIBRARIES += \
+ libJavaScriptCore.la
# JavaScriptCore
javascriptcore_cppflags += \
@@ -196,30 +196,12 @@ libJavaScriptCore_la_CPPFLAGS = \
$(global_cppflags) \
$(javascriptcore_cppflags)
-# WebCore
-nodist_EXTRA_libWebCore_la_SOURCES = \
+# WebKit
+nodist_EXTRA_libwebkit_1_0_la_SOURCES = \
$(webcore_built_nosources)
-nodist_libWebCore_la_SOURCES = \
- $(webcore_built_sources)
-
-libWebCore_la_SOURCES = \
- $(webcore_sources) \
- $(webcoregtk_sources)
-
-libWebCore_la_CXXFLAGS = \
- $(global_cxxflags) \
- $(corekit_cflags)
-
-libWebCore_la_CFLAGS = \
- $(global_cflags) \
- $(corekit_cflags)
-
-libWebCore_la_CPPFLAGS = \
- $(corekit_cppflags)
-
-# WebKit
nodist_libwebkit_1_0_la_SOURCES = \
+ $(webcore_built_sources) \
$(webkitgtk_built_sources)
libwebkit_1_0_ladir = $(prefix)/include/webkit-1.0/webkit
@@ -228,6 +210,8 @@ libwebkit_1_0_la_HEADERS = \
WebKit/gtk/webkit/webkitenumtypes.h
libwebkit_1_0_la_SOURCES = \
+ $(webcore_sources) \
+ $(webcoregtk_sources) \
$(webkitgtk_sources)
libwebkit_1_0_la_CXXFLAGS = \
@@ -251,7 +235,6 @@ libwebkit_1_0_la_LDFLAGS = \
libwebkit_1_0_la_LIBADD = \
-lpthread \
libJavaScriptCore.la \
- libWebCore.la \
libWebCoreJS.la \
$(webcore_ldflags) \
$(CAIRO_LIBS) \
@@ -459,11 +442,12 @@ typelibs_DATA += $(JSCORE_GIRSOURCES:.gir=.typelib) $(WEBKIT_GIRSOURCES:.gir=.ty
%.typelib: %.gir $(G_IR_COMPILER)
$(AM_V_GEN)$(G_IR_COMPILER) --includedir $(top_srcdir)/WebKit/gtk $< -o $@
-EXTRA_DIST += $(JSCORE_GIRSOURCES)
CLEANFILES += $(JSCORE_GIRSOURCES) $(WEBKIT_GIRSOURCES) $(typelibs_DATA)
endif
+EXTRA_DIST += WebKit/gtk/JSCore-1.0.gir
+
WEBKIT_MARSHAL = $(GENSOURCES)/webkitmarshal
WEBKIT_MARSHAL_LIST = $(top_srcdir)/WebKit/gtk/webkitmarshal.list
@@ -542,7 +526,8 @@ EXTRA_DIST += \
$(srcdir)/WebKit/gtk/docs/webkitgtk-sections.txt \
$(srcdir)/WebKit/gtk/docs/version.xml.in \
$(srcdir)/WebKit/gtk/po/* \
- $(srcdir)/WebKit/gtk/resources/*
+ $(srcdir)/WebKit/gtk/resources/* \
+ $(srcdir)/WebKit/gtk/tests/resources/*
# extra resource files
resourcesdir = ${datadir}/webkit-1.0/resources
diff --git a/recipes/webkit/webkit-gtk/configure.ac b/recipes/webkit/webkit-gtk/configure.ac
index d2877c0834..3bc8351040 100644
--- a/recipes/webkit/webkit-gtk/configure.ac
+++ b/recipes/webkit/webkit-gtk/configure.ac
@@ -35,7 +35,7 @@ AC_CONFIG_SRCDIR([WebCore/config.h])
dnl # Libtool library version, not to confuse with API version
dnl # see http://www.gnu.org/software/libtool/manual/html_node/Libtool-versioning.html#Libtool-versioning
-LIBWEBKITGTK_VERSION=15:0:13
+LIBWEBKITGTK_VERSION=16:0:14
AC_SUBST([LIBWEBKITGTK_VERSION])
AM_INIT_AUTOMAKE([foreign subdir-objects tar-ustar])
@@ -190,7 +190,7 @@ if test "$with_hildon" = "yes"; then
fi
# minimum base dependencies
-LIBSOUP_REQUIRED_VERSION=2.27.91
+LIBSOUP_REQUIRED_VERSION=2.28.2
CAIRO_REQUIRED_VERSION=1.6
FONTCONFIG_REQUIRED_VERSION=2.4
FREETYPE2_REQUIRED_VERSION=9.0
@@ -291,14 +291,6 @@ AC_ARG_ENABLE(optimizations,
[if test "$enable_debug" = "yes"; then enable_optimizations="no"; else enable_optimizations="yes"; fi])
AC_MSG_RESULT([$enable_optimizations])
-# check whether to enable dashboard support
-AC_MSG_CHECKING([whether to enable Dashboard support])
-AC_ARG_ENABLE(dashboard_support,
- AC_HELP_STRING([--enable-dashboard-support],
- [enable Dashboard support [default=yes]]),
- [],[enable_dashboard_support="yes"])
-AC_MSG_RESULT([$enable_dashboard_support])
-
# check whether to enable 3D transforms support
AC_MSG_CHECKING([whether to enable support for 3D Transforms])
AC_ARG_ENABLE(3D_transforms,
@@ -379,6 +371,14 @@ AC_ARG_ENABLE(video,
[],[enable_video="yes"])
AC_MSG_RESULT([$enable_video])
+# check whether to enable XHTML-MP support
+AC_MSG_CHECKING([whether to enable XHTML-MP support])
+AC_ARG_ENABLE(xhtmlmp,
+ AC_HELP_STRING([--enable-xhtmlmp],
+ [enable support for XHTML-MP [default=no]]),
+ [],[enable_xhtmlmp="no"])
+AC_MSG_RESULT([$enable_xhtmlmp])
+
# check whether to enable XPath support
AC_MSG_CHECKING([whether to enable XPath support])
AC_ARG_ENABLE(xpath,
@@ -742,7 +742,6 @@ AM_CONDITIONAL([USE_PANGO], [test "$with_font_backend" = "pango"])
# WebKit feature conditionals
AM_CONDITIONAL([ENABLE_DEBUG],[test "$enable_debug" = "yes"])
-AM_CONDITIONAL([ENABLE_DASHBOARD_SUPPORT],[test "$enable_dashboard_support" = "yes"])
AM_CONDITIONAL([ENABLE_3D_TRANSFORMS],[test "$enable_3D_transforms" = "yes"])
AM_CONDITIONAL([ENABLE_CHANNEL_MESSAGING],[test "$enable_channel_messaging" = "yes"])
AM_CONDITIONAL([ENABLE_JAVASCRIPT_DEBUGGER],[test "$enable_javascript_debugger" = "yes"])
@@ -752,6 +751,7 @@ AM_CONDITIONAL([ENABLE_DATABASE],[test "$enable_database" = "yes"])
AM_CONDITIONAL([ENABLE_DATALIST],[test "$enable_datalist" = "yes"])
AM_CONDITIONAL([ENABLE_EVENTSOURCE],[test "$enable_eventsource" = "yes"])
AM_CONDITIONAL([ENABLE_ICONDATABASE],[test "$enable_icon_database" = "yes"])
+AM_CONDITIONAL([ENABLE_XHTMLMP],[test "$enable_xhtmlmp" = "yes"])
AM_CONDITIONAL([ENABLE_XPATH],[test "$enable_xpath" = "yes"])
AM_CONDITIONAL([ENABLE_XSLT],[test "$enable_xslt" = "yes"])
AM_CONDITIONAL([ENABLE_FILTERS],[test "$enable_filters" = "yes"])
@@ -803,7 +803,6 @@ Build configuration:
Features:
3D Transforms : $enable_3D_transforms
JIT compilation : $enable_jit
- Dashboard support : $enable_dashboard_support
Filters support : $enable_filters
Geolocation support : $enable_geolocation
JavaScript debugger/profiler support : $enable_javascript_debugger
@@ -825,6 +824,7 @@ Features:
WML support : $enable_wml
Web Sockets support : $enable_web_sockets
Web Workers support : $enable_workers
+ XHTML-MP support : $enable_xhtmlmp
XPATH support : $enable_xpath
XSLT support : $enable_xslt
GTK+ configuration:
diff --git a/recipes/webkit/webkit-gtk_svn.bb b/recipes/webkit/webkit-gtk_svn.bb
index a2d3be83b1..f0b042c938 100644
--- a/recipes/webkit/webkit-gtk_svn.bb
+++ b/recipes/webkit/webkit-gtk_svn.bb
@@ -3,7 +3,7 @@ DEPENDS = "enchant gtk-doc-native gtk-doc gnome-keyring libsoup-2.4 curl icu lib
SRCREV_FORMAT = "webcore-rwebkit"
-SRCREV = "52207"
+SRCREV = "53071"
PV = "1.1.18+svnr${SRCPV}"
SRC_URI = "\