aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wifi-radar/wifi-radar_1.9.6.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/wifi-radar/wifi-radar_1.9.6.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/wifi-radar/wifi-radar_1.9.6.bb')
-rw-r--r--recipes/wifi-radar/wifi-radar_1.9.6.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/wifi-radar/wifi-radar_1.9.6.bb b/recipes/wifi-radar/wifi-radar_1.9.6.bb
new file mode 100644
index 0000000000..57eb9e33fb
--- /dev/null
+++ b/recipes/wifi-radar/wifi-radar_1.9.6.bb
@@ -0,0 +1,37 @@
+SECTION = "x11/network"
+DESCRIPTION="WiFi Radar is a Python/PyGTK2 utility for managing WiFi profiles."
+HOMEPAGE="http://www.bitbuilder.com/wifi_radar/"
+LICENSE = "GPL"
+
+PR = "r2"
+
+PACKAGE_ARCH = "all"
+
+RDEPENDS = "python-core python-pygtk python-re python-io python-pygobject python-pycairo"
+
+SRC_URI="http://wifi-radar.systemimager.org/pub/${PN}-${PV}.tar.bz2 \
+ file://wifi-radar.patch;patch=1 \
+ file://wifi-radar_destktop.patch;patch=1 "
+
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+do_install() {
+ oe_runmake sbindir=${D}${sbindir} initdir=${D}${sysconfdir}/init.d sysconfdir=${D}${sysconfdir} mandir=${D}${mandir} pixmapsdir=${D}${datadir}/pixmaps appsdir=${D}${datadir}/applications install
+
+ #sbindir = /usr/sbin
+ #initdir = /etc/init.d
+ #sysconfdir = /etc/wifi-radar
+ #mandir = /usr/share/man
+ #pixmapsdir = /usr/share/pixmaps
+ #appsdir = /usr/share/applications
+}
+
+pkg_postinst() {
+#!/bin/sh
+# post installation script
+echo "*******************************************"
+echo "Please edit /etc/wifi-radar.conf"
+echo "to match your wifi card name (wlan0, eth0, ...)"
+echo "*******************************************"
+}