aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wireless-tools/wireless-tools
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-04-02 09:24:54 +0000
committerJeremy Lainé <jeremy.laine@m4x.org>2009-04-02 09:24:54 +0000
commitb0f170f9cec728483f282c65c44d48b33ac12f2e (patch)
treecfcfa4c8c9b382a11570ef07cd81b89a6589b3e9 /recipes/wireless-tools/wireless-tools
parentf36e79c8e34e76dcc272bbfb11ebdf160d9d6401 (diff)
downloadopenembedded-b0f170f9cec728483f282c65c44d48b33ac12f2e.tar.gz
wireless-tools: use LDFLAGS (fixes QA error)
Diffstat (limited to 'recipes/wireless-tools/wireless-tools')
-rw-r--r--recipes/wireless-tools/wireless-tools/shared_lib_ldflags.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes/wireless-tools/wireless-tools/shared_lib_ldflags.patch b/recipes/wireless-tools/wireless-tools/shared_lib_ldflags.patch
new file mode 100644
index 0000000000..85abde0ff3
--- /dev/null
+++ b/recipes/wireless-tools/wireless-tools/shared_lib_ldflags.patch
@@ -0,0 +1,12 @@
+diff -urN wireless_tools.29.orig/Makefile wireless_tools.29/Makefile
+--- wireless_tools.29.orig/Makefile 2007-09-17 23:56:46.000000000 +0000
++++ wireless_tools.29/Makefile 2009-04-02 09:22:14.000000000 +0000
+@@ -145,7 +145,7 @@
+
+ # Compilation of the dynamic library
+ $(DYNAMIC): $(OBJS:.o=.so)
+- $(CC) -shared -o $@ -Wl,-soname,$@ $(STRIPFLAGS) $(LIBS) -lc $^
++ $(CC) $(LDFLAGS) -shared -o $@ -Wl,-soname,$@ $(STRIPFLAGS) $(LIBS) -lc $^
+
+ # Compilation of the static library
+ $(STATIC): $(OBJS:.o=.so)