summaryrefslogtreecommitdiffstats
path: root/recipes/wrt/wrt-utils.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/wrt/wrt-utils.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/wrt/wrt-utils.bb')
-rw-r--r--recipes/wrt/wrt-utils.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/recipes/wrt/wrt-utils.bb b/recipes/wrt/wrt-utils.bb
new file mode 100644
index 0000000000..7e02f6830c
--- /dev/null
+++ b/recipes/wrt/wrt-utils.bb
@@ -0,0 +1,50 @@
+DESCRIPTION = "wrt tools"
+SECTION = "base"
+LICENSE = "broadcom"
+SRC_URI = "cvs://anonymous@openwrt.org/openwrt;module=openwrt/package/openwrt;tag=TESTED \
+ http://openwrt.inf.fh-brs.de/mirror/linksys-wlconf.tar.gz \
+ file://nvram-makefile.diff;patch=1;pnum=0 \
+ file://libshared-makefile.diff;patch=1;pnum=0"
+
+S = "${WORKDIR}/openwrt"
+
+inherit module-base
+
+TARGET_CFLAGS =+ "-I${STAGING_KERNEL_DIR}/include"
+
+do_compile() {
+ make -C libshared TARGET_CC="${CC}"
+ make -C libnvram TARGET_CC="${CC}"
+
+ ${CC} ${CFLAGS} -Iinclude -o wlc wlc.c -L./libshared -lshared
+ ${CC} ${CFLAGS} -o jffs2root jffs2root.c
+ ${CC} ${CFLAGS} -o mtd mtd.c
+
+ make -C ../linksys-wlconf TOP=${S} SRCBASE=${S} LDFLAGS="-L${S}/libnvram -lnvram -L${S}/libshared -lshared"
+
+ ${KERNEL_CC} -D__KERNEL__ -fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 \
+ -mno-abicalls -fno-pic -finline-limit=100000 -mabi=32 -march=mips32 -Wa,-32 \
+ -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap -DMODULE -mlong-calls -fno-common \
+ -funsigned-char -nostdinc -iwithprefix include -I. -I${STAGING_KERNEL_DIR}/include \
+ -I${STAGING_KERNEL_DIR}/include/asm/gcc -I./include -c -o wlcompat.o wlcompat.c
+}
+
+do_install() {
+ install -d ${D}/usr/sbin/ ${D}/sbin/ ${D}/${libdir} ${D}/lib/modules/${KERNEL_VERSION}
+ install -m 644 libshared/libshared.so ${D}/${libdir}
+ install -m 755 libnvram/nvram ${D}/usr/sbin/
+ install -m 644 libnvram/libnvram.so ${D}/${libdir}
+
+ install -m 755 wlc ${D}/usr/sbin/
+ install -m 755 jffs2root ${D}/sbin/
+ install -m 755 mtd ${D}/sbin/
+
+ install -m 755 ../linksys-wlconf/wlconf ${D}/usr/sbin/
+ install -m 644 wlcompat.o ${D}/lib/modules/${KERNEL_VERSION}/
+}
+
+PACKAGES = "${PN}-dbg wrt-libs wrt-utils kernel-module-wlcompat"
+FILES_wrt-libs = "/usr/lib"
+FILES_wrt-utils = "/usr/sbin /sbin"
+FILES_kernel-module-wlcompat = "/lib/modules/"
+RDEPENDS_wrt-utils = "wrt-libs"