aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wv
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2009-11-08 18:23:00 +0100
committerPhil Blundell <philb@gnu.org>2009-11-08 17:39:43 +0000
commit2d8e4dfc5684f8787fee879b9a4d95a6868b31dc (patch)
tree622c8ee88dc84a15258cc62f8c671aed1baddcd5 /recipes/wv
parentbab585ab7b53d795d1be404e28d876cb0a70d6a5 (diff)
downloadopenembedded-2d8e4dfc5684f8787fee879b9a4d95a6868b31dc.tar.gz
wv: fix compile problem
base_do_compile() checks if there's Makefile or makefile in source directory, and then it runs oe_runmake. Since there's GNUmakefile generated, change do_compile accordingly. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'recipes/wv')
-rw-r--r--recipes/wv/wv_1.2.0.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes/wv/wv_1.2.0.bb b/recipes/wv/wv_1.2.0.bb
index 7f06f587c4..b3114a5325 100644
--- a/recipes/wv/wv_1.2.0.bb
+++ b/recipes/wv/wv_1.2.0.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Programs for accessing Microsoft Word documents"
HOMEPAGE = "http://wvware.sourceforge.net/"
LICENSE = "GPLv2"
DEPENDS = "libgsf glib-2.0"
-PR = "r3"
+PR = "r4"
SRC_URI = "${SOURCEFORGE_MIRROR}/wvware/wv-${PV}.tar.gz \
file://pkgconfig.patch;patch=1"
@@ -16,3 +16,7 @@ EXTRA_OECONF = ""
do_stage () {
autotools_stage_all
}
+
+do_compile () {
+ oe_runmake -f GNUmakefile
+}